Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: No wireless after updating packages in 12.04

  1. #21
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No wireless after updating packages in 12.04

    rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
    Ouch!!

    Please see: https://bbs.archlinux.org/viewtopic.php?id=136607

    The same error is mentioned and a patch is available. I suspect the patch has made it to the backports modules. Please do:
    Code:
    sudo apt-get install linux-backports-modules-cw-3.3-precise-generic
    Reboot and let us see again:
    Code:
    dmesg | grep rt2
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  2. #22
    Join Date
    Oct 2012
    Beans
    12

    Re: No wireless after updating packages in 12.04

    PHP Code:
    gnat@gnat-nForce-750i-SLI:~$ dmesg grep rt2
    [   18.334834rt2800pci 0000:06:0a.0PCI INT A -> Link[APC3] -> GSI 18 (levellow) -> IRQ 18
    [   18.334841rt2800pci 0000:06:0a.0setting latency timer to 64
    [   18.345372Registered led devicert2800pci-phy0::radio
    [   18.345396Registered led devicert2800pci-phy0::assoc
    [   18.345417Registered led devicert2800pci-phy0::quality
    [   19.100167phy0 -> rt2800pci_mcu_statusError MCU request failedno response from hardware
    gnat
    @gnat-nForce-750i-SLI:~$ 

    That problem seems to have displayed again, and after testing the internet it still seems to be clocking out.

    Also read the thread you linked to and it's one that i have found in the past but found no luck. However I'm sure it was longer last time I viewed it.
    Last edited by scwogit; October 8th, 2012 at 07:10 PM.

  3. #23
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No wireless after updating packages in 12.04

    Please try two things:
    Code:
    sudo modprobe -r rt2800pci
    sudo modprobe rt2800pci nohwcrypt=Y
    Any change in behavior? If not, reload the default:
    Code:
    sudo modprobe -r rt2800pci
    sudo modprobe rt2800pci
    Now try:
    Code:
    sudo iwconfig wlan0 power off
    In this case, 'power' refers to power management. Any change?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #24
    Join Date
    Oct 2012
    Beans
    12

    Re: No wireless after updating packages in 12.04

    Sadly no change although both methods still allow the internet to connect it still chocked out. I also ran the previous thing and it still displays the same message. and for the 'sudo iwconfig wlan0 power off ' I can't see a difference but it's not made it worse, should I just leave that off.

  5. #25
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No wireless after updating packages in 12.04

    Quote Originally Posted by scwogit View Post
    Sadly no change although both methods still allow the internet to connect it still chocked out. I also ran the previous thing and it still displays the same message. and for the 'sudo iwconfig wlan0 power off ' I can't see a difference but it's not made it worse, should I just leave that off.
    I'm afraid to report that I have no further ideas. Sorry.

    Would you care to swap your wireless card and let's see if we can make it work?
    If it helps I have a 'ciso linksys dual-band wireless-n pci adapter'
    If so, after it's in place, run and post:
    Code:
    lspci -nn | grep 0280
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #26
    Join Date
    Oct 2012
    Beans
    12

    Re: No wireless after updating packages in 12.04

    Thanks for your help anyway, I'm thinking of reinstalling ubuntu an seein if that sorts it out. Will let you know how well that goes. sadly my wireless card is the best I've ever had an always has a great signal so I'm not really looking to chuck it out.

  7. #27
    Join Date
    Oct 2012
    Beans
    12

    Re: No wireless after updating packages in 12.04

    I have reinstalled ubuntu onto my computer however this hasn't fixed the problem. Is there anyway of turning the current driver off and using the one that cisco create for windows?

  8. #28
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No wireless after updating packages in 12.04

    Quote Originally Posted by scwogit View Post
    I have reinstalled ubuntu onto my computer however this hasn't fixed the problem. Is there anyway of turning the current driver off and using the one that cisco create for windows?
    If this is a PCI device, aren't you going to physically remove the Realtek and replace it with the Cisco? If so, the Realtek driver simply won't load. Then please post:
    Code:
    lspci -nn | grep 0280
    There may be another way to get the Cisco going aside from the Windows driver.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #29
    Join Date
    Oct 2012
    Beans
    12

    Re: No wireless after updating packages in 12.04

    hey okay so I did some messing around anyway and followed this video to an extent... http://www.youtube.com/watch?v=wchim...ture=endscreen ... however every time I log into my computer I know have to use ...
    Code:
    sudo modprobe rt2800pci
    in terminal to start the internet. Once on the internet I find it to be very laggy and slow but I haven't found any problems with it chocking out which is an improvement I guess.

    Okay so first off I ran the query in your most recent post 'lspci -nn | grep 0280', after that I ran various other things which might happen in the new circumstance. ( I will just mention it still shows that error
    Code:
    rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
    and yesterday I ran the patch mentioned earlier in the 3rd page so that hasn't made any difference to it.

    Code:
    gnat@gnat-nForce-750i-SLI:~$ lspci -nn | grep 0280
    06:0a.0 Network controller [0280]: Ralink corp. RT2800 802.11n PCI [1814:0601]
    gnat@gnat-nForce-750i-SLI:~$ rfkill list all
    0: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    gnat@gnat-nForce-750i-SLI:~$ dmesg | grep rt2
    [ 1064.699631] rt2800pci 0000:06:0a.0: PCI INT A -> Link[APC3] -> GSI 18 (level, low) -> IRQ 18
    [ 1064.699639] rt2800pci 0000:06:0a.0: setting latency timer to 64
    [ 1064.763736] Registered led device: rt2800pci-phy0::radio
    [ 1064.763758] Registered led device: rt2800pci-phy0::assoc
    [ 1064.763795] Registered led device: rt2800pci-phy0::quality
    [ 1064.820199] phy0 -> rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
    gnat@gnat-nForce-750i-SLI:~$ nm-tool
    
    NetworkManager Tool
    
    State: connected (global)
    
    - Device: wlan0  [caroline] ----------------------------------------------------
      Type:              802.11 WiFi
      Driver:            rt2800pci
      State:             connected
      Default:           yes
      HW Address:        68:7F:74:BC:71:EE
    
      Capabilities:
        Speed:           130 Mb/s
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
      Wireless Access Points (* = current AP)
        *caroline:       Infra, 4C:17:EB:B8:A1:0C, Freq 2412 MHz, Rate 54 Mb/s, Strength 62 WPA WPA2
    
      IPv4 Settings:
        Address:         192.168.0.5
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.0.1
    
        DNS:             192.168.0.1
    
    
    - Device: eth0 -----------------------------------------------------------------
      Type:              Wired
      Driver:            forcedeth
      State:             unavailable
      Default:           no
      HW Address:        00:1F:BC:07:A5:F6
    
      Capabilities:
        Carrier Detect:  yes
    
      Wired Properties
        Carrier:         off
    
    
    gnat@gnat-nForce-750i-SLI:~$ dmesg | grep -e rt2 -e wlan
    [ 1064.699631] rt2800pci 0000:06:0a.0: PCI INT A -> Link[APC3] -> GSI 18 (level, low) -> IRQ 18
    [ 1064.699639] rt2800pci 0000:06:0a.0: setting latency timer to 64
    [ 1064.763736] Registered led device: rt2800pci-phy0::radio
    [ 1064.763758] Registered led device: rt2800pci-phy0::assoc
    [ 1064.763795] Registered led device: rt2800pci-phy0::quality
    [ 1064.820199] phy0 -> rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
    [ 1064.844336] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1064.844735] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1071.352118] wlan0: authenticate with 4c:17:eb:b8:a1:0c (try 1)
    [ 1071.353541] wlan0: authenticated
    [ 1071.353675] wlan0: associate with 4c:17:eb:b8:a1:0c (try 1)
    [ 1071.356749] wlan0: RX AssocResp from 4c:17:eb:b8:a1:0c (capab=0x411 status=0 aid=6)
    [ 1071.356753] wlan0: associated
    [ 1071.356757] wlan0: moving STA 4c:17:eb:b8:a1:0c to state 1
    [ 1071.356760] wlan0: moving STA 4c:17:eb:b8:a1:0c to state 2
    [ 1071.364265] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 1071.381506] wlan0: moving STA 4c:17:eb:b8:a1:0c to state 3
    [ 1081.968009] wlan0: no IPv6 routers present
    gnat@gnat-nForce-750i-SLI:~$

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •