Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Log files not working

  1. #11
    Join Date
    Aug 2012
    Location
    Hong Kong
    Beans
    160
    Distro
    Ubuntu Development Release

    Re: Log files not working

    I'm a bit mystified...Why is the tag [Lubuntu]? This is about server, isn't it?

  2. #12
    Join Date
    Jan 2008
    Location
    Manchester UK
    Beans
    13,648
    Distro
    Ubuntu

    Re: Log files not working

    Prefix changed from lubuntu to ubuntu.

  3. #13
    Join Date
    Oct 2011
    Beans
    47

    Re: Log files not working

    Code:
    user@Vault:~$ sudo service rsyslog status
    [sudo] password for user:
    rsyslog start/running, process 758
    user@Vault:~$ lss /etc/ | grep rsys
    -rw-r--r--   1 root root                1.2K 2011-06-17 13:13 rsyslog.conf
    drwxr-xr-x   2 root root                4.0K 2012-04-15 19:26 rsyslog.d
    
    user@Vault:~$ lss /etc/rsyslog.d
    total 16K
    drwxr-xr-x  2 root root 4.0K 2012-04-15 19:26 .
    drwxr-xr-x 93 root root 4.0K 2012-08-16 14:25 ..
    -rw-r--r--  1 root root  311 2011-07-18 18:30 20-ufw.conf
    -rw-r--r--  1 root root 1.6K 2012-04-15 19:26 50-default.conf

  4. #14
    Join Date
    Oct 2011
    Beans
    47

    Re: Log files not working

    Server is still not logging anything. still have a 0 size auth.log file.

    although the rsyslog service is running and it does have .config files....

  5. #15
    Join Date
    Oct 2011
    Beans
    47

    Re: Log files not working

    bump

  6. #16
    Join Date
    Nov 2006
    Location
    Belgium
    Beans
    3,002
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Log files not working

    suggestion :


    temporarily replace your config file with one that only contains something like

    Code:
    *.*   /var/log/test.log
    this should send any logging to the filer mentioned.

    don't forget to restart rsyslog, so it'll read the modified config

    then, force a logging event by running something like
    Code:
    logger -p daemon.info "test"
    this should put an entry in the logfile.


    see what you get, take it from there.

  7. #17
    Join Date
    Nov 2006
    Location
    Belgium
    Beans
    3,002
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Log files not working


  8. #18
    Join Date
    Oct 2008
    Beans
    323
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Log files not working

    Just having the same problem, hope its a bug and not a feature from the producer of the last entry

    neither getting ssh logins nor anacron job or other sudo uses

    sshd_config has
    Code:
    # Logging
    SyslogFacility AUTH
    LogLevel INFO
    last entry:
    Aug 24 00:57:58 PC_NAME sshd[23336]: Did not receive identification string from 123.189.4.148
    i set up sshd to only allow myself to login, maybe the username was too easy to guess. Also the port wasnt standard - at least to the outside.

    taken the sshd off the port-forwading for now but somehow my X11 got screwed up...


    Thinking back i uninstalles some of the unity stuff on this 12.04 machine, using gnome now.
    Logs seem to have been working until shutdown, Not afterwards.
    Last edited by cholericfun; August 24th, 2012 at 05:42 PM.

  9. #19
    Join Date
    Oct 2008
    Beans
    323
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Log files not working

    Hi,
    i didnt have any entries in auth.log and realized the permission have changed somehow (how is rather mysterious to me)
    Code:
    ll auth.log
    was:
    Code:
    -rw-r----- 1 root root 0 Aug 25 11:26 auth.log
    changed to
    Code:
    -rw-r----- 1 syslog root 619 Aug 25 11:26 auth.log
    and immediatly fills up.
    Anyone any ideas if this is indeed the right ownership of the file and why it could have changed (i installed and removed DesktopEnv related things, shouldnt be interfering with rsyslog)

  10. #20
    Join Date
    Sep 2011
    Location
    Behind you!
    Beans
    504
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Log files not working

    Quote Originally Posted by cholericfun View Post
    Anyone any ideas if this is indeed the right ownership of the file and why it could have changed (i installed and removed DesktopEnv related things, shouldnt be interfering with rsyslog)
    I have Ubuntu Server 12.04 LTS (64-bit) installed and this is the permission settings on my file:

    Code:
    -rw-r----- 1 syslog adm 61804 Aug 25 10:34 auth.log
    I verified it is the same on 5 other 12.04 servers I have running as well as 2 servers running 10.04.

    As for ideas on how it changed, my initial thought would be that somebody issued a chown command using the recursive -R incorrectly.

    Take a look by typing ls -l /var/log and see if everything was set to root:root. There should be many files set to syslog:adm and some set to root:utmp and root:root

    LHammonds
    Last edited by LHammonds; August 25th, 2012 at 04:45 PM.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •