Results 1 to 2 of 2

Thread: Depends: lib... but it is not installable

  1. #1
    Join Date
    Jul 2009
    Beans
    16

    Depends: lib... but it is not installable

    Hello everyone,

    I am using ubuntu 12.04 on my laptop.

    Last night I needed to install a package (octovis). When I entered the command

    sudo apt-get install ros-fuerte-octovis

    I get the following error

    Code:
    The following packages have unmet dependencies:
     ros-fuerte-octovis : Depends: libqt4 but it is not installable
                          Depends: libqglviewer-qt4 but it is not installable
    E: Unable to correct problems, you have held broken packages.
    There are some *suggestions* for synaptic package manager, but in 12.04 synaptic package manager does not exist, as far as I know.

    *Here* one suggests to use apt-get with -f argument to fix broken packages. It didn't solve my problem either.

    Can someone guide me to solve this problem?

    Thanks in advance.

  2. #2
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: Depends: lib... but it is not installable

    You can install synaptic without a problem. Just make sure the universe & multiverse repos are enabled in software-sources, then run
    Code:
    sudo apt-get install synaptic
    It's the first addition I make these days as I simply can not function without it. The USC is a poor, and useless substitute for synaptic when attempting to sort out problems of this sort.
    DISTRO: Xubuntu 12.04-64bit --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •