Results 1 to 9 of 9

Thread: Asus eeebox EB1021 with ALC887 soundchip

  1. #1
    Join Date
    Mar 2012
    Beans
    2

    Asus eeebox EB1021 with ALC887 soundchip

    Hi,

    I'm using a Asus Eeebox EB1021 (AMD E450 platform) together with XBMCbuntu.
    This works really like a charm, very smooth ... exept no audio ??

    The audio chip used is : ALC887

    I've already tried the suggested fix on some forums :

    sudo gedit /etc/modprobe.d/alsa-base.conf
    options snd-hda-intel model=generic

    But no luck ...

    Alsamixer shows 2 sound cards:

    1/ HD audio generic : This sound device does not have any controls
    2/ HDA ATI SB: Master / Headphone / Mic / Mic Boost / S/PDIF / SPDIF Default (none are muted)

    Any help ? Seems to be a difficult audio chip ... :confused2:


    Edit: I've tried the following

    options snd-hda-intel model=auto index=1

    and got a sound bar level in the system tray! But no sound?

  2. #2
    Join Date
    Dec 2005
    Location
    Arles, France
    Beans
    184
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus eeebox EB1021 with ALC887 soundchip

    Did you get any further with this? I just installed 11.10 on the same box with the same result.
    If a man speaks his mind in the forest, and no woman hears him, is he still wrong?

  3. #3
    Join Date
    Mar 2012
    Beans
    2

    Re: Asus eeebox EB1021 with ALC887 soundchip

    Nope ... I installed Win8 for the time being

  4. #4
    Join Date
    Dec 2005
    Location
    Arles, France
    Beans
    184
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus eeebox EB1021 with ALC887 soundchip

    Well, there are some other messages around by users with the same on-board audio in different set-ups, some of which seem to have had some success. I'll have another look this evening if I have time and if I get lucky I'll post here.
    If a man speaks his mind in the forest, and no woman hears him, is he still wrong?

  5. #5
    Join Date
    Apr 2012
    Beans
    2

    Re: Asus eeebox EB1021 with ALC887 soundchip

    Same problem here. Had to move to W7-64 bit with my ee.

  6. #6
    Join Date
    May 2010
    Beans
    1

    Re: Asus eeebox EB1021 with ALC887 soundchip

    Upgrade to 12.04 - I got myself a fresh install and headphones are working without additional configuration.

  7. #7
    Join Date
    Dec 2005
    Location
    Arles, France
    Beans
    184
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus eeebox EB1021 with ALC887 soundchip

    Ditto. Upgraded to 12.04 and sound issues are history.
    If a man speaks his mind in the forest, and no woman hears him, is he still wrong?

  8. #8
    Join Date
    Mar 2009
    Beans
    5

    Re: Asus eeebox EB1021 with ALC887 soundchip

    Quote Originally Posted by nikkkko View Post
    Ditto. Upgraded to 12.04 and sound issues are history.
    I have the same computer, eb1021, however there is still a problem with the hdmi sound. I do not use any propretary driver. from time to time, I do not have sound. When it has happend, there is no HDMI
    in the sound settings. In this case I have to restart the computer.
    Has somebody the same problem?

  9. #9
    Join Date
    Oct 2012
    Beans
    1

    Re: Asus eeebox EB1021 with ALC887 soundchip

    Quote Originally Posted by nikkkko View Post
    Ditto. Upgraded to 12.04 and sound issues are history.
    Hi, I am planning on buying ASUS EeeBox PC EB1021. Can you please tell me if 12.04 works smoothly out of the box or were there some issues?

    Does all HW work such as audio through HDMI?

    Have you or anyone tried using the remote and had any success with it?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •