Results 1 to 7 of 7

Thread: Sound clicking on your System76 Laptop? This should fix it.

  1. #1
    Join Date
    May 2007
    Beans
    15
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Exclamation Sound clicking on your System76 Laptop? This should fix it.

    If your System76 machine makes a clicking noise while sound is not playing, don't worry. It turns out it's an issue with power save in the Intel High Definition Audio drivers. What's worse, is that it's an issue that has affected some portable Intel HDA users for years.

    Anyway, according to this post from three years ago, the easiest way to fix it is to simply turn off the power save function.

    It's pretty simple to do:

    To disable it immediately,
    Code:
    echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save
    To disable it on every boot, add this above "exit 0" in /etc/rc.local
    Code:
    echo 0 > /sys/module/snd_hda_intel/parameters/power_save
    Last edited by TheOnlyEnglishRose; August 12th, 2012 at 12:15 AM. Reason: Updated with a safer alternative.

  2. #2
    Join Date
    Oct 2007
    Location
    Aurora, CO
    Beans
    2,563
    Distro
    Ubuntu

    Re: Sound clicking on your System76 Laptop? This should fix it.

    Quote Originally Posted by TheOnlyEnglishRose View Post
    If your System76 machine makes a clicking noise while sound is not playing, don't worry. It turns out it's an issue with power save in the Intel High Definition Audio drivers. What's worse, is that it's an issue that has affected some portable Intel HDA users for years.

    Anyway, according to this post from three years ago, the easiest way to fix it is to simply turn off the power save function.

    It's pretty simple to do:

    To disable it immediately,
    Code:
    sudo su
    echo 0 > /sys/module/snd_hda_intel/parameters/power_save
    exit              # to exit your dangerous root session
    To disable it on every boot, add this above "exit 0" in /etc/rc.local
    Code:
    echo 0 > /sys/module/snd_hda_intel/parameters/power_save
    As a note, it's much better to run that like this:

    Code:
     echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save
    This uses sudo rather than su, which means you don't have a root shell open. This is much less dangerous.
    Ian Santopietro - System76 Technical Support.
    Open a Support Ticket!
    Ask a Sales Question!

  3. #3
    Join Date
    May 2007
    Beans
    15
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: Sound clicking on your System76 Laptop? This should fix it.

    Thanks! OP has been updated.

  4. #4
    Join Date
    Jan 2009
    Beans
    5

    Re: Sound clicking on your System76 Laptop? This should fix it.

    Quote Originally Posted by TheOnlyEnglishRose View Post
    If your System76 machine makes a clicking noise while sound is not playing, don't worry. It turns out it's an issue with power save in the Intel High Definition Audio drivers. What's worse, is that it's an issue that has affected some portable Intel HDA users for years.
    Thanks this solved the problem on my Dell Inspiron 17R with the following audio device:
    Code:
    00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
    - the clicking was only there when running on battery for obvious reasons.

  5. #5
    Join Date
    Oct 2007
    Location
    Buenos Aires, Argentina
    Beans
    99
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Sound clicking on your System76 Laptop? This should fix it.

    Quote Originally Posted by TheOnlyEnglishRose View Post
    It's pretty simple to do:

    To disable it immediately,
    Code:
    echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save
    To disable it on every boot, add this above "exit 0" in /etc/rc.local
    Code:
    echo 0 > /sys/module/snd_hda_intel/parameters/power_save
    Thank you so much!!!

    This solved the problem for my Samsung NP300!
    I have the following audio device:

    Code:
    00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)

    Anyway, how I am affecting my system by disabling this power-saving feature?

    Thank you!

  6. #6
    Join Date
    Jan 2009
    Beans
    5

    Re: Sound clicking on your System76 Laptop? This should fix it.

    Turns out that it was actually Google Chrome causing this problem on my laptop. After a lot of searching I found out that disabling the "Pepperflash" plugin solved the issue, leaving the power-saving feature intact.
    To do this, go to chrome://plugins and disable the plugin with the path /opt/google/chrome/PepperFlash/libpepflashplayer.so. Flash content is not affected as far as I can tell.as content reverts to the Adobe flash player.

    FYI, on my laptop the problem only occured when running on battery after waking up from a sleep state.

  7. #7
    Join Date
    Sep 2006
    Beans
    50

    Re: Sound clicking on your System76 Laptop? This should fix it.

    Wow, Bjornd! This solves a long-term problem I have been having. I run Kubuntu 12.04, and I have noticed that using Chrome to play videos causes the system sound to stammer. Generally it is about one second of audio that repeats 3 times, then goes on.

    Disabling pepperflash seems to have fixed it!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •