Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: Unable to enable wireless on computer

  1. #1
    Join Date
    Aug 2012
    Beans
    16

    Unable to enable wireless on computer

    I can't turn on the wireless hardware button on my computer. When I type in rfkill list, it says the phy0 Wireless Lan is hard blocked (Not soft blocked). Please help ASAP.

  2. #2
    anewguy is offline I Ubuntu, Therefore, I Am
    Join Date
    Jun 2007
    Location
    Sometimes I visit earth
    Beans
    5,440
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unable to enable wireless on computer

    If possible, wait for wildmanne39 to get to you - he's an expert in all of this. In the mean time, you may want to check one of his recent posts, find the script he has, download it and follow the instructions for running it and posting it back here as that will give you a head-start - see post #8 in this thread:

    http://ubuntuforums.org/showthread.php?t=2038977

  3. #3
    Join Date
    Sep 2011
    Location
    Pennsylvania, U.S.A.
    Beans
    2,025
    Distro
    Ubuntu Development Release

    Re: Unable to enable wireless on computer

    Anewguy gives you good advice. In the meantime though you could try this in a terminal - I don't think it'll do any harm.

    "rfkill unblock all"

    There were a few wifi adapters that if disabled in Windows had to be enabled in windows then log out of Windows and log into Linux. I don't know how common that issue was.

  4. #4
    Join Date
    Aug 2012
    Beans
    16

    Re: Unable to enable wireless on computer

    I did up to post #13. I'm still a newb, but I'm pretty sure i uploaded the link of the txt. if not, please tell me how to do it. Also, the rfkill unblock all idea only unblocks the soft block, not the hard blocked. Unfortunately, I do not have my original OS (which I regret.)
    Attached Files Attached Files

  5. #5
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,715
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Unable to enable wireless on computer

    Hi, please do:
    Code:
    gksudo gedit /etc/rc.local
    Add your three lines above exit 0:
    Code:
    modprobe -r ath9k
    rfkill unblock all
    modprobe ath9k
    Reboot
    Make sure your wireless is turned on, you may need to look at the documentation because some computers have to ways to turn wireless on.
    Thanks

  6. #6
    Join Date
    Aug 2012
    Beans
    16

    Re: Unable to enable wireless on computer

    I should probably tell you that my computer has a wireless button, but it does not work while I'm using Linux.

  7. #7
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,715
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Unable to enable wireless on computer

    Hi Newmandude, that is what we are working on, so I need you to play with the wireless on button or key and check with
    Code:
    rfkill list all
    Did you do what I suggested in my last post? What was the outcome?
    Thanks

  8. #8
    Join Date
    Aug 2012
    Beans
    16

    Re: Unable to enable wireless on computer

    i did what you told me, but there was no change. When I type in rfkill list all, it responds,

    Code:
    1: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: yes
    I already know that typing in
    Code:
    rfkill unblock all
    only unblocks the soft block on my computer, but not the hard block. Do I put the three lines you told me right above exit 0, because that's what I did.
    Last edited by Newmandude; August 10th, 2012 at 06:58 PM.

  9. #9
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,715
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Unable to enable wireless on computer

    Hi, yes that is where you add them, please post the contents of:
    Code:
    gksudo gedit /etc/rc.local
    Thanks

  10. #10
    Join Date
    Aug 2012
    Beans
    16

    Re: Unable to enable wireless on computer

    Code:
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    modprobe -r ath9k
    rfkill unblock all
    modprobe ath9k
    exit 0
    these are the contents.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •