Results 1 to 3 of 3

Thread: No graphics acceleration on iMac G5

  1. #1
    Join Date
    Oct 2010
    Beans
    62
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Question No graphics acceleration on iMac G5

    Hello all, it's been a while since I've been here

    I took the plunge and instaleld a clean install of Ubuntu 12.04 on my old PowerPC iMac G5. When I installed it, it couldn't even get to the login screen. I added radeon.agpmode=-1 as a Yaboot argument and now I can get to the desktop with full resolution. Through some twists and turns I have managed to get Wifi, Bluetooth, and sound running perfectly as well. What doesn't work is graphics aceleration.

    When I open the Aditional Drivers icon in the System Settings an alert pops up that says, "Search for additional drivers" and then closes after 1-2 seconds. Nothing pops up after that. I have a 'ATI Radeon X600 XT' according to it's specs sheet from Apple.

    Unity 2D and Gnome Classic w/ no effects works great, but I HTML5 videos play at 1 FPS and 3D games are unusable. I would really like to get acceleration working but I can't figure out how. Any help would be much appreciated
    iMac G5 (Ubuntu 12.04 PPC)

  2. #2
    Join Date
    Oct 2010
    Beans
    62
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: No graphics acceleration on iMac G5

    Bump
    iMac G5 (Ubuntu 12.04 PPC)

  3. #3
    Join Date
    Jul 2007
    Beans
    73
    Distro
    Ubuntu Development Release

    Re: No graphics acceleration on iMac G5

    I have no advice sadly, but if you figure it out please post back. My folks have the same iMac, and will be replacing it soon due to difficulty in finding PPC software in OSX. It's still a perfectly good computer, I'd love to put ubuntu on it and give it to a nephew, assuming all the hardware was supported. No youtube would be a dealbreaker for sure.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •