Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: GMA 500: Screen problem - regression!

  1. #21
    Join Date
    Feb 2007
    Location
    Rome, Italy
    Beans
    2,184

    Re: GMA 500: Screen problem - regression!

    Quote Originally Posted by NormanFLinux View Post
    so it shouldn't be a problem with the Gallium llvmpipe which is supposed to allow default Unity/Cinnamon desktop environments to be run on computers without accelerated graphics video cards.
    Gallium llvmpipe allows to execute Opengl stuff on the CPU instead of the GPU.
    This means that the Atom is doing a giant work.. and it is simply not able to handle it.

    The Gallium llvmpipe driver is a software rasterizer that uses LLVM to do runtime code generation. Shaders, point/line/triangle rasterization and vertex processing are implemented with LLVM IR which is translated to x86 or x86-64 machine code. Also, the driver is multithreaded to take advantage of multiple CPU cores (up to 8 at this time). It's the fastest software rasterizer for Mesa.
    http://www.mesa3d.org/llvmpipe.html

    llvmpipe needs at least a multicore 64bit cpu to work well and a lot of profiling... it is not good for ARM or Atom. take a look at phoronix benchmarks.

  2. #22
    Join Date
    Feb 2007
    Location
    Cameron Park CA USA
    Beans
    4,435
    Distro
    Ubuntu Development Release

    Re: GMA 500: Screen problem - regression!

    Thanks, Luca, for the education. I suppose that GMA500 boxes will not be of much use when 12.10 is released. We'll find that 12.04 will be good for five years. When that period is over my Dell mini-10 will be retired to the wood pile. So be it.
    Regards, frank, at http://yantrayoga.typepad.com/noname/
    Homebuilt Lian-Li PC-Q30X Intel i5-4670K 4.0GHz, SSDs, 16G RAM | Dell laptop E1505n, netbook 10n
    Oracle VBox w/ WinXP Pro running Xara Designer, PaintShopPro, and InDesign CS.

  3. #23
    Join Date
    Mar 2009
    Beans
    341

    Re: GMA 500: Screen problem - regression!

    Quote Originally Posted by lucazade View Post
    Gallium llvmpipe allows to execute Opengl stuff on the CPU instead of the GPU.
    This means that the Atom is doing a giant work.. and it is simply not able to handle it.


    http://www.mesa3d.org/llvmpipe.html

    llvmpipe needs at least a multicore 64bit cpu to work well and a lot of profiling... it is not good for ARM or Atom. take a look at phoronix benchmarks.
    I did a clean install of Ubuntu 12.10 and it runs acceptably except for occasional crashes. The point is llvmpipe WAS provided to run single core computers at a standard of efficiency minus all the fancy graphics. I can live without the fancy rendering. All I care is the computer works. The lower half of the Unity launcher is mushed up.

    Its a beta after all and if Canonical wants to make Unity run on ALL computers - management problems need to be resolved. I run SUSE 12.2 Cinnamon on a dog of VIA C-7 chip network and everything works fine!

    My Dell Mini 10 boots up to a black screen rather than the splash screen but then the desktop loads to the correct screen size. As mentioned its a beta and far more work has to be done to make Unity run acceptably on low-end computers.

  4. #24
    Join Date
    Aug 2007
    Beans
    18

    Re: GMA 500: Screen problem - regression!

    I haven't had any video problems on my gma500 Sony Vaio P since the saga above. But this is with lxde and e17 and xfce. No kde, gnome, and certainly no unity.

    On 3.6.0 mainline nightly currently it's even faster than it's ever been before except for the few times I was able to use a proprietary driver.
    Not fast exactly, but I can watch a YouTube video in a 2 or 3 inch window and it's almost smooth and the audio mostly stays in sync.
    All the normal window/app/desktop activity is fine.

    On the other hand my ath9k wifi has been complete crap on the entire range of 3.5.0 and 3.6.0. Worked fine on 3.2.0. Don't remember if I ever tried anything between 3.2.0 and 3.5.0. That's why I'm posting this from my phone!

    Can't win.

  5. #25
    Join Date
    Aug 2007
    Beans
    18

    Re: GMA 500: Screen problem - regression!

    ...online via usb tether to my phone, which is using the very same wifi that the laptop can't use. Vaguely humiliating. At least I didn't have to boot to Windows or Puppy.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •