Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 32

Thread: Nvidia card/driver and 2560x1440 Monitor

  1. #11
    Join Date
    Apr 2007
    Beans
    38
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Nvidia card/driver and 2560x1440 Monitor

    Help please!

    I'm trying to follow these instructions to run my Catleap Q270 with twinview with my smaller LG monitor. I am able to get each one working individually, but the problem happens when I try to run them with twinview.

    If I connect only the LG, nvidia-settings will let me select from a variety of resolutions for it. However, if I use the xorg.conf file posted above, the LG stops working properly, and the only options are Auto (800x600) and 2560x1440, but the LG is only 1680x1050. I think this line might be the problem:

    Code:
    Modeline "2560x1440" 241.50 2560 2608 2640 2720 1440 1443 1448 1481 +hsync -vsync
    because now the only resolution I can pick is 2560x1440 even for the LG. It seems to have stopped auto-detecting the valid resolutions.

    Is there some way to modify xorg.conf to add this resolution (1680x1050) back in?

    Just so we're clear, I have this line that specifies both monitors' resolutions, but it just results in a black screen on the LG, or alternatively an 800x600 resolution:

    Code:
    Option         "metamodes" "2560x1440_60 +0 +0, 1680x1050 +2560+0"
    Thanks!
    Last edited by Silvo; December 9th, 2012 at 02:44 AM. Reason: typo

  2. #12
    Join Date
    May 2010
    Beans
    14

    Re: Nvidia card/driver and 2560x1440 Monitor

    Quote Originally Posted by Silvo View Post
    Help please!

    I'm trying to follow these instructions to run my Catleap Q270 with twinview with my smaller LG monitor. I am able to get each one working individually, but the problem happens when I try to run them with twinview.

    If I connect only the LG, nvidia-settings will let me select from a variety of resolutions for it. However, if I use the xorg.conf file posted above, the LG stops working properly, and the only options are Auto (800x600) and 2560x1440, but the LG is only 1680x1050. I think this line might be the problem:

    Code:
    Modeline "2560x1440" 241.50 2560 2608 2640 2720 1440 1443 1448 1481 +hsync -vsync
    because now the only resolution I can pick is 2560x1440 even for the LG. It seems to have stopped auto-detecting the valid resolutions.

    Is there some way to modify xorg.conf to add this resolution (1680x1050) back in?

    Just so we're clear, I have this line that specifies both monitors' resolutions, but it just results in a black screen on the LG, or alternatively an 800x600 resolution:

    Code:
    Option         "metamodes" "2560x1440_60 +0 +0, 1680x1050 +2560+0"
    Thanks!
    Refloating the thread, I have the same issue as you, I have a Achieva Simyian, 2560*1440 monitor.
    Thanks to prior posts I was able to configure it, but I cant make my other display, a SONY BRAVIA 1920x1080 to work above 800x600.

    ¿Anyone knows how can we force it to work? My xorg.conf is almost tfe same as the previous ones.

    Thank You in advance

  3. #13
    Join Date
    Feb 2013
    Beans
    1

    Re: Nvidia card/driver and 2560x1440 Monitor

    I also have a problem doing this.

    I have Four monitors, without the Xorg.conf file they all work just fine except for my main 2560x1440 monitor.

    When i do create the Xorg.conf file, using OP method. The 2560x1440 monitor works, however the others will stop working. i can get them to Turn on with twinview but the res cannot go any higher then 800x600.

    attempts to edit the EDID file for my setup have only led to all of my monitor to stop working.

  4. #14
    Join Date
    May 2010
    Beans
    14

    Re: Nvidia card/driver and 2560x1440 Monitor

    Quote Originally Posted by dekoomer View Post
    I also have a problem doing this.

    I have Four monitors, without the Xorg.conf file they all work just fine except for my main 2560x1440 monitor.

    When i do create the Xorg.conf file, using OP method. The 2560x1440 monitor works, however the others will stop working. i can get them to Turn on with twinview but the res cannot go any higher then 800x600.

    attempts to edit the EDID file for my setup have only led to all of my monitor to stop working.
    I'm using nvidia-experimental-310 driver, after many attemps without success I'm thinking to switch to previous versions to see if that fixes the problem. Which nvidia driver are you using?

    EDIT: NO DRIVER change had solved anything...
    Last edited by sylar666; February 11th, 2013 at 07:18 PM.

  5. #15
    Join Date
    Apr 2007
    Beans
    38
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Nvidia card/driver and 2560x1440 Monitor

    Hey guys,

    I managed to get it to work, by generating a new EDID manually for my LG monitor, and using the EDID file for the Catleap from here: http://learnitwithme.com/?p=342

    I've made a note of the steps I used to do this, which might help you solve it for your monitors. Note that I had to boot Windows to run Phoenix EDID Designer to get my LG's EDID file.

    More info at:
    http://ubuntuforums.org/showthread.php?t=1946208
    http://ubuntuforums.org/showthread.p...highlight=edid


    Manual EDID for non-Catleap monitor:
    * Boot Windows
    * Install Phoenix EDID Designer
    * Save all registry EDIDs to text files
    * Boot Linux
    * Compile C program to turn text files into binary files
    * Manually edit the text files to remove columns and row headings
    * Convert into .bin files:
    .EDIDprog < GSM.txt > GSM.bin
    * Install read-edid (command is for Arch Linux, you'll need to find the Ubuntu equivalent, it's probably just an apt-get away though):
    yaourt -S read-edid
    * Parse EDID files to look at contents:
    parse-edid < GSM.bin
    * Keep the one for the LG monitor


    Add line to xorg.conf:
    Option "CustomEDID" "DFP-0:/path/to/EDIDs/edid-catleap.bin; DFP-1:/path/to/EDIDs/edid-LG.bin"



    NOTE: this problem can definitely be solved another (simpler) way. I had it working before and definitely didn't need to generate any EDID files, I managed to solve it by playing with the xorg.conf file. But I didn't back it up and now it's gone so I don't know how I did it. But this method is working perfectly for me (for now, until I get a new monitor and it all goes to hell) so I'm not going to touch it anymore.

    Good luck!

  6. #16
    Join Date
    May 2010
    Beans
    14

    Re: Nvidia card/driver and 2560x1440 Monitor

    Quote Originally Posted by Silvo View Post
    Hey guys,

    I managed to get it to work, by generating a new EDID manually for my LG monitor, and using the EDID file for the Catleap from here: http://learnitwithme.com/?p=342

    I've made a note of the steps I used to do this, which might help you solve it for your monitors. Note that I had to boot Windows to run Phoenix EDID Designer to get my LG's EDID file.

    More info at:
    http://ubuntuforums.org/showthread.php?t=1946208
    http://ubuntuforums.org/showthread.p...highlight=edid


    Manual EDID for non-Catleap monitor:
    * Boot Windows
    * Install Phoenix EDID Designer
    * Save all registry EDIDs to text files
    * Boot Linux
    * Compile C program to turn text files into binary files
    * Manually edit the text files to remove columns and row headings
    * Convert into .bin files:
    .EDIDprog < GSM.txt > GSM.bin
    * Install read-edid (command is for Arch Linux, you'll need to find the Ubuntu equivalent, it's probably just an apt-get away though):
    yaourt -S read-edid
    * Parse EDID files to look at contents:
    parse-edid < GSM.bin
    * Keep the one for the LG monitor


    Add line to xorg.conf:
    Option "CustomEDID" "DFP-0:/path/to/EDIDs/edid-catleap.bin; DFP-1:/path/to/EDIDs/edid-LG.bin"



    NOTE: this problem can definitely be solved another (simpler) way. I had it working before and definitely didn't need to generate any EDID files, I managed to solve it by playing with the xorg.conf file. But I didn't back it up and now it's gone so I don't know how I did it. But this method is working perfectly for me (for now, until I get a new monitor and it all goes to hell) so I'm not going to touch it anymore.

    Good luck!
    Thanks for the help, unfortunately, my compiling skills are very low, Im very lost at this steps:

    * Compile C program to turn text files into binary files
    * Manually edit the text files to remove columns and row headings
    * Convert into .bin files:
    .EDIDprog < GSM.txt > GSM.bin

    As far as I know, this is my C program as I saw on the other thread

    Code:
    #include <stdio.h>
    
    int main()
    {
      while (!feof(stdin))
      {
        unsigned char i;
        scanf("%02X ", &i);
        printf("%c", i);
      }
      return 0;
    I'm using Anjuta to make the program, and I have my txt files ready to conversion
    But thats all I have manage to do , Can you help me here, please?

    If it's worth it, there are my .txt files
    Attached Files Attached Files

  7. #17
    Join Date
    Apr 2007
    Beans
    38
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Nvidia card/driver and 2560x1440 Monitor

    Quote Originally Posted by sylar666 View Post
    Thanks for the help, unfortunately, my compiling skills are very low, Im very lost at this steps:

    * Compile C program to turn text files into binary files
    * Manually edit the text files to remove columns and row headings
    * Convert into .bin files:
    .EDIDprog < GSM.txt > GSM.bin

    As far as I know, this is my C program as I saw on the other thread

    Code:
    #include <stdio.h>
    
    int main()
    {
      while (!feof(stdin))
      {
        unsigned char i;
        scanf("%02X ", &i);
        printf("%c", i);
      }
      return 0;
    I'm using Anjuta to make the program, and I have my txt files ready to conversion
    But thats all I have manage to do , Can you help me here, please?

    If it's worth it, there are my .txt files

    No worries! It is a little difficult to follow, I agree. That's the right C code (except there should be one more line at the end with just a right curly brace } after the return statement), save it as say main.c

    Then compile it, naming the program as EDIDprog:
    gcc main.c -o EDIDprog

    Then run it with:
    ./EDIDprog < sony.txt > sony.bin

    (I forgot the ./ in my original post). I got several files for my monitor, and just picked the best-looking one and used that.

    Good luck!

  8. #18
    Join Date
    May 2010
    Beans
    14

    Re: Nvidia card/driver and 2560x1440 Monitor

    Quote Originally Posted by Silvo View Post
    No worries! It is a little difficult to follow, I agree. That's the right C code (except there should be one more line at the end with just a right curly brace } after the return statement), save it as say main.c

    Then compile it, naming the program as EDIDprog:
    gcc main.c -o EDIDprog

    Then run it with:
    ./EDIDprog < sony.txt > sony.bin

    (I forgot the ./ in my original post). I got several files for my monitor, and just picked the best-looking one and used that.

    Good luck!
    All clear and perfect, I manage to make my .bin files and to learn in the process, thnaks a lot.

    This is my xorg.conf now

    Code:
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Shimian"
        ModelName      "QHD270"
        HorizSync      88.8
        VertRefresh    59.5
        Option         "DPMS"
        Modeline       "2560x1440" 241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
        DisplaySize    597 336  
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 670"  
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "NoLogo" "True"
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "DFP-3"
        Option         "CustomEDID" "DFP-3:/home/carlos/Documentos/BIN/monitor2.bin; DFP-1:/home/carlos/Documentos/BIN/sony.bin"
        Option         "UseEDID" "True"
        Option         "UseEDIDDPI" "False"
        Option         "UseEDIDFreqs" "False"
        Option         "ExactModeTimingsDVI" "True"
        Option         "metamodes" "DFP-3: 2560x1440_60 +0 +0, DFP-1: 1920x1080 +2560+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        Option         "Xinerama" "0"
    EndSection
    Still not working :/ , I added the line to other places, but no luck, where shoul it be added? I also changed the option

    Code:
    Option         "UseEDID" "False"
    to true. Something I'm not doing here right....

  9. #19
    Join Date
    Apr 2007
    Beans
    38
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Nvidia card/driver and 2560x1440 Monitor

    Hmm, not sure. I take it you've double checked your DFP-x numbers?

    If it helps, my xorg.conf now looks like this:

    Code:
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Shimian"
        ModelName      "QHD270"
        HorizSync      88.8
        VertRefresh    59.5
        Option         "DPMS"
        Modeline       "2560x1440" 241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
        DisplaySize    597 336  
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "LG Electronics W2252"
        HorizSync       30.0 - 83.0
        VertRefresh     56.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 9800 GTX+"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "NoLogo" "True"
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "DFP-0"
        Option         "ExactModeTimingsDVI" "True"
        Option         "metamodes" "DFP-0: 2560x1440_60 +1680+0, DFP-1: 1680x1050 +0+0"
        Option         "CustomEDID" "DFP-0:/etc/dotfiles/edid-catleap.bin; DFP-1:/etc/dotfiles/xorg/edid-LG.bin"
        Option         "ConnectedMonitor" "Monitor0, Monitor1"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        Option         "Xinerama" "0"
    EndSection
    A lot of that is unnecessary, I'm sure. Maybe try removing those extra EDID lines you have? I really don't know, sorry!

  10. #20
    Join Date
    May 2010
    Beans
    14

    Re: Nvidia card/driver and 2560x1440 Monitor

    Quote Originally Posted by Silvo View Post
    Hmm, not sure. I take it you've double checked your DFP-x numbers?

    If it helps, my xorg.conf now looks like this:

    Code:
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Shimian"
        ModelName      "QHD270"
        HorizSync      88.8
        VertRefresh    59.5
        Option         "DPMS"
        Modeline       "2560x1440" 241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
        DisplaySize    597 336  
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "LG Electronics W2252"
        HorizSync       30.0 - 83.0
        VertRefresh     56.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 9800 GTX+"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "NoLogo" "True"
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "DFP-0"
        Option         "ExactModeTimingsDVI" "True"
        Option         "metamodes" "DFP-0: 2560x1440_60 +1680+0, DFP-1: 1680x1050 +0+0"
        Option         "CustomEDID" "DFP-0:/etc/dotfiles/edid-catleap.bin; DFP-1:/etc/dotfiles/xorg/edid-LG.bin"
        Option         "ConnectedMonitor" "Monitor0, Monitor1"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        Option         "Xinerama" "0"
    EndSection
    A lot of that is unnecessary, I'm sure. Maybe try removing those extra EDID lines you have? I really don't know, sorry!
    thanks for the quick answer, I'll check later at home and let you know.

    EDIT: DONE¡¡¡ Thank you very much pal, now everything works fine. Just a tip, don't save options with nvidia-settings, will destroy everything.
    Last edited by sylar666; February 13th, 2013 at 02:46 PM.

Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •