The title of the thread is likely a bit vague so I'll try to explain this as clearly as possible. Here is what I expect to happen:

Boot laptop > Use laptop > Close lid > Open lid > Enter password > Continue using laptop.

However, what is happening is I open the lid and get the desktop wallpaper, but nothing else. No password dialog appears and I need to reset the laptop. This doesn't always happen. I'm not certain why it happens some times and not others. I've tried to close the lid and open again but that doesn't have any effect.

I'm able to reboot using the "magic key" (ctrl+alt+sysreq+reisub) sequence so the computer itself is still responsive. My feeling is that the password dialogue is either not being summoned or is appearing in such a position that I can't see it (thinking on it, I'll try typing blind next time it happens to see if that works). I've tried switching desktops (ctrl+alt+cursor) to see if that works with no effect.

So then gurus any ideas where to begin with this one? I'm using a fully updated version of Precise Pangolin but I've had the issue since Oneric, today I was just vexed enough to report it Oh if it makes any difference I have to use the linux_ocpi option in grub to get around the fact my laptop backlight doesn't come on by itself.