Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 32

Thread: Frontendend will not launch after fresh install

  1. #11
    Join Date
    Aug 2012
    Beans
    16

    Re: Frontendend will not launch after fresh install

    I have tested connection to BE in Control center and test is OK.

    We may have something here on your other comment, I do enter the host IP during the initial setup, however I do not believe I have changed the "hostname". What seems unusual is when I went to mythweb clicked settings, mythtv, settings table. The drop down menu for edit setting for: does not list the hostname of my last install.

    I am going to try a fresh install and use the hostname which is in the list to see if that works. If it does great, however how do I add additional hosts to mythweb (or BE) if i add future FE's?

  2. #12
    Join Date
    Nov 2011
    Beans
    12

    Re: Frontendend will not launch after fresh install

    I've never added a second front end, but I recall the settings are specific for a given hostname so you should be ok as long as the hostname of your front ends is unique. I had a problem when I changed my front end from "localhost" to its ip address without following the instructions in the wiki. I was later able to clean it up by modifying the database directly.

  3. #13
    Join Date
    Aug 2012
    Beans
    16

    Re: Frontendend will not launch after fresh install

    I did a new install again. Same issue. It has to be this "QGtkStyle was unable to detect the current GTK+ theme." error. I have Google searched the issue can't find anything helpful. Are there other sources of help?

  4. #14
    Join Date
    Nov 2011
    Beans
    12

    Re: Frontendend will not launch after fresh install

    What theme were you using for the front end? Maybe the front end is trying to load a theme that is not included with a clean install (ie- a downloadable theme). There might be some settings you need to purge when you do a clean install of a previously-configured front end client.

  5. #15
    Join Date
    Nov 2011
    Beans
    12

    Re: Frontendend will not launch after fresh install

    This is from the mythtv wiki. Check the database for duplicate entries.

    Change the hostname of a MythTV frontend or backend

    Before changing the hostname of a MythTV frontend or backend, make sure you create a good database backup, so that you can get back to a known state if things go wrong.
    When changing the hostname of your system, you must perform the following actions before you start any MythTV programs. If you start a MythTV program before modifying the hostname in the database, the program will create new entries with the new hostname, meaning that the following procedure is likely to fail because of duplicate entries.

    It is also critical to ensure you do not change the name of a host to the name of another already-existing host in the database--doing so will cause duplicate entries. Instead, if necessary, run the command below multiple times, using a temporary "placeholder" hostname to ensure the different hosts are not improperly merged.

    Note that changing the hostname is performed on an existing database and does not restore a database. Therefore, to change a hostname, ensure that the database exists (restore an old database, as above, if necessary) and execute the following command, replacing "XXXX" and "YYYY" with appropriate values for the old and new hostnames, respectively:

    mythconverg_restore.pl --change_hostname --old_hostname="XXXX" --new_hostname="YYYY"

  6. #16
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,381
    Distro
    Ubuntu Development Release

    Re: Frontendend will not launch after fresh install

    Maybe some more logging will shed some light on it.

    Code:
    mythfrontend -v all
    *Don't PM me directly for support, open a new thread
    *Looking for a MythTV quick start guide?

  7. #17
    Join Date
    Aug 2012
    Beans
    16

    Re: Frontendend will not launch after fresh install

    jeff@htpc1:~$ mythfrontend -v all
    QGtkStyle was unable to detect the current GTK+ theme.
    2012-08-08 22:25:59.693514 C mythfrontend version: fixes/0.25 [v0.25] www.mythtv.org
    2012-08-08 22:25:59.693593 N Enabled verbose msgs: all
    2012-08-08 22:25:59.693688 N Setting Log Level to LOG_INFO
    2012-08-08 22:25:59.693849 I Added logging to the console
    2012-08-08 22:25:59.693945 I Added syslogging to facility local7
    2012-08-08 22:25:59.693974 I Added database logging to table logging
    2012-08-08 22:25:59.694349 N Setting up SIGHUP handler
    2012-08-08 22:25:59.694938 N Using runtime prefix = /usr
    2012-08-08 22:25:59.695096 N Using configuration directory = /home/jeff/.mythtv
    2012-08-08 22:25:59.695723 E (old)Settings::ReadSettings(settings.txt) - No such file settings.txt
    2012-08-08 22:25:59.696109 I Assumed character encoding: en_US.UTF-8
    2012-08-08 22:25:59.696739 E (old)Settings::ReadSettings(settings.txt) - No such file settings.txt
    2012-08-08 22:25:59.696950 E (old)Settings::ReadSettings(settings.txt) - No such file settings.txt
    2012-08-08 22:25:59.697064 E (old)Settings::ReadSettings(/usr/share/mythtv/mysql.txt) - No such file /usr/share/mythtv/mysql.txt
    2012-08-08 22:25:59.697148 E (old)Settings::ReadSettings(/usr/etc/mythtv/mysql.txt) - No such file /usr/etc/mythtv/mysql.txt
    2012-08-08 22:25:59.697884 E (old)Settings::ReadSettings(./mysql.txt) - No such file ./mysql.txt
    2012-08-08 22:25:59.698098 N Empty LocalHostName.
    2012-08-08 22:25:59.698139 I Using localhost value of htpc1
    2012-08-08 22:25:59.698203 I Clearing Settings Cache.
    2012-08-08 22:25:59.698542 I DefaultUPnP() - No default UPnP backend
    2012-08-08 22:25:59.698609 I Testing network connectivity to '192.168.1.200'
    2012-08-08 22:25:59.704608 I Starting process manager
    2012-08-08 22:25:59.704840 I Starting process signal handler
    2012-08-08 22:25:59.709163 I Starting IO manager (write)
    2012-08-08 22:25:59.710831 I Managed child (PID: 1796) has started! * command=ping -t 3 -c 1 192.168.1.200 >/dev/null 2>&1, timeout=0
    2012-08-08 22:25:59.711223 I Starting IO manager (read)
    2012-08-08 22:25:59.804939 I Managed child (PID: 1796) has exited! command=ping -t 3 -c 1 192.168.1.200 >/dev/null 2>&1, status=0, result=0
    2012-08-08 22:25:59.805325 I Clearing Settings Cache.
    2012-08-08 22:25:59.857676 I Database connection created: DBManager0
    2012-08-08 22:25:59.857797 I New DB connection, total: 1
    ^C
    jeff@htpc1:~$

    Hope this helps. Thanks!!!!

  8. #18
    Join Date
    Aug 2012
    Beans
    16

    Re: Frontendend will not launch after fresh install

    x
    Last edited by jeffc7186; August 9th, 2012 at 04:39 AM.

  9. #19
    Join Date
    Aug 2012
    Beans
    16

    Re: Frontendend will not launch after fresh install

    Bumb

  10. #20
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: Frontendend will not launch after fresh install

    Quote Originally Posted by jeffc7186 View Post
    jeff@htpc1:~$ mythfrontend -v all
    QGtkStyle was unable to detect the current GTK+ theme.
    2012-08-08 22:25:59.693514 C mythfrontend version: fixes/0.25 [v0.25] www.mythtv.org
    2012-08-08 22:25:59.693593 N Enabled verbose msgs: all
    2012-08-08 22:25:59.693688 N Setting Log Level to LOG_INFO
    2012-08-08 22:25:59.693849 I Added logging to the console
    2012-08-08 22:25:59.693945 I Added syslogging to facility local7
    2012-08-08 22:25:59.693974 I Added database logging to table logging
    2012-08-08 22:25:59.694349 N Setting up SIGHUP handler
    2012-08-08 22:25:59.694938 N Using runtime prefix = /usr
    2012-08-08 22:25:59.695096 N Using configuration directory = /home/jeff/.mythtv
    2012-08-08 22:25:59.695723 E (old)Settings::ReadSettings(settings.txt) - No such file settings.txt
    2012-08-08 22:25:59.696109 I Assumed character encoding: en_US.UTF-8
    2012-08-08 22:25:59.696739 E (old)Settings::ReadSettings(settings.txt) - No such file settings.txt
    2012-08-08 22:25:59.696950 E (old)Settings::ReadSettings(settings.txt) - No such file settings.txt
    2012-08-08 22:25:59.697064 E (old)Settings::ReadSettings(/usr/share/mythtv/mysql.txt) - No such file /usr/share/mythtv/mysql.txt
    2012-08-08 22:25:59.697148 E (old)Settings::ReadSettings(/usr/etc/mythtv/mysql.txt) - No such file /usr/etc/mythtv/mysql.txt
    2012-08-08 22:25:59.697884 E (old)Settings::ReadSettings(./mysql.txt) - No such file ./mysql.txt
    2012-08-08 22:25:59.698098 N Empty LocalHostName.
    2012-08-08 22:25:59.698139 I Using localhost value of htpc1
    2012-08-08 22:25:59.698203 I Clearing Settings Cache.
    2012-08-08 22:25:59.698542 I DefaultUPnP() - No default UPnP backend
    2012-08-08 22:25:59.698609 I Testing network connectivity to '192.168.1.200'
    2012-08-08 22:25:59.704608 I Starting process manager
    2012-08-08 22:25:59.704840 I Starting process signal handler
    2012-08-08 22:25:59.709163 I Starting IO manager (write)
    2012-08-08 22:25:59.710831 I Managed child (PID: 1796) has started! * command=ping -t 3 -c 1 192.168.1.200 >/dev/null 2>&1, timeout=0
    2012-08-08 22:25:59.711223 I Starting IO manager (read)
    2012-08-08 22:25:59.804939 I Managed child (PID: 1796) has exited! command=ping -t 3 -c 1 192.168.1.200 >/dev/null 2>&1, status=0, result=0
    2012-08-08 22:25:59.805325 I Clearing Settings Cache.
    2012-08-08 22:25:59.857676 I Database connection created: DBManager0
    2012-08-08 22:25:59.857797 I New DB connection, total: 1
    ^C
    jeff@htpc1:~$

    Hope this helps. Thanks!!!!
    ^c killed the process, no wonder it dodn't start!

    Have you tried with a different themepainter.
    Code:
    mythfrontend -O ThemePainter=qt
    or opengl

Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •