Results 1 to 4 of 4

Thread: Gnome keyring does not work

  1. #1
    Join Date
    Apr 2008
    Beans
    21

    Question Gnome keyring does not work

    Hi,

    I have just installed a fresh Xubuntu 12.04. The Gnome keyring only seems to work if I select "Load runtime environment for GNOME at system start" in the settings menu.
    Specifically, I am using a secondary SSH key stored in, say, ~./ssh/id_rsa_2. Without the above option actived, I have to re-enter the SSH keyphrase every time.
    However, I don't actually want to load a full "runtime environment for GNOME" on startup -- I just want the keyring to work, nothing else.
    On my Unity machine, on the contrary, this all works perfectly fine and hassle-free out-of-the-box.

    Thanks for your help!

  2. #2
    Join Date
    Apr 2008
    Beans
    21

    Re: Gnome keyring does not work

    *bump*

  3. #3
    Join Date
    Mar 2012
    Beans
    303

    Re: Gnome keyring does not work

    Edit the needed gnome-keyring-*.desktop files located in /etc/xdg/autostart and change the value of "OnlyShowIn=" to:
    Code:
    OnlyShowIn=GNOME;Unity;XFCE;
    Additionally, you might need to activate those entries in your application autostart list (settings manager).
    GNU/Linux

  4. #4
    Join Date
    Apr 2008
    Beans
    21

    Re: Gnome keyring does not work

    I did this with just one of them (the ssh one), and it didn't work; do you think enabling all of them might help?
    Also, I've tried executing the commands in these .desktop files manually just to see if this resolves the issue; but it didn't help.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •