Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Connecting to remote Byobu session

  1. #1
    Join Date
    Mar 2008
    Beans
    7

    Question Connecting to remote Byobu session

    Hi. I've been searching around for a solution for my problem but found nothing. Does anyone know how to resize remote byobu window? The problem is as follows: I have a Gentoo desktop running a byobu session, and I'm trying to connect to it from my Ubuntu laptop via ssh. So to avoid byobu-within-byobu problem, I start regular Terminal on the laptop, and ssh to the desktop. Now the problem is that remote byobu windows are of different size than what can be displayed on my laptop screen. I've attached a screenshot showing the issue.
    I have no idea how to resize such window. i tried many key combinations, including Ctrl+Left/Right but nothing seems to work. I'd appreciate any help, thanks.
    Attached Images Attached Images

  2. #2
    Join Date
    Jan 2008
    Location
    Manchester UK
    Beans
    13,658
    Distro
    Ubuntu

    Re: Connecting to remote Byobu session

    byobu has an option to use a backend of either screen or tmux. I have never found a reliable way to do this with tmux but if you exit byobu then run

    Code:
    byobu-select-backend
    and choose screen (it defaults to tmux) then you can redraw the screen with Ctrl-A Shift-F when you log in from different machines.

    Both tmux and screen have advantages and disadvantages, but if this is something you do often then screen is the choice.



    ......unless someone knows how to do it with tmux in which case I'm all ears

  3. #3
    Join Date
    Aug 2009
    Location
    Charleston, SC (USA)
    Beans
    1,407
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Connecting to remote Byobu session

    Quote Originally Posted by nothingspecial View Post
    byobu has an option to use a backend of either screen or tmux. I have never found a reliable way to do this with tmux but if you exit byobu then run....
    +1 BUT just in case that doesn't work check out this thread

    X/Config/Resolution
    UA Team Member
    "When our actions do not, our fears do make us traitors." -- Shakespeare
    "Unless someone like you cares a whole awful lot, nothing is going to get better. It's not!" -- Dr. Seuss
    "No man has ever seen his dreams fulfilled and regretted the sacrifice necessary to fulfill them" -- Mattie Montgomery


  4. #4
    Join Date
    Mar 2008
    Beans
    7

    Re: Connecting to remote Byobu session

    Thanks, that would be just what I need, but I've changed the backend on server to screen and the result is that when I connect to it, it seems to start a new byobu session instead of connecting to the already running one. Any ideas how can I force it to select the right one?

  5. #5
    Join Date
    Mar 2008
    Beans
    7

    Re: Connecting to remote Byobu session

    Quote Originally Posted by nothingspecial View Post
    byobu has an option to use a backend of either screen or tmux. I have never found a reliable way to do this with tmux but if you exit byobu then run

    Code:
    byobu-select-backend
    and choose screen (it defaults to tmux) then you can redraw the screen with Ctrl-A Shift-F when you log in from different machines.

    Both tmux and screen have advantages and disadvantages, but if this is something you do often then screen is the choice.



    ......unless someone knows how to do it with tmux in which case I'm all ears
    Thanks, that would be just what I need, but I've changed the backend on server to screen and the result is that when I connect to it, it seems to start a new byobu session instead of connecting to the already running one. Any ideas how can I force it to select the right one?

    (sorry for double post but I'm new to this forum and can't seem to find a way to delete a post ;( )
    Last edited by caleb9; July 31st, 2012 at 06:56 PM.

  6. #6
    Join Date
    Aug 2009
    Location
    Charleston, SC (USA)
    Beans
    1,407
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Connecting to remote Byobu session

    Quote Originally Posted by caleb9 View Post
    Any ideas how can I force it to select the right one?
    See if this answer helps any.

    Ask Ubuntu
    UA Team Member
    "When our actions do not, our fears do make us traitors." -- Shakespeare
    "Unless someone like you cares a whole awful lot, nothing is going to get better. It's not!" -- Dr. Seuss
    "No man has ever seen his dreams fulfilled and regretted the sacrifice necessary to fulfill them" -- Mattie Montgomery


  7. #7
    Join Date
    Mar 2008
    Beans
    7

    Re: Connecting to remote Byobu session

    Quote Originally Posted by Caboose885 View Post
    +1 BUT just in case that doesn't work check out this thread

    X/Config/Resolution
    Thanks though I don't think forcing a specific resolution is the problem here. The remote byobu window is not full-screen but just arbitrary size, and the two screens (desktop and laptop) differ in resolution a lot.

  8. #8
    Join Date
    Mar 2008
    Beans
    7

    Re: Connecting to remote Byobu session

    Quote Originally Posted by Caboose885 View Post
    See if this answer helps any.

    Ask Ubuntu
    Ok so I've set byobu-select-backend to screen, then started byobu with byobu-shell on the server. On the client after ssh it doesn't start byobu automatically anymore so I do byobu-select-session and it connects to the right one. Unfortunately Ctrl+a F doesn't resize the window, like there was no reaction to it ;(.

  9. #9
    Join Date
    Aug 2009
    Location
    Charleston, SC (USA)
    Beans
    1,407
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Connecting to remote Byobu session

    Try opening the ssh connection from TTY1 session and see if the formatting issues still occur.

    If my memory jogs me correctly I always had formatting issues on my server when I had a monitor hooked up to it....or was it if I had xserver running.... I really don't remember anymore. My Ubuntu Server sits in the corner headless and no GUI.

    I will keep poking around the Internet and see what I can turn up
    UA Team Member
    "When our actions do not, our fears do make us traitors." -- Shakespeare
    "Unless someone like you cares a whole awful lot, nothing is going to get better. It's not!" -- Dr. Seuss
    "No man has ever seen his dreams fulfilled and regretted the sacrifice necessary to fulfill them" -- Mattie Montgomery


  10. #10
    Join Date
    Mar 2008
    Beans
    7

    Re: Connecting to remote Byobu session

    Ok the problem seems to be on my Gentoo box, as even testing it locally on two separate terminals (of differing sizes) I'm able to resize with Ctrl+a F on Ubuntu and not able to do it on Gentoo. On Ubuntu this shortcut works despite the backend selected. This is interesting considering that on Gentoo the byobu version is newer (5.18) than on Ubuntu (5.17).
    That said, probably I should look for solution on Gentoo's forums, though people there don't seem to care much about byobu :(.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •