I'm running Thunderbird 14.0 on the amd64 version of Ubuntu 10.04 LTS and desperately searching for a suitable version of the Lightning extension. Being too dumb to build it myself I'd appreciate any help.

Thanks,
-Dieter