Results 1 to 3 of 3

Thread: Wine grabs sound device. Can't play other sounds.

  1. #1
    Join Date
    Mar 2012
    Beans
    48

    Wine grabs sound device. Can't play other sounds.

    It seems that wine is grabbing my sound device. I cannot play other sounds like videos and music while wine is running.

    If it matters any, the program I'm running in wine is VBALink (visualboy advance fork). When I disable sound in the emulator, then I can play video and music again.

    If I am already playing audio when I start wine, the emulator will give an error. Something like "Cannot create DirectSound". And the its wine that has no sound.

    I think I understand that Ubuntu handles requests to the sound card through PulseAudio?
    Don't know whether this is relevant, but the wine configuration says its using winealsa.drv for sound.

    Thanks.

  2. #2
    Join Date
    Mar 2012
    Beans
    305

    Re: Wine grabs sound device. Can't play other sounds.

    Switching to winepulse might solve your issue, but it could cause other problems like disoriented sound output.

    winepulse in ubuntu wine ppa
    GNU/Linux

  3. #3
    Join Date
    Mar 2012
    Beans
    48

    Re: Wine grabs sound device. Can't play other sounds.

    OK. For some reason, starting wine while audio is playing results in no sound in wine, but no error either.

    The reason I wanted both to be able to play together is that VBALink runs too fast if I disable sound emulation, so I set it to mute (still emulates, but doesn't actually play it).
    I wanted to listen to music while using VBALink, so I guess the problem has been circumvented.

    Technically this isn't a solution, so I won't mark this solved.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •