Results 1 to 6 of 6

Thread: Problems with jackd???

  1. #1
    Join Date
    Jul 2012
    Beans
    3

    Problems with jackd???

    Hi I am an reasonable experianced linux user. I usually manage to google most of my problems but this one has drawn a blank. I am trying to set up a little music recording thing to practise my guitar and keyboard on and record it on the computer but it does not seem to want to play ball. rakarrack or rosegarden etc it say's jackd is not working. My keyboard is conected with a midi to usb cable and my electric guitar is connected with a guitar link usb interface. Both new. When I try to start jack control it displays this message
    p, li { white-space: pre-wrap; } "Could not connect to JACK server as client."
    The message window log will not copy and paste sorry but it said I was unable to run realtime scheduling and told me to check my /etc/security/limits.conf for the following lines
    @audio - rtprio 100
    @audio - nice -10
    I have checked and these lines were not there so I edited the file and added them. Then restarted but this error still occurred. It also said I did not appear to have a sane system configuration. and would likely get x runs.
    Sorry this is a long one but linux looks really good for recording and playing music on and it would be nice to fix the bug/error.
    Many Thanks
    Gareth

  2. #2
    Join Date
    Jun 2008
    Beans
    1,129
    Distro
    Ubuntu Studio

    Re: Problems with jackd???

    Are you in audio group?

  3. #3
    Join Date
    Jul 2012
    Beans
    3

    Re: Problems with jackd???

    Quote Originally Posted by jejeman View Post
    Are you in audio group?
    To be honest I'm not sure, I assume probably not if i have not heard of it.

  4. #4
    Join Date
    Jun 2008
    Beans
    1,129
    Distro
    Ubuntu Studio

    Re: Problems with jackd???

    I assume that you didn't install ubuntu studio but Ubuntu, since your limits.conf wasn't set.

    Check with this
    Code:
    groups
    if you don't see audio group listed, add your username to it.

  5. #5
    Join Date
    Dec 2006
    Beans
    1,540

    Re: Problems with jackd???

    rt 'priority' should work at 99 or lower, never used it at
    100...and the priority
    shown in qjackctl is a ratio of that, maximum 89.

    I can use lower settings, like 70 etc in qjackctl, but use 89, for luck, since I don't use the computer beyond recording/browsing.

    http://jackaudio.org/linux_rt_config

    good info

    Cheers

  6. #6
    Join Date
    Jan 2012
    Beans
    5

    Re: Problems with jackd???

    Oops, misread your post, disregard my feeble reply.
    Last edited by UndercoverLawyer; August 17th, 2012 at 02:57 AM. Reason: Mistake, apologies.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •