Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Enable 3D Mode Unity 12.04

  1. #1
    Join Date
    Feb 2011
    Location
    GA
    Beans
    171
    Distro
    Ubuntu 12.04 Precise Pangolin

    Enable 3D Mode Unity 12.04

    Ok, guys. I thought I had this figured out, but I can't find the xorg.conf file to enable compositing on my new netbook installation. I just did this very same thing on my desktop and there were no hiccups or flaws. All I had to do was go in and edit the xorg.conf file in /etc/X11/xorg.conf. I have an NVIDIA graphics card and have installed the latest driver. Suggestions?

  2. #2
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Enable 3D Mode Unity 12.04

    Hi!, ditchdoc7893,

    From a Terminal run:
    Code:
    sudo apt-get update
    sudo update-grub
    And watch for any errors.

    Have you run Nvidia Xserver settings? or:
    Code:
    sudo nvidia-settings
    ?? You may need to install the later, depending on how you installed the "latest"driver version.

    BTW, What version is it?. nvidia-current or downloaded .run file.?

    Chao!, bogan.
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  3. #3
    Join Date
    Feb 2011
    Location
    GA
    Beans
    171
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Enable 3D Mode Unity 12.04

    I ran both the sudo apt-get and sudo update grub. No error messages were generated. When I run the command sudo nvidia-settings, it returns the following error statement:

    You do not appear to be using the NVIDIA X driver. Pease edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server. Any ideas?

  4. #4
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Enable 3D Mode Unity 12.04

    Hi ,
    you can follow the recommendation ..
    Code:
    sudo nvidia-xconfig
    and reboot the pc.

    and give the result of these commands
    Code:
    cat /etc/lsb-release && uname -r
    apt-cache policy nvidia-current
    lspci -nnk | grep -iA2 vga
    Thanks

  5. #5
    Join Date
    Feb 2011
    Location
    GA
    Beans
    171
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Enable 3D Mode Unity 12.04

    I may have screwed up. I went back and double checked the specs of this netbook. Seems that it may have Intel GMA 950 graphics. I'm far from familiar with this. It is an Asus Eee PC 1005 HAB. This has been my utility book that worked fine with 10.10 without any modifications to anything. Any ideas?

  6. #6
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Enable 3D Mode Unity 12.04

    Hi ,
    please give the result of this command
    Code:
    lspci -nnk | grep -iA2 vga
    so we can see for sure what is your graphics card and what driver you use.
    Then we can guide you .

    Thanks

  7. #7
    Join Date
    Feb 2011
    Location
    GA
    Beans
    171
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Enable 3D Mode Unity 12.04

    Results are as follows:

    00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME Express Intregrated Graphics Controller [8086:27ae] (rev 03)
    Subystem: ASUSTeK Computer Inc. Device [1043:8340]
    Kernel driver in use: i915

  8. #8
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    6,497
    Distro
    Ubuntu

    Re: Enable 3D Mode Unity 12.04

    Your running intel drivers, there will be no need for an xorg.conf file. The drivers are built into the kernel. If it seems like the system isn't recognizing it follow this link:

    http://askubuntu.com/questions/12922...n-ubuntu-12-04

    If your not sure whether or not your system is running Unity-3d, try this:
    Terminal
    Code:
    /usr/lib/nux/unity_support_test -p
    If any of the responses are returned no, then your system cannot run in Unity-3d mode.

  9. #9
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Enable 3D Mode Unity 12.04

    Hi ,
    it seems that you are running Intel driver , and your card Must have unity 3D support.

    Give the results of deadflowr's command .

    Purge nvidia drivers.. it not needed
    Code:
    sudo apt-get purge nvidia-current nvidia-settings 
    sudo rm /etc/X11/xorg.conf
    reboot your pc.

    Thanks

  10. #10
    Join Date
    Apr 2005
    Location
    Miami, FL
    Beans
    39
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Enable 3D Mode Unity 12.04

    I don't mean to hijack the thread but what about those of us with hybrid video cards? I have one of the Optimus that uses the Intel for most things but can switch tot he Nvidia when needed (420M) but I can't seem to get Ubuntu setup to do so.

    Code:
    edwin@Dreadmaul:~$ lspci -nnk | grep -iA2 vga
    00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 18)
    	Subsystem: Dell Device [1028:046e]
    	Kernel driver in use: i915
    --
    02:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:0df1] (rev a1)
    	Subsystem: Dell Device [1028:046e]
    	Kernel driver in use: nvidia
    edwin@Dreadmaul:~$ /usr/lib/nux/unity_support_test -p
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: GLX is not available on the system

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •