Results 1 to 2 of 2

Thread: Xorg requires root for 1600x1200 but 1280x1024 is ok

  1. #1
    Join Date
    Jun 2006
    Beans
    16

    Xorg requires root for 1600x1200 but 1280x1024 is ok

    Got strange behavouir of Xorg after migrating from SuSE to Dapper.
    Xorg refuses to run at 1600x1200 as a regular user, the maximum it can shows is 1280x1024 (which I belive is max for VESA standart or something like that).
    So I tried to run it as root (Xorg :1 vt6) and connect to it using startx (startx -- :1 vt6). In this way everything is fine. But when I run the X server is run as a regular user it doesn't give any errors in its log but simple runs at 1280x1024.

    The card is "Intel Corporation 82852/855GM Integrated Graphics Device".
    Driver is i810.

    When I tried to switch driver to vesa it runs at 1600x1200 with no problem (except vesa driver is much slower).

    I think it has something to do with Debian/Ubuntu because the video system ran perfectly with RedHat and SuSE.

  2. #2
    Join Date
    Dec 2005
    Location
    A Brit in Lezardrieux, Fr
    Beans
    1,595
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Xorg requires root for 1600x1200 but 1280x1024 is ok

    http://ubuntuforums.org/showthread.php?t=203047

    This thread has just solved a similar problem - might be worth checking to see if yours has the same symptoms and/or cause.
    When someone says 'I cannot do this in Linux, the limitation is not in the software, but simply in their knowledge.'
    Linux User - 380191

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •