Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 38

Thread: Power Mac G5 Refusing to Install 12.04

  1. #11
    Join Date
    Jan 2011
    Beans
    939

    Re: Power Mac G5 Refusing to Install 12.04

    Quote Originally Posted by str8bs View Post
    That chart hasn't been updated since 2010 judging from the stamp on the page.
    +1 . Which is why I just deleted it.

    video=ofonly should have no effect with nouveau.
    I think nosplash is also a myth. You should use the option live64-nosplash (or whatever it is called) instead:

    Code:
    boot: live64-nosplash single nouveau.modeset=0

  2. #12
    Join Date
    Apr 2012
    Beans
    103

    Re: Power Mac G5 Refusing to Install 12.04

    Quote Originally Posted by rsavage View Post

    video=ofonly should have no effect with nouveau.
    I think nosplash is also a myth. You should use the option live64-nosplash (or whatever it is called) instead:
    Thanks rsavage! Good to know!

  3. #13
    Join Date
    Jul 2012
    Beans
    17

    Re: Power Mac G5 Refusing to Install 12.04

    Quote Originally Posted by str8bs View Post
    When it goes to black screen, can you press CTL+ALT+F1 to get to a terminal?
    If not, I would suspect a phantom port issue like the 5200's have or the HDMI adapter may be confusing things.

    Just speculation, but I wonder if the 6600 has phantom port issues as well? I can't really tell without seeing the logs.

    Things I would try if possible:
    1.
    Code:
    boot: live video=TV-1:d
    2.
    Code:
    boot: live 1 nosplash video=ofonly nouveau.modeset=0
    Should at least boot to command line unless the adapter is causing problems.
    2. Another display with DVI. (To rule out the adapter.)
    3. Swap port it is plugged in to.

    Also, I've never seen the 1. 1. 1. you described from CLI install so I may be way off base. Since you are dual booting, I presume the firmware is the latest?
    I believe the firmware is the latest, as software update on osx says I am up to date. If it makes it any easier I dont really have to keep it dual boot, i dont use this thing for anything but file storage at this point.

    boot: live 1 nosplash video=ofonly nouveau.modeset=0 seems to have made the computer hang at the white screen instead of the black one. all of the others stopped at the black screen.

    I should also note that after the computer loads the kernel the fans go to full speed, which is very annoying

  4. #14
    Join Date
    Jan 2011
    Beans
    939

    Re: Power Mac G5 Refusing to Install 12.04

    I should probably qualify that since you also use debian.

    video=ofonly shouldn't be necessary in ubuntu, but in debian you may need it (if the installer doesn't add it automatically).

  5. #15
    Join Date
    Jul 2012
    Beans
    17

    Re: Power Mac G5 Refusing to Install 12.04

    My 10.10 desktop iso finished downloading and I am staring at the ubuntu live desktop right now-it worked! Is there anything I can get off of here that can help with getting 12.04 to work? I didnt have to use any special options-just hit enter, saw the white screen, and ubuntu loaded-graphics look the way they should.

  6. #16
    Join Date
    Apr 2012
    Beans
    103

    Re: Power Mac G5 Refusing to Install 12.04

    rsavage- clarification appreciated

    ImAliveG5- Cool. I speculate you could distribution upgrade from there, but may run in to the same problems. IIRC, 10.04 used driver NV instead of Nouveau and hardware acceleration is disabled (3D.) Don't know about 10.10.

    I do know that driver "NV" will avoid phantom port issues that "nouveau" will not.
    So you may want to find the issue in 12.04 if you want to get current.

    From within your live 10.10 boot, if you could get a copy of /var/log/Xorg.0.log and post it, I might be able to tell how it is seeing the ports/adapter. No promises though.
    Last edited by str8bs; July 21st, 2012 at 12:31 AM. Reason: Log

  7. #17
    Join Date
    Jul 2012
    Beans
    17

    Smile Re: Power Mac G5 Refusing to Install 12.04

    10.10 seems to be working, so I will try toupgrade from that once I can get in the swing of things.

    I can keep you posted-after all my g5 is still refusing to install 12.04 lol

    It is still amazing that ubuntu on PPC hardware even exists! I must say it is great that there are people who even try to make this possible.

  8. #18
    Join Date
    Apr 2012
    Beans
    103

    Re: Power Mac G5 Refusing to Install 12.04

    Sounds good. When I make time, I need to file a proper bug report on the phantom port issue the FX5200 has. It would be helpful if we could confirm whether the 6600 does or does not have the same issue.

    Would you mind if I PM you when I get to it? The live ISO can be used to gather logs if you have a USB flash drive or something to copy them to. It may be helpful to the maintainers if we confirm other cards. The idea being the problem gets resolved in the long run so the next person who installs on the same hardware won't go through what you just did and it will work "out of the box."


    PS: The dual boot will not impact the display issues. I would leave it for now unless you are hurting for disk space.

  9. #19
    Join Date
    Jul 2012
    Beans
    17

    Re: Power Mac G5 Refusing to Install 12.04

    Quote Originally Posted by str8bs View Post
    rsavage- clarification appreciated

    ImAliveG5- Cool. I speculate you could distribution upgrade from there, but may run in to the same problems. IIRC, 10.04 used driver NV instead of Nouveau and hardware acceleration is disabled (3D.) Don't know about 10.10.

    I do know that driver "NV" will avoid phantom port issues that "nouveau" will not.
    So you may want to find the issue in 12.04 if you want to get current.

    From within your live 10.10 boot, if you could get a copy of /var/log/Xorg.0.log and post it, I might be able to tell how it is seeing the ports/adapter. No promises though.
    here it is
    http://pastebin.com/t3Zd7ctg

  10. #20
    Join Date
    Apr 2012
    Beans
    103

    Re: Power Mac G5 Refusing to Install 12.04

    ImAliveG5- Thanks for the log. Looks like 10.10 is using nouveau and I don't see a phantom port. No reason for me to bug you further. (pun intended) Assuming you checked MD5 sums and their was nothing wrong with the ISO burn, I'm out of ideas.

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •