Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: Struggling to find a way to use my ipod with Ubuntu

  1. #11
    Join Date
    Aug 2009
    Location
    England
    Beans
    260
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: Struggling to find a way to use my ipod with Ubuntu

    This may not be the solution you are looking for but I hope you don't mind me contributing.

    I had a lot of trouble using my iPod when I first moved to Ubuntu over three years ago. Between them Banshee and Rhythmbox wiped all my covers or wiped all my songs. This was three years ago so they may be better now.

    Since then I've been using Virtualbox with Windows XP and iTunes.

    This is the only thing I have to go to XP for. I absolutely hate iTunes but use it solely to manage my iPod.

    Cheers
    Dave
    AMD Bulldozer FX-4100 Quad Core @ 3.6GHz, NVidia GT430, Asus M5A78L-M LX, 8GB DDR3, Western Digital Green 1TB SATA2 hard-drive

  2. #12
    Join Date
    May 2009
    Beans
    3

    Re: Struggling to find a way to use my ipod with Ubuntu

    Thanks Dave, this might work for many.

    I didn't have any trouble with gtkpod and my iPod nano in the past though (the "past" being a 10.04 ubuntu system). It even played nice with occasionally getting a file or two from iTunes at a friends place.

    And I just don't own a windows license. So VirtualBox/VMware won't do...

    kai

  3. #13
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Struggling to find a way to use my ipod with Ubuntu

    Quote Originally Posted by kai12 View Post
    Hey hey,

    I'm having gtkpod trouble in kubuntu 12.04,
    so I followed the above procedure and compiled from the git sources.

    But something apparently went wrong
    Hi
    I've just compiled gtkpod from git again.
    It's working OK.
    Version is 2.1.3-2067905
    System is Xubuntu-12.04
    Attached Images Attached Images

  4. #14
    Join Date
    Mar 2012
    Beans
    5

    Re: Struggling to find a way to use my ipod with Ubuntu

    Sorry for the newbie question.
    I follow all the instructions but when I type gtkpod in terminal I get:

    bash: /usr/bin/gtkpod: Arquivo ou diretório não encontrado

    I need use any diferent path to run?

  5. #15
    Join Date
    Mar 2012
    Beans
    5

    Re: Struggling to find a way to use my ipod with Ubuntu

    It was in other directory, I found it, thanks!

  6. #16
    Join Date
    Nov 2009
    Beans
    611

    Re: Struggling to find a way to use my ipod with Ubuntu

    I tried to install Gtkpod using using the 2 aforementioned commands.

    What do I do next?

    Please be exact as I have no idea really how to do those "make" "install" etc commands or other fancy sort of stuff.

  7. #17
    Join Date
    Aug 2007
    Beans
    14

    Re: Struggling to find a way to use my ipod with Ubuntu

    Thanks so much for the easy scripts! i'd been wanting to update GTKPod for over a year (when i was still on 10.10). After upgrading to 12.04.1 (64-bit) i was dismayed to read of teh troubles with the version in the Ubuntu repos. This is a great relief, there are few software programs that annoy me as much as iTunes.

  8. #18
    Join Date
    Oct 2007
    Beans
    5

    Re: Struggling to find a way to use my ipod with Ubuntu

    I compiled and installed gtkpod from git but I think some libraries
    get missplaced, when I run /usr/local/bin/gtkpod does not find
    libgtkpod.so.1

  9. #19
    Join Date
    Dec 2008
    Beans
    4

    Re: Struggling to find a way to use my ipod with Ubuntu

    Hi

    I followed your steps, but had lots of tweaking to do, maybe because it's a Kubuntu-based distro in 64bit. After 3 hrs I think I have nearly made it, but can't figure out my last problem. Below you find the terminal output before the script / your command sequence aborts. It seem that .libs/libgtkpod.lai cannot be found, and indeed if I check the folder ~/gtkpod/libgtkpod/.libs, the only the files libgtkpod.so and .a are there, but not .lai. Any suggestions would be very welcome, I am quite frustrated after 3hrs of work...

    Code:
    *****************************************
    **** Debian package creation selected ***
    *****************************************
    
    This package will be built according to these values: 
    
    0 -  Maintainer: [ root@Moria ]
    1 -  Summary: [ Package created with checkinstall 1.6.2 ]
    2 -  Name:    [ gtkpod ]
    3 -  Version: [ 2.1.3+git20130323 ]
    4 -  Release: [ 1 ]
    5 -  License: [ GPL ]
    6 -  Group:   [ checkinstall ]
    7 -  Architecture: [ amd64 ]
    8 -  Source location: [ gtkpod ]
    9 -  Alternate source location: [  ]
    10 - Requires: [  ]
    11 - Provides: [ gtkpod ]
    12 - Conflicts: [  ]
    13 - Replaces: [  ]
    
    Enter a number to change any of them or press ENTER to continue: 
    
    Installing with make install...
    
    ========================= Installation results ===========================
    Making install in libgtkpod
    make[1]: Entering directory `/home/isildur/gtkpod/libgtkpod'
    make[2]: Entering directory `/home/isildur/gtkpod/libgtkpod'
    test -z "/usr/local/lib" || /bin/mkdir -p "/usr/local/lib"
     /bin/bash ../libtool   --mode=install /usr/bin/install -c   libgtkpod.la '/usr/local/lib'
    libtool: install: /usr/bin/install -c .libs/libgtkpod.so.1.1.0 /usr/local/lib/libgtkpod.so.1.1.0
    libtool: install: (cd /usr/local/lib && { ln -s -f libgtkpod.so.1.1.0 libgtkpod.so.1 || { rm -f libgtkpod.so.1 && ln -s libgtkpod.so.1.1.0 libgtkpod.so.1; }; })
    libtool: install: (cd /usr/local/lib && { ln -s -f libgtkpod.so.1.1.0 libgtkpod.so || { rm -f libgtkpod.so && ln -s libgtkpod.so.1.1.0 libgtkpod.so; }; })
    libtool: install: /usr/bin/install -c .libs/libgtkpod.lai /usr/local/lib/libgtkpod.la
    /usr/bin/install: cannot stat `.libs/libgtkpod.lai': No such file or directory
    make[2]: *** [install-libLTLIBRARIES] Error 1
    make[2]: Leaving directory `/home/isildur/gtkpod/libgtkpod'
    make[1]: *** [install-am] Error 2
    make[1]: Leaving directory `/home/isildur/gtkpod/libgtkpod'
    make: *** [install-recursive] Error 1
    
    ****  Installation failed. Aborting package creation.
    
    Cleaning up...OK
    
    Bye.

    Thanks,

    Daniel

  10. #20
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Struggling to find a way to use my ipod with Ubuntu

    Hi
    I've just compiled gtkpod from git again.
    It's working OK.
    Version is 2.1.3-665fe09
    System is Xubuntu-12.04 (32-bit)

    Code:
    *****************************************
    **** Debian package creation selected ***
    *****************************************
    
    This package will be built according to these values: 
    
    0 -  Maintainer: [ root@xubuntu ]
    1 -  Summary: [ Package created with checkinstall 1.6.2 ]
    2 -  Name:    [ gtkpod ]
    3 -  Version: [ 2.1.3+git20130323 ]
    4 -  Release: [ 1 ]
    5 -  License: [ GPL ]
    6 -  Group:   [ checkinstall ]
    7 -  Architecture: [ i386 ]
    8 -  Source location: [ gtkpod ]
    9 -  Alternate source location: [  ]
    10 - Requires: [  ]
    11 - Provides: [ gtkpod ]
    12 - Conflicts: [  ]
    13 - Replaces: [  ]
    
    Enter a number to change any of them or press ENTER to continue: 
    
    Installing with make install...
    
    ========================= Installation results ===========================
    Making install in libgtkpod
    make[1]: Entering directory `/home/ron/gtkpod/libgtkpod'
    make[2]: Entering directory `/home/ron/gtkpod/libgtkpod'
    test -z "/usr/local/lib" || /bin/mkdir -p "/usr/local/lib"
     /bin/bash ../libtool   --mode=install /usr/bin/install -c   libgtkpod.la '/usr/local/lib'
    libtool: install: /usr/bin/install -c .libs/libgtkpod.so.1.1.0 /usr/local/lib/libgtkpod.so.1.1.0
    libtool: install: (cd /usr/local/lib && { ln -s -f libgtkpod.so.1.1.0 libgtkpod.so.1 || { rm -f libgtkpod.so.1 && ln -s libgtkpod.so.1.1.0 libgtkpod.so.1; }; })
    libtool: install: (cd /usr/local/lib && { ln -s -f libgtkpod.so.1.1.0 libgtkpod.so || { rm -f libgtkpod.so && ln -s libgtkpod.so.1.1.0 libgtkpod.so; }; })
    libtool: install: /usr/bin/install -c .libs/libgtkpod.lai /usr/local/lib/libgtkpod.la
    libtool: install: /usr/bin/install -c .libs/libgtkpod.a /usr/local/lib/libgtkpod.a
    libtool: install: chmod 644 /usr/local/lib/libgtkpod.a
    libtool: install: ranlib /usr/local/lib/libgtkpod.a
    libtool: finish: PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/sbin" ldconfig -n /usr/local/lib
    ----------------------------------------------------------------------
    Libraries have been installed in:
       /usr/local/lib
    Attached Images Attached Images

Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •