View Poll Results: Has this thread been helpful?

Voters
811. You may not vote on this poll
  • Yes

    550 67.82%
  • No

    104 12.82%
  • Somewhat

    157 19.36%
Page 82 of 184 FirstFirst ... 3272808182838492132182 ... LastLast
Results 811 to 820 of 1832

Thread: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

  1. #811
    Join Date
    Jan 2005
    Beans
    Hidden!
    Distro
    Kubuntu 8.04 Hardy Heron

    Re: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

    This has been a bit of a pain, but it actually works for mapping multiple 'known' points in your /etc/network/interfaces file. I've got some ideas from here, which helped me fix the mapping problems I was having when I was using my own script. His information is for WEP, but this will also work for WPA, as you will see below.

    First, you'll want to create /etc/network/wlan-scanning.sh:
    Code:
    #!/bin/sh
    #
    #  Written by Thomas Dilts 20060719, Trivial fixups by Shawn Holwegner.
    #  This script is designed to be run by the "interfaces" system to find which
    #  wireless networks are present and return the first found interface.
    #
    #We must run as root (id -u returns then 0) and we must have the interface name as input
    if [ `id -u` -ne "0" ] || [ "$1" = "" ]; then exit 1; fi
    
    iface="$1"
    which=""
    # With this method, You only need one scan, instead of scanning for each SSID until you find the AP.
    FOUNDAPS=`/sbin/iwlist "$iface" scanning  | grep ESSID`
    while read searchstring returnvalue ; do
            if [ "$which" ]; then continue; fi
            echo "     Trying to find wlan $searchstring" >&2
            if echo "$FOUNDAPS" | /bin/grep -c "$searchstring" >/dev/null2>&1
            then
                    which="$returnvalue" ;
                    echo "     found $searchstring and now starting $which" >&2
            fi
    done
    
    if [ "$which" ]; then echo $which; exit 0; fi
    exit 1
    Remember to chmod it 775 so it can run.

    Now, edit your mappings in /etc/network/interfaces as so:

    Code:
    auto eth1
    mapping eth1
      script /etc/network/wlan-scanning.sh
      map HomeSSID HOME
      map WorkSSID WORK
      map key:off TRAVELING
    
    iface HOME inet dhcp
      wpa-ssid HomeSSID
      wpa-psk wpa_key_generated_with_wpa_passphrase_here
      ... 
    
    iface WORK inet dhcp
      wpa-ssid WorkSSID
      wpa-psk wpa_key_generated_with_wpa_passphrase_here
      ...
    
    #This is the open system setup that works at hotels and airports.
    iface TRAVELING inet dhcp
    iface eth1 inet dhcp
    It's actually pretty simple to use, once you have it setup. It will scan for any of the 'known' SSIDs in your mapping, and execute wpa_supplicant with the correct data. Priorly, I had been using a custom ifup interface and a cobbled together wpa_supplicant.conf that set priorities for different SSIDs. It also took about 5 seconds to bring the interface up. Now? About 2.

    I hope this helps others, many thanks to Thomas Dilts for a functional mapping script.

    If you run it manually, it will tell you what it's looking for, and what it finds. Using the '-v' flag coupled with ifup will give useful debugging information.

    Code:
    %sudo ifup eth1
    Trying to find wlan HomeSSID
    Trying to find wlan WorkSSID
    Found WorkSSID and now starting WORK
    Last edited by neptho; September 18th, 2007 at 09:39 AM. Reason: Trivial fixes added
    Registered Linux user #32508.
    I use openSUSE on my Latitude E6500.

  2. #812
    Join Date
    Jan 2007
    Location
    United States, VA
    Beans
    856
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

    I am having problems with my wireless on startup. It does not always connect on startup, it drops connections randomly, and Network Manager does not cooperate with my setup.

    route -n:
    Code:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
    192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
    169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
    0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
    iwconfig:
    Code:
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    Warning: Driver for device wlan0 has been compiled with version 22
    of Wireless Extension, while this program supports up to version 20.
    Some things may be broken...
    
    wlan0     IEEE 802.11g  ESSID:"mason"  
              Mode:Managed  Frequency:2.422 GHz  Access Point: 00:13:10:C8:97:8D   
              Bit Rate=36 Mb/s   Tx-Power:32 dBm   
              RTS thr=2347 B   Fragment thr=2346 B   
              Power Management:off
              Link Quality:62/100  Signal level:-56 dBm  Noise level:-96 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    ifconfig:
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:15:C5:B7:17:A9  
              inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
              Interrupt:22 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:8 errors:0 dropped:0 overruns:0 frame:0
              TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:516 (516.0 b)  TX bytes:516 (516.0 b)
    
    wlan0     Link encap:Ethernet  HWaddr 00:18:F3:57:D5:3D  
              inet addr:192.168.1.102  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::218:f3ff:fe57:d53d/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:3320 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2334 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:2547642 (2.4 MiB)  TX bytes:331565 (323.7 KiB)
              Interrupt:16 Memory:efdfc000-efe00000
    route:
    Code:
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.2.0     *               255.255.255.0   U     0      0        0 eth0
    192.168.1.0     *               255.255.255.0   U     0      0        0 wlan0
    link-local      *               255.255.0.0     U     1000   0        0 wlan0
    default         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
    cat /etc/network/interfaces:
    Code:
    #auto eth0
    #iface eth0 inet dhcp
    
    #auto eth1
    #iface eth1 inet dhcp
    
    #auto eth2
    #iface eth2 inet dhcp
    
    #auto ath0
    #iface ath0 inet dhcp
    
    auto wlan0
    iface wlan0 inet dhcp
    wpa-driver wext
    wpa-ssid ***** #censored!
    wpa-ap-scan 1
    wpa-proto RSN
    wpa-pairwise TKIP
    wpa-group TKIP
    wpa-key-mgmt WPA-PSK
    wpa-psk 1072992ef365767275eb91331246b79ceb8175e359df3dfbc18f01704ac001fe
    cat /etc/modprobe.d/ndiswrapper:
    Code:
    alias wlan0 ndiswrapper
    cat /etc/resolv.conf:
    Code:
    nameserver 68.87.73.242
    nameserver 68.87.71.226

  3. #813
    Join Date
    May 2006
    Location
    100acrewood
    Beans
    7,480
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

    Quote Originally Posted by st33med View Post
    I am having problems with my wireless on startup. It does not always connect on startup, it drops connections randomly, and Network Manager does not cooperate with my setup.
    It's close to impossible to judge from here what could be going on. Network Manager usually does a better job at reconnecting, however, under the circumstances it is no option I guess.

    What wireless adapter have you got?

    WICD might be an alternative for you if everything else fails. If reconnecting after boot is the issue, then see post #2.

  4. #814
    Join Date
    Sep 2007
    Beans
    102
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

    I followed these steps (after trying ALOT of other methods) but couldnt get it to work. I decided to test if it would work after a reboot, instead I was given the gnome-settings-daemon error.

    Initially having no idea what had happened (I couldn't login), I managed to pin-point it back to the /etc/network/interfaces file I just edited.

    The bug has been discussed here:

    https://bugs.launchpad.net/ubuntu/+s...ter/+bug/61381

    and more specifically:

    https://bugs.launchpad.net/ubuntu/+s...81/comments/43

    https://bugs.launchpad.net/ubuntu/+s...81/comments/23

    However, during that time, my wireless was working!

    Is there anything I can try? I can remember another guide adding something like DISABLED=1 to /etc/wpa_supplicant.conf (I saw it mentioned in the Launchpad thread)... Is that the correct command?

  5. #815
    Join Date
    Apr 2007
    Beans
    6

    Re: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

    I have a Belkin 54g PC card, and it is connected to a Netgear WGR614v7 using WEP. I have SSID broadcast OFF, and the key is 128bit Hex.

    I'm using WEP for now, as I have another notebook with a wireless B card. In time I'll find another great deal on a G card, and go to WPA-PSK.

    Until then, I'm using WEP, and securing it as best I can. I start the notebook (or after it wakes from hibernate) and then have to enter the network manager > connect to other wireless manager. I enter the information, and connect. Can I save this information in some way, and streamline the process. I'd like to keep things simple, as I take this notebook to other locations, and do not want to complicate things going forward.

    Here is iwconfig
    Code:
               iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     IEEE 802.11g  ESSID:"STATIONID"  
              Mode:Managed  Frequency:2.427 GHz  Access Point: 00:1B:2F:55:C0:32   
              Bit Rate=54 Mb/s   Tx-Power:32 dBm   
              RTS thr=2347 B   Fragment thr=2346 B   
              Power Management:off
              Link Quality:48/100  Signal level:-65 dBm  Noise level:-96 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Iwlist scan:
    Code:
     iwlist scan
    
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    wlan0     Scan completed :
              Cell 01 - Address: 00:1B:2F:55:C0:32
                        ESSID:"STATIONID"
                        Protocol:IEEE 802.11g
                        Mode:Managed
                        Frequency:2.427 GHz (Channel 4)
                        Quality:51/100  Signal level:-63 dBm  Noise level:-96 dBm
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                                  11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                                  48 Mb/s; 54 Mb/s
                        Extra:bcn_int=100
                        Extra:atim=0
    Finally, my network interface config:

    Code:
    sudo gedit /etc/network/interfaces
    
    auto lo
    iface lo inet loopback
    I've read some posts in this thread, and I'm looking for some help to alter my config, so that I can connect to my home wireless with as few steps as possible.

    Thanks.

  6. #816
    Join Date
    Sep 2007
    Beans
    3

    Re: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

    I have experienced that I have to restart networking multiple times to get connected. Is there a more reliable method to get connected?

  7. #817
    Join Date
    May 2006
    Location
    100acrewood
    Beans
    7,480
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

    Quote Originally Posted by gladstone View Post
    I followed these steps (after trying ALOT of other methods) but couldnt get it to work. I decided to test if it would work after a reboot, instead I was given the gnome-settings-daemon error.

    Initially having no idea what had happened (I couldn't login), I managed to pin-point it back to the /etc/network/interfaces file I just edited.

    The bug has been discussed here:

    https://bugs.launchpad.net/ubuntu/+s...ter/+bug/61381

    and more specifically:

    https://bugs.launchpad.net/ubuntu/+s...81/comments/43

    https://bugs.launchpad.net/ubuntu/+s...81/comments/23

    However, during that time, my wireless was working!

    Is there anything I can try? I can remember another guide adding something like DISABLED=1 to /etc/wpa_supplicant.conf (I saw it mentioned in the Launchpad thread)... Is that the correct command?
    If you posted the contents of "/etc/network/interfaces" it would help a lot. I don't know if "DISABLED=1" is the right command at the moment.

  8. #818
    Join Date
    May 2006
    Location
    100acrewood
    Beans
    7,480
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

    Quote Originally Posted by lorenmcc View Post
    I have experienced that I have to restart networking multiple times to get connected. Is there a more reliable method to get connected?
    Have you noticed post #2? It might be the solution.

  9. #819
    Join Date
    May 2006
    Location
    100acrewood
    Beans
    7,480
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

    Quote Originally Posted by Target2019 View Post
    I have a Belkin 54g PC card, and it is connected to a Netgear WGR614v7 using WEP. I have SSID broadcast OFF, and the key is 128bit Hex.

    I'm using WEP for now, as I have another notebook with a wireless B card. In time I'll find another great deal on a G card, and go to WPA-PSK.

    Until then, I'm using WEP, and securing it as best I can. I start the notebook (or after it wakes from hibernate) and then have to enter the network manager > connect to other wireless manager. I enter the information, and connect. Can I save this information in some way, and streamline the process. I'd like to keep things simple, as I take this notebook to other locations, and do not want to complicate things going forward.

    Here is iwconfig
    Code:
               iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     IEEE 802.11g  ESSID:"STATIONID"  
              Mode:Managed  Frequency:2.427 GHz  Access Point: 00:1B:2F:55:C0:32   
              Bit Rate=54 Mb/s   Tx-Power:32 dBm   
              RTS thr=2347 B   Fragment thr=2346 B   
              Power Management:off
              Link Quality:48/100  Signal level:-65 dBm  Noise level:-96 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Iwlist scan:
    Code:
     iwlist scan
    
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    wlan0     Scan completed :
              Cell 01 - Address: 00:1B:2F:55:C0:32
                        ESSID:"STATIONID"
                        Protocol:IEEE 802.11g
                        Mode:Managed
                        Frequency:2.427 GHz (Channel 4)
                        Quality:51/100  Signal level:-63 dBm  Noise level:-96 dBm
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                                  11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                                  48 Mb/s; 54 Mb/s
                        Extra:bcn_int=100
                        Extra:atim=0
    Finally, my network interface config:

    Code:
    sudo gedit /etc/network/interfaces
    
    auto lo
    iface lo inet loopback
    I've read some posts in this thread, and I'm looking for some help to alter my config, so that I can connect to my home wireless with as few steps as possible.

    Thanks.
    Well, you could follow this tutorial which should make it as simple as possible for you. If you encounter problems you could just post here.

    Another solution for you might be WICD:

    http://wicd.sourceforge.net/

  10. #820
    Join Date
    Apr 2007
    Beans
    6

    Re: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

    Quote Originally Posted by wieman01 View Post
    Well, you could follow this tutorial which should make it as simple as possible for you. If you encounter problems you could just post here.

    Another solution for you might be WICD:

    http://wicd.sourceforge.net/
    Thanks for the link to WICD. I'll check that out.

    Assuming by tutorial, you mean the first post or two, I have read that. I did not find WEP mentioned, so I searched the thread with google. I found some posts tht tried to address WEP specifically, read them, and was confused. So I posted the results of what I have in configuration, as I had seen done many times in this thread.

    Thanks again for the reference to WICD.

Page 82 of 184 FirstFirst ... 3272808182838492132182 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •