View Poll Results: Has this thread been helpful?

Voters
811. You may not vote on this poll
  • Yes

    550 67.82%
  • No

    104 12.82%
  • Somewhat

    157 19.36%
Page 4 of 184 FirstFirst ... 234561454104 ... LastLast
Results 31 to 40 of 1832

Thread: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

  1. #31
    Join Date
    May 2005
    Beans
    6

    Re: WPA2 / RSN, NDiswrapper, Static IP, Hidden ESSID, WUSB54G V4

    Quote Originally Posted by wieman01 View Post
    Using "ndiswrapper"? And what "wpa-driver" are you using (I assume "wext")? Just for the record...
    I am using ndiswrapper and wext, it looks like wpa_supplicator doesn't work with standard bcm43xx driver, although if you don't need WPA bcm43xx works reasonably well. Few more details I am on edgy and ndiswrapper and wpa_supplicant are from standard edgy repositories as well. And I also have issue with network restart.

  2. #32
    Join Date
    Aug 2005
    Location
    Gold Coast, Queensland,AU
    Beans
    224
    Distro
    Ubuntu 11.04 Natty Narwhal

    Talking Re: WPA2 / RSN, NDiswrapper, Static IP, Hidden ESSID, WUSB54G V4

    This thread resulted in my getting a Broadcom 4318 wireless installed and running with WPA(1) under Edgy. I am basically using your example '*Sample configuration WPA1 & DHCP, ESSID broadcast enabled*' from your message #1. Thanks very much.

    A slight improvement on this is that actually, to get wireless up at bootup, all you need is to do this as root:
    echo 'ifdown wlan0' >/etc/init.d/WlanDown
    chmod +x /etc/init.d/WlanDown
    ln -s ../init.d/WlanDown /etc/rcS.d/S40WlanDown
    This runs S40WlanDown just before S40networking, so tidies up something in the wlan setup. Then S40networking runs ../init.d/networking which runs 'ifup -a' which successfully starts wlan0 and all other interfaces.

    The source problem is a bug whereby at shutdown 'ifdown -a' does not seem to run (successfully) :not effectively doing an 'ifdown wlan0'.

    Now I just gotta find again (for the record) where is the other forum message that told me where to get a tarball, that had the driver, and a script to do a lot of the work for me.
    Last edited by DavidTangye; November 23rd, 2006 at 10:52 PM. Reason: .
    The last great frontier is In Your Mind!

  3. #33
    Join Date
    May 2006
    Location
    100acrewood
    Beans
    7,480
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: WPA2 / RSN, NDiswrapper, Static IP, Hidden ESSID, WUSB54G V4

    Quote Originally Posted by DavidTangye View Post
    This thread resulted in my getting a Broadcom 4318 wireless installed and running with WPA(1) under Edgy. I am basically using your example '*Sample configuration WPA1 & DHCP, ESSID broadcast enabled*' from your message #1. Thanks very much.

    A slight improvement on this is that actually, to get wireless up at bootup, all you need is

    This runs S40WlanDown just before S40networking, so tidies up something in the wlan setup. Then S40networking runs ../init.d/networking which runs 'ifup -a' which successfully starts wlan0 and all other interfaces.
    Great. Thank you as well for the script. I will try it out sometime this week & update the guide.

    Would you mind sharing your configuration with us? So the I can take a glance at the "wpa-driver", etc. Just curious, and it it perhaps helpful for others with Broadcom chipsets as well.

  4. #34
    Join Date
    Aug 2006
    Location
    UK
    Beans
    441
    Distro
    Ubuntu

    Re: WPA2 / RSN, NDiswrapper, Static IP, Hidden ESSID, WUSB54G V4

    Quote Originally Posted by DavidTangye View Post
    This thread resulted in my getting a Broadcom 4318 wireless installed and running with WPA(1) under Edgy. I am basically using your example '*Sample configuration WPA1 & DHCP, ESSID broadcast enabled*' from your message #1. Thanks very much.

    A slight improvement on this is that actually, to get wireless up at bootup, all you need is

    This runs S40WlanDown just before S40networking, so tidies up something in the wlan setup. Then S40networking runs ../init.d/networking which runs 'ifup -a' which successfully starts wlan0 and all other interfaces.

    The source problem is a bug whereby at shutdown 'ifdown -a' does not seem to run (successfully) :not effectively doing an 'ifdown wlan0'.

    Now I just gotta find again (for the record) where is the other forum message that told me where to get a tarball, that had the driver, and a script to do a lot of the work for me.
    Hi,

    I assume by 'bootup' you mean outside of X windows in a plain old terminal? Before X is loaded, perhaps in Recovery Mode?

    I can see why this would be useful.

    Thanks.
    "My mind is aglow with whirling, transient nodes of thought careening through a cosmic vapor of invention." - Hedley Lamarr
    Lenovo T500 2243-4EG

  5. #35
    Join Date
    May 2006
    Location
    100acrewood
    Beans
    7,480
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: WPA2 / RSN, NDiswrapper, Static IP, Hidden ESSID, WUSB54G V4

    Quote Originally Posted by tedrogers View Post
    Hi,

    I assume by 'bootup' you mean outside of X windows in a plain old terminal? Before X is loaded, perhaps in Recovery Mode?

    I can see why this would be useful.
    Yes, this kind of operation can only be run as "root" process. Once X is up & running you are sort confined as to what process you can run. That's to do with Linux' architecture (without going into detail). Found this link which may be interesting in that respect:

    https://wiki.ubuntu.com/StreamlinedB...ight=%28rcs%29

  6. #36
    Join Date
    Aug 2006
    Location
    UK
    Beans
    441
    Distro
    Ubuntu

    Re: WPA2 / RSN, NDiswrapper, Static IP, Hidden ESSID, WUSB54G V4

    When I run this in X windows...

    Code:
    echo 'ifdown wlan0' >/etc/init.d/WlanDown
    ln -s ../init.d/WlanDown /etc/rcS.d/S40WlanDown
    ...I get permission denied...even with sudo appended to the front.

    Do I need to run this in a root terminal, or by CTRL + ALT + F1 and logging in?

    Also have you tried this yet Wieman?

    Thanks.
    "My mind is aglow with whirling, transient nodes of thought careening through a cosmic vapor of invention." - Hedley Lamarr
    Lenovo T500 2243-4EG

  7. #37
    Join Date
    May 2006
    Location
    100acrewood
    Beans
    7,480
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: WPA2 / RSN, NDiswrapper, Static IP, Hidden ESSID, WUSB54G V4

    Deleted...
    Last edited by wieman01; November 16th, 2006 at 12:37 PM.

  8. #38
    Join Date
    Aug 2006
    Location
    UK
    Beans
    441
    Distro
    Ubuntu

    Re: WPA2 / RSN, NDiswrapper, Static IP, Hidden ESSID, WUSB54G V4

    Even if I run these using sudo...

    Code:
    sudo echo 'ifdown wlan0' >/etc/init.d/WlanDown
    sudo ln -s ../init.d/WlanDown /etc/rcS.d/S40WlanDown
    ...I get permission denied.

    Could this be because of the chmod command we ran before to change permissions on the wlan config files?
    "My mind is aglow with whirling, transient nodes of thought careening through a cosmic vapor of invention." - Hedley Lamarr
    Lenovo T500 2243-4EG

  9. #39
    Join Date
    Aug 2006
    Location
    UK
    Beans
    441
    Distro
    Ubuntu

    Re: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

    Sorry for the double post here, but the solution is listed at this post:

    http://ubuntuforums.org/showthread.php?t=299651

    Basically, these commands need to run at a root terminal. To get access through a normal terminal, type the following:

    Code:
    sudo -i
    Then issue these commands without the 'sudo' prefix (as mentioned by me previously).

    Code:
    echo 'ifdown wlan0' >/etc/init.d/WlanDown
    ln -s ../init.d/WlanDown /etc/rcS.d/S40WlanDown
    Alternatively, you should be able to run the root terminal from the Application > System Tools menu...as long as you have enabled this option within the Preferences > Menu Layout configuration.

    Hope this helps.
    Last edited by tedrogers; November 14th, 2006 at 08:52 PM. Reason: Errors corrected
    "My mind is aglow with whirling, transient nodes of thought careening through a cosmic vapor of invention." - Hedley Lamarr
    Lenovo T500 2243-4EG

  10. #40
    Join Date
    Aug 2005
    Location
    Gold Coast, Queensland,AU
    Beans
    224
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.

    Quote Originally Posted by tedrogers
    sudo echo 'ifdown wlan0' >/etc/init.d/WlanDown
    Yes this line is incorrect because >/etc/init.d/WlanDown is checked in the shell that presents that line, ie your current shell. At that point 'you' are the command presenter not root, so 'you' get the erro message that 'you' do not have the necessary permissions, and the sudo command is not even attempted.

    This works:
    sudo bash -c 'echo "ifdown wlan0" >/etc/init.d/WlanDown'
    because here the access to /etc/init.d/WlanDown is not attempted until a bash shell is run by the user root.

    The command "echo 'ifdown wlan0' >/etc/init.d/WlanDown" must be run by root, from a bash shell started by, eg
    • "sudo -i" (login fully and run your default shell, probably bash), or
    • "sudo bash" (just run a bash shall)
    • "sudo bash -c ... " (just run a single command in a bash shell as per above)
    The last great frontier is In Your Mind!

Page 4 of 184 FirstFirst ... 234561454104 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •