Page 3 of 106 FirstFirst 123451353103 ... LastLast
Results 21 to 30 of 1059

Thread: HOWTO: Setup Samba peer-to-peer with Windows

  1. #21
    Join Date
    Mar 2006
    Beans
    258

    Re: HOWTO: Setup Samba peer-to-peer with Windows

    I'm now fully networked, write access and all, with my brother's PC. All thanks to the help recieved here, giving me the courage and the knowledge to get my hands dirty and actually set this up, where normally I would rely entirely on automated installers.

    I doubt I'd be able to articulate how to do all this to anyone else, over the phone or 'net, but if anyone ever asked me to go over to their house to set up an XP/Ubuntu network I know I'd be able to do so with confidence.

    I just wanted to say thank you to all the people involved in this thread for sharing your knowledge and being patient with our problems

  2. #22
    Join Date
    Jul 2006
    Beans
    13

    Re: HOWTO: Setup Samba peer-to-peer with Windows

    So ah... didnt work.

    I followed the instructions. When I go to map network drive on my winXP box, it looks but doesnt find anything. Im (really really) sure I have the ip address right and the share name right.

    Could it be that I'm trying to share /home/share ? I tried changing some things according to the Wiki to be able to read/write home directories, but still, the samba share isnt being seen by my xp computer.

    My xp account is Matt, and the account on my ubuntu machine is matt, with different passwords. I added matt, Matt, and just to be safe MATT, as samba users, still no effect.

    I feel like I'm missing something... any clues?

    Thanks

  3. #23
    Join Date
    Dec 2005
    Location
    Vienna, Austria
    Beans
    155
    Distro
    Ubuntu

    Re: HOWTO: Setup Samba peer-to-peer with Windows

    Quote Originally Posted by AsYouWish View Post
    My xp account is Matt, and the account on my ubuntu machine is matt, with different passwords. I added matt, Matt, and just to be safe MATT, as samba users, still no effect.
    Having different passwords across two machines for the same useraccount is a most common pitfall.

    You added the useraccount to Samba (btw: there's no need for Upper-/Lowercase as Windows ignores the cases in a standard setup - so simply delete the ones having different spelling to the one of your Linux box) --- but with WHICH password?

    - If you gave the user the password of your Linux box it's the wrong one. Change it with smbpasswd to the correct one.
    - If you gave the user the password of your Windows box it's the right one and everything _should_ work ok.

    Samba not displaying anything usually means...

    ...the user isn't enabled on the Linux box (sudo smbpasswd -e <username>)
    ...the password of the user accounts don't match.
    ...that one of the systems is inside the wrong workgroup.

    That's all I can think of by looking at your post.

    -Storm

  4. #24
    Join Date
    Jul 2006
    Beans
    13

    Re: HOWTO: Setup Samba peer-to-peer with Windows

    Ok so... that didnt work. Here is my smb.conf. I've tried several differnt version but this is straight from your howto.

    My smb.conf:

    Code:
    [global]
        ; General server settings
        netbios name = server
        server string =
        workgroup = mshome
        announce version = 5.0
        socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
    
        passdb backend = tdbsam
        security = user
        null passwords = true
        username map = /etc/samba/smbusers
        name resolve order = hosts wins bcast
    
        wins support = yes
    
        printing = CUPS
        printcap name = CUPS
    
        syslog = 1
        syslog only = yes
    
    ; NOTE: If you need access to the user home directories uncomment the
    ; lines below and adjust the settings to your hearts content.
    ;[homes]
        ;valid users = %S
        ;create mode = 0600
        ;directory mode = 0755
        ;browseable = no
        ;read only = no
        ;veto files = /*.{*}/.*/mail/bin/
    
    ; NOTE: Only needed if you run samba as a primary domain controller.
    ; Not needed as this config doesn't cover that matter.
    ;[netlogon]
        ;path = /var/lib/samba/netlogon
        ;admin users = Administrator
        ;valid users = %U
        ;read only = no
    
    ; NOTE: Again - only needed if you're running a primary domain controller.
    ;[Profiles]
        ;path = /var/lib/samba/profiles
        ;valid users = %U
        ;create mode = 0600
        ;directory mode = 0700
        ;writeable = yes
        ;browseable = no
    
    ; NOTE: Inside this place you may build a printer driver repository for
    ; Windows - I'll cover this topic in another HOWTO.
    [print$]
        path = /var/lib/samba/printers
        browseable = yes
        guest ok = yes
        read only = yes
        write list = root
        create mask = 0664
        directory mask = 0775
    
    [printers]
        path = /tmp
        printable = yes
        guest ok = yes
        browseable = no
    
    ; Uncomment if you need to share your CD-/DVD-ROM Drive
    ;[DVD-ROM Drive]
        ;path = /media/cdrom
        ;browseable = yes
        ;read only = yes
        ;guest ok = yes
    
    [Files]
        path = /media/share/
        browseable = yes
        read only = no
        guest ok = no
        create mask = 0644
        directory mask = 0755
        force user = matt
        force group = matt
    So my ubuntu acct is matt with password1 and my winxp accoutn is Matt with password2. I set and enabled user 'matt' with password2 in smbpasswd. Still nothing. When I enter \\192.168.1.102\Files I get a pause, and then a 'could not be located' error.

    Does it matter Im running this on a PPC?
    Does it matter that \media\share is not actual media but just a dir I created?
    Does it matter that i'm setting this up via VNC to desktop 1 (not 0)

    Argh. Sorry to be a pain. Thanks.

  5. #25
    Join Date
    Dec 2005
    Location
    Vienna, Austria
    Beans
    155
    Distro
    Ubuntu

    Re: HOWTO: Setup Samba peer-to-peer with Windows

    Your smb.conf looks fine - and it shouldn't matter that you're running Ubuntu PPC.

    Try the following command inside a Terminal ...

    # smbclient -L localhost -U%

    When asked for a password you need to type "password2".

    If the command returns an error you either entered the wrong password or there's something fishy with your samba setup. You should see something like this ...

    Code:
    Domain=[STORMBRINGER] OS=[Unix] Server=[Samba 3.0.22-Ubuntu]
    
            Sharename       Type      Comment
            ---------       ----      -------
            netlogon        Disk      Network Logon Service
            print$          Disk      Printer Drivers
            IPC$            IPC       IPC Service (nebuchanezzar)
            ADMIN$          IPC       IPC Service (nebuchanezzar)
    Domain=[MSHOME] OS=[Unix] Server=[Samba 3.0.22-Ubuntu]
    
            Server               Comment
            ---------            -------
            NEBUCHADNEZZAR       
    
            Workgroup            Master
            ---------            -------
            STORMBRINGER         NEBUCHADNEZZAR
    If you get a result similar to the one from right above then samba is running and doing fine.

    If not, let's see if Windows is freaking out...

    Try to ping your Windows box from Linux and vice versa just to make absolutely sure that you're network connection is fine.

    If this works please take a look into the Firewall control panel in Windows and make sure that the firewall is either disabled or "File- and Printersharing" is allowed to pass through the firewall.

    Try to disable "Require SignOrSeal" (encrypted smb-connections) in Windows XP ...

    To make this an easy job simply paste to following lines into notepad and save it as DisableReqSignOrSeal.reg (or any filename you like)

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters]
    "requiresignorseal"=dword:00000000
    Open the location where you saved the file, double-click, and confirm the dialog.

    Reboot and try again...

    It should be sufficient to paste this line into any open Explorer windows: \\192.168.1.102\Files

    If it still doesn't work, try to connect to the share from the command-line:

    net use x: \\192.168.1.102\Files password2 /user:matt /persistent:yes

    Try these steps and tell me how it turned out.

  6. #26
    Join Date
    Jul 2006
    Beans
    13

    Re: HOWTO: Setup Samba peer-to-peer with Windows

    Yeah... I'm a retard. Forgot about ZoneAlarm... silently blocking me from the outside world. Couldnt ping the XP box from Ubuntu so I added 192.168.1.100-110 to the trusted zone and bingo. Fully functional.


    Thanks so much.

  7. #27
    Join Date
    May 2006
    Location
    Las Vegas
    Beans
    12
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Setup Samba peer-to-peer with Windows

    Well first of all I would like to say thank you very much for this post!!
    But Im haveing a few issues that I can't quite solve. I can ping my linux box from a windows box and vice versa, but I can't exchange any data or map a drive. I tried everything in your post, but I still get, from both boxes, that permission is required. Here is my output when I type

    smbclient -L localhost -U%

    Domain=[WINBLOWS] OS=[Unix] Server=[Samba 3.0.22]

    Sharename Type Comment
    --------- ---- -------
    ADMIN$ IPC IPC Service ()
    IPC$ IPC IPC Service ()
    MyFiles Disk
    print$ Disk
    Domain=[WINBLOWS] OS=[Unix] Server=[Samba 3.0.22]

    Server Comment
    --------- -------
    DARE-DEVIL

    Workgroup Master
    --------- -------
    WINBLOWS DARE-DEVIL


    and this is my smb.cfg file setup

    [global]
    ; General server settings
    netbios name = dare-devil
    server string =
    workgroup = WINBLOWS
    announce version = 5.0
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
    ;interfaces = lo, eth0
    ;bind interfaces only = true

    passdb backend = tdbsam
    security = user
    null passwords = true
    username map = /etc/samba/smbusers
    name resolve order = hosts wins bcast

    wins support = yes

    printing = CUPS
    printcap name = CUPS

    syslog = 1
    syslog only = yes

    ; NOTE: If you need access to the user home directories uncomment the
    ; lines below and adjust the settings to your hearts content.
    ;[homes]
    ;valid users = %S
    ;create mode = 0600
    ;directory mode = 0755
    ;browseable = no
    ;read only = no
    ;veto files = /*.{*}/.*/mail/bin/

    ; NOTE: Only needed if you run samba as a primary domain controller.
    ; Not needed as this config doesn't cover that matter.
    ;[netlogon]
    ;path = /var/lib/samba/netlogon
    ;admin users = dare-devil
    ;valid users = %U
    ;read only = no

    ; NOTE: Again - only needed if you're running a primary domain controller.
    ;[Profiles]
    ;path = /var/lib/samba/profiles
    ;valid users = %U
    ;create mode = 0600
    ;directory mode = 0700
    ;writeable = yes
    ;browseable = no

    ; NOTE: Inside this place you may build a printer driver repository for
    ; Windows - I'll cover this topic in another HOWTO.
    [print$]
    path = /var/lib/samba/printers
    browseable = yes
    guest ok = yes
    read only = yes
    write list = root
    create mask = 0664
    directory mask = 0775

    [printers]
    path = /tmp
    printable = yes
    guest ok = yes
    browseable = no

    ;Uncomment if you need to share your CD-/DVD-ROM Drive
    [DVD-ROM Drive]
    path = /media/dvd-rw
    browseable = yes
    read only = yes
    guest ok = yes

    [MyFiles]
    path = /home/dare-devil/
    browseable = yes
    read only = yes
    guest ok = yes
    create mask = 0644
    directory mask = 0755
    force user = dare-devil
    force group = WINBLOWS

    Any help would be greatly appreciated Storm!! Again thanks so much for your time you have put into making this post.

  8. #28
    Join Date
    Dec 2005
    Location
    Vienna, Austria
    Beans
    155
    Distro
    Ubuntu

    Re: HOWTO: Setup Samba peer-to-peer with Windows

    Ok, let's see if we can get your problem solved ...

    - About the "permission is required" thing:
    What's the exact error message and what do you do to get it?

    - About your smb.conf
    Wait a sec; what's that?

    Code:
    [MyFiles]
        path = /home/dare-devil/
        browseable = yes
        read only = yes
        guest ok = yes
        create mask = 0644
        directory mask = 0755
        force user = dare-devil
        force group = WINBLOWS
    Are you trying to share your home directory? That won't work out that way.

    EDIT What's the "force group" ??? "WINBLOWS"? All uppercase? That looks dead wrong unless you created such a group yourself.

    Code:
        force user = dare-devil
        force group = dare-devil
    Would be more right.
    /EDIT

    If you like to "share" your home, then you should do it that way instead ...

    Code:
    [global]
        ; General server settings
        netbios name = dare-devil
        server string =
        workgroup = WINBLOWS
        announce version = 5.0
        socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
        ;interfaces = lo, eth0
        ;bind interfaces only = true
    
        passdb backend = tdbsam
        security = user
        null passwords = true
        username map = /etc/samba/smbusers
        name resolve order = hosts wins bcast
    
        wins support = yes
    
        printing = CUPS
        printcap name = CUPS
    
        syslog = 1
        syslog only = yes
    
    ; NOTE: If you need access to the user home directories uncomment the
    ; lines below and adjust the settings to your hearts content.
    [homes]
        valid users = %S
        create mode = 0600
        directory mode = 0755
        browseable = no
        read only = no
        veto files = /*.{*}/.*/mail/bin/
    
    ; NOTE: Only needed if you run samba as a primary domain controller.
    ; Not needed as this config doesn't cover that matter.
    ;[netlogon]
        ;path = /var/lib/samba/netlogon
        ;admin users = dare-devil
        ;valid users = %U
        ;read only = no
    
    ; NOTE: Again - only needed if you're running a primary domain controller.
    ;[Profiles]
        ;path = /var/lib/samba/profiles
        ;valid users = %U
        ;create mode = 0600
        ;directory mode = 0700
        ;writeable = yes
        ;browseable = no
    
    ; NOTE: Inside this place you may build a printer driver repository for
    ; Windows - I'll cover this topic in another HOWTO.
    [print$]
        path = /var/lib/samba/printers
        browseable = yes
        guest ok = yes
        read only = yes
        write list = root
        create mask = 0664
        directory mask = 0775
    
    [printers]
        path = /tmp
        printable = yes
        guest ok = yes
        browseable = no
    
    ;Uncomment if you need to share your CD-/DVD-ROM Drive
    [DVD-ROM Drive]
        path = /media/dvd-rw
        browseable = yes
        read only = yes
        guest ok = yes
    The difference is that I enabled the [homes] section and removed the share you declared at the bottom of the file.

    If the directory in question (/home/dare-devil) *IS NOT* the home directory of a valid user account but a badly placed data directory you like to share on the network you may have an issue with the filesystem permissions.

    # sudo chmod 0777 /home/dare-devil
    # sudo chown dare-devil.dare-devil /home/dare-devil

    Again - DO NOT ALTER the permissions if it's the home directory of a valid user account! You may break your local login.
    You've been warned.

    Restart samba (sudo /etc/init.d/samba restart) and map your home-directory (commandline example):

    net use h: \\dare-devil\dare-devil your_password /user:dare-devil /persistent:yes

    Awaiting your answer ...

    -Storm
    Last edited by Stormbringer; July 18th, 2006 at 06:36 PM.

  9. #29
    Join Date
    May 2006
    Location
    Las Vegas
    Beans
    12
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Setup Samba peer-to-peer with Windows

    Ok...thanks for the quick reply, I expected it to be a day or two!!

    Anyhow, in response, yes WINBLOWS is the name of the WORKGROUP I created on my windows box, and I just thought it would keep things simple if I used that as my force group. Did I figure wrong in my understanding of how this all works? I am new to samba, so i really appreciate all your help.

    Yes, /home/dare-devil is the home directory of a valid user account. I would like to share the whole directory, and I only want to share it with my home network not anything outside of it. I would like to be able to uncomment out the following so I can use your suggestion.

    ;interfaces = lo, eth0
    ;bind interfaces only = true

    Do these lines have anything to do with preventing me from being able to use the connection?

    As for the exact error message I get here is the screen dump for you.

    Ohh and it seems that I already kinda bokre my login on my linux box, because it was telling me that I shouldn't be sharing my home folder or something like that ahhhh

    Thanks again for any, and all your help, it reall is appreciated storm, your're a great penguin!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	MS screen dump.jpg 
Views:	166 
Size:	6.4 KB 
ID:	12931   Click image for larger version. 

Name:	MS screen dump 2.jpg 
Views:	156 
Size:	10.9 KB 
ID:	12932   Click image for larger version. 

Name:	Screenshot-nautilus.png 
Views:	166 
Size:	13.7 KB 
ID:	12933  

  10. #30
    Join Date
    Dec 2005
    Location
    Vienna, Austria
    Beans
    155
    Distro
    Ubuntu

    Re: HOWTO: Setup Samba peer-to-peer with Windows

    Quote Originally Posted by PENGUIN-PC View Post
    Ok...thanks for the quick reply, I expected it to be a day or two!!

    Anyhow, in response, yes WINBLOWS is the name of the WORKGROUP I created on my windows box, and I just thought it would keep things simple if I used that as my force group. Did I figure wrong in my understanding of how this all works? I am new to samba, so i really appreciate all your help.
    The "force group" parameter inside the definition of the share DOES NOT, i repeat: DOES NOT, refer to a Windows-Workgroup but to the group of the local useraccount(s) on your Linux box.

    So, "force group" should contain the same definition as "force user". But as you only like to share your home you won't need to bother with this directive.

    Quote Originally Posted by PENGUIN-PC View Post
    Yes, /home/dare-devil is the home directory of a valid user account. I would like to share the whole directory, and I only want to share it with my home network not anything outside of it. I would like to be able to uncomment out the following so I can use your suggestion.
    Kill the share you added at the bottom of the file and remove the comments at the [homes] section (remove the ";" at the beginning of the lines).

    Quote Originally Posted by PENGUIN-PC View Post
    ;interfaces = lo, eth0
    ;bind interfaces only = true

    Do these lines have anything to do with preventing me from being able to use the connection?
    Nope - the lines just tell samba to which network interfaces the daemon should bind by default; if it isn't specified it will bind to *any* available interface that is up.

    This is a very useful directive if your box has multiple interfaces (i.e. 2 network cards, wireless, firewire, bluetooth, and so on). By giving the names of the interfaces the daemon will only bind to the ones you configured; the ones not specified will be leaved out.

    Quote Originally Posted by PENGUIN-PC View Post
    As for the exact error message I get here is the screen dump for you.
    You actually can share your home directory ([homes] section of smb.conf), but trying it the way you did may lead to severe problems.

    Quote Originally Posted by PENGUIN-PC View Post
    Ohh and it seems that I already kinda bokre my login on my linux box, because it was telling me that I shouldn't be sharing my home folder or something like that ahhhh
    That's what the screenshot of the nautilus error-message suggests.

    Please type

    # ls -lisa /home
    # ls -lisa /home/dare-devil

    inside a terminal and paste the output into a post.

Page 3 of 106 FirstFirst 123451353103 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •