Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Can't Install OpenShot Because of Dependencies

  1. #1
    Join Date
    Nov 2011
    Beans
    11
    Distro
    Ubuntu 13.04 Raring Ringtail

    Can't Install OpenShot Because of Dependencies

    After I updated to 12.04, OpenShot wouldn't open, so I uninstalled it. Now, when I try to reinstall it in terminal, the installation fails and the following appears:
    Code:
    The following packages have unmet dependencies:
     openshot : Depends: python-mlt3 but it is not going to be installed or
                         python-mlt2 but it is not installable or
                         python-mlt but it is not installable
    E: Unable to correct problems, you have held broken packages.
    I currently have python-mlt5 installed. When, in Synaptic, I try to replace it with the older python-mlt3, it says python-mlt depends on libmlt4 and libmlt++3. However,those two packages are irreconcilable because libmlt++3 depends on libmlt5, not libmlt4.

    How can I install Openshot?

    Thanks.

  2. #2
    Join Date
    Nov 2011
    Beans
    11
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Can't Install OpenShot Because of Dependencies

    Bump.

  3. #3
    Join Date
    Aug 2007
    Location
    US
    Beans
    887
    Distro
    Ubuntu Development Release

    Re: Can't Install OpenShot Because of Dependencies

    Remove python-mlt5. Since you're using 12.04 you have absolutely no reason to be running quantal packages. This is causing your problems. Make sure your sources.list contains sources for only precise. Then you can install the appropriate versions of the packages this way:

    Code:
    sudo apt-get update
    sudo apt-get install libmlt4=0.7.6+git20120204-2 libmlt++3=0.7.6+git20120204-2 libmlt-data=0.7.6+git20120204-2 python-mlt3=0.7.6+git20120204-2
    Please mark completed threads as [SOLVED], which lets us find solutions faster!

  4. #4
    Join Date
    Nov 2011
    Beans
    11
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Can't Install OpenShot Because of Dependencies

    Thanks, ptn107. I followed your instructions and also inputted the following:
    Code:
    sudo apt-get install melt=0.7.6+git20120204-2
    because OpenShot requires melt.

    OpenShot installed, but it crashes whenever I try to open it, showing the following message:
    Code:
    ------------------------- ERROR 1 ------------------------------
    Failed to import 'from openshot import main'
    Error Message: cannot import name main
    ----------------------------------------------------------------
    --------------------------------
       OpenShot (version 1.4.2)
    --------------------------------
    Process no longer exists: 19444.  Creating new pid lock file.
    
    Detecting formats, codecs, and filters...
    Segmentation fault (core dumped)
    How could I determine the source of this problem?

  5. #5
    Join Date
    Nov 2011
    Beans
    11
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Can't Install OpenShot Because of Dependencies

    Bump.

  6. #6
    Join Date
    Aug 2007
    Location
    US
    Beans
    887
    Distro
    Ubuntu Development Release

    Re: Can't Install OpenShot Because of Dependencies

    Make sure openshot is the correct version. Your version 1.4.2 (1.4.2-1.1build1) is from quantal. In precise it's 1.4.0-1ubuntu1.
    I think your getting the error because 1.4.2 is supposed to use python-mlt5 and were trying to make it use python-mlt3.

    Code:
    sudo apt-get install openshot=1.4.0-1ubuntu1 openshot-doc=1.4.0-1ubuntu1
    Please mark completed threads as [SOLVED], which lets us find solutions faster!

  7. #7
    Join Date
    Nov 2011
    Beans
    11
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Can't Install OpenShot Because of Dependencies

    I downgraded to OpenShot 1.4.0 as you suggested, but the same error occurs with the same message (with 1.4.2 changed to 1.4.0.)

  8. #8
    Join Date
    Aug 2008
    Beans
    5

    Lightbulb Re: Can't Install OpenShot Because of Dependencies

    Quote Originally Posted by Utnubu42 View Post
    After I updated to 12.04, OpenShot wouldn't open, so I uninstalled it. Now, when I try to reinstall it in terminal, the installation fails and the following appears:
    Code:
    The following packages have unmet dependencies:
     openshot : Depends: python-mlt3 but it is not going to be installed or
                         python-mlt2 but it is not installable or
                         python-mlt but it is not installable
    E: Unable to correct problems, you have held broken packages.
    I currently have python-mlt5 installed. When, in Synaptic, I try to replace it with the older python-mlt3, it says python-mlt depends on libmlt4 and libmlt++3. However,those two packages are irreconcilable because libmlt++3 depends on libmlt5, not libmlt4.

    How can I install Openshot?

    Thanks.
    Hi, I am a Ubuntu newbie, but I just resolved a similar problem myself. I had problems with installing the package librapi2-tools. It depends on librapi2, which depends on libsynce0, which is installed, but not detected by APT when trying to install librapi2. The solution I found was to use apt-get build-dep librapi2 (suddenly 45 Mb to download though).

    Best wishes!

  9. #9
    Join Date
    Nov 2011
    Beans
    11
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Can't Install OpenShot Because of Dependencies

    That does share similarities with my installation problem. However, I'm now having trouble actually running the program I installed.

  10. #10
    Join Date
    Aug 2008
    Beans
    5

    Re: Can't Install OpenShot Because of Dependencies

    I am sorry,

    my suggestion did not help much for myself either. Now I try to run apt-get dist-upgrade ...

    I hope it helps!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •