Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Installer not recognizing drive (Intel Smart Response Technology)

  1. #1
    Join Date
    Oct 2009
    Beans
    10

    Installer not recognizing drive (Intel Smart Response Technology)

    Hi

    I am trying to dual boot Lubuntu on my new Dell 15R SE along with Windows 7. It has a 32GB cache drive that uses Intel Smart Response Technology. I managed to partition the drive using GParted on a live usb drive. Windows 7 is installed and I have Intel Smart Response Technology set up. For Intel Smart Response Technology to work it needs a RAID drive. In the BIOS the SATA Operation is: 'Intel Smart Response Technology'. The other options are 'ATA' and 'AHCI'. I have read that ATA will work but I would like to keep the Smart Response working. I have tried the alternate installation disc and it prompted me that it detected a RAID drive but did not show the drive at the partitioning step. Any ideas of how to get it working?

    Thanks

  2. #2
    Join Date
    Oct 2009
    Beans
    10

    Re: Installer not recognizing drive (Intel Smart Response Technology)

    Just a thought, can I change the SATA Operation to ATA, install ubuntu and then change back to Intel Smart Response Technology? Will the grub installation be affected? Will Windows or Ubuntu be affected?

  3. #3
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Installer not recognizing drive (Intel Smart Response Technology)

    Actually AHCI is a better choice than ATA, but if it doesn't recognize the disk(s) correctly with ISRT, when you change it back I doubt it will recognize the ubuntu installation you made.

    On the other hand, the alternate installer (or the live cd too) does seem to detect that there is a type of raid, but I guess it doesn't have the drivers to understand it properly. It's not even a raid in the true meaning of the word because it combines smaller disk with a larger one, not identical disks.

    These machines seem to create issues for dual boot, I'm not sure what can you do about it.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  4. #4
    Join Date
    Oct 2009
    Beans
    10

    Re: Installer not recognizing drive (Intel Smart Response Technology)

    Quote Originally Posted by darkod View Post
    Actually AHCI is a better choice than ATA, but if it doesn't recognize the disk(s) correctly with ISRT, when you change it back I doubt it will recognize the ubuntu installation you made.

    On the other hand, the alternate installer (or the live cd too) does seem to detect that there is a type of raid, but I guess it doesn't have the drivers to understand it properly. It's not even a raid in the true meaning of the word because it combines smaller disk with a larger one, not identical disks.

    These machines seem to create issues for dual boot, I'm not sure what can you do about it.
    Okay, thanks for your answer. I guess I will have to wait a while for this to get supported. The live USB will have to do for now.

  5. #5
    Join Date
    Jul 2012
    Beans
    6

    Re: Installer not recognizing drive (Intel Smart Response Technology)

    I had the same issue. I recently bought a Lenovo ideapad u410, it has a 500GB HDD and a 32GB SSD. Intel Smart Response and Intel Rapid Storage are pre installed and configured for Windows7.

    I have made it to install Ubuntu on it, but now my Windows is f#@!ed Up =)
    I removed the dmraid package within the Live-System and voila, Ubuntu recognizes the HDD. But I didn't make it that GRUB2 comes up at start. I put GRUB2 at MBR of my HDD and at the start of my ext4 partition, but only the windows bootmanager comes up. Because of this pre configured Intel stuff Windows boots from the SSD, when I tried to install GRUB2 on the SSD I got various errors. (Also Gparted shows the SSD as "unallocated"). I then knew nothing of the RAID Configuration.

    I started to immerse myself in the Intel Smart Respone and Intel Rapid Storage topic.
    It looks like dmraid is legacy (Just google "Intel Rapid Storage Technology Dualboot" and you'll find a pdf called Intel RST in Linux* )

  6. #6
    Join Date
    Oct 2009
    Beans
    10

    Re: Installer not recognizing drive (Intel Smart Response Technology)

    I have found a solution.

    To get the Ubuntu live installer (normal version) to detect the drive, in the 'Try Ubuntu before Installing' option, open a terminal and try the commands on this page: https://wiki.archlinux.org/index.php...ID#Load_dmraid. I think all that is needed is
    # modprobe dm_mod
    # dmraid -ay
    # ls -la /dev/mapper/
    Then you can open the installer in the Live session and install.

    You must also go back to Windows and open the 'Intel Rapid Storage Technology' application and go to the 'Accelerate' Tab. Disable acceleration (this will not lose any data but will automatically back up some data if you are using maximised option). Then you should be able to restart into GRUB. You may need to try reinstalling GRUB (Google it). If the GRUB screen is present then you can go back to Windows and re-enable acceleration in 'Intel Rapid Storage Technology'.

    Hope this works for everyone else.

  7. #7
    Join Date
    Dec 2008
    Beans
    63

    Re: Installer not recognizing drive (Intel Smart Response Technology)

    Quote Originally Posted by godgough View Post
    I have found a solution.

    To get the Ubuntu live installer (normal version) to detect the drive, in the 'Try Ubuntu before Installing' option, open a terminal and try the commands on this page: https://wiki.archlinux.org/index.php...ID#Load_dmraid. I think all that is needed is
    # modprobe dm_mod
    # dmraid -ay
    # ls -la /dev/mapper/
    Then you can open the installer in the Live session and install.

    You must also go back to Windows and open the 'Intel Rapid Storage Technology' application and go to the 'Accelerate' Tab. Disable acceleration (this will not lose any data but will automatically back up some data if you are using maximised option). Then you should be able to restart into GRUB. You may need to try reinstalling GRUB (Google it). If the GRUB screen is present then you can go back to Windows and re-enable acceleration in 'Intel Rapid Storage Technology'.

    Hope this works for everyone else.
    I tried something similar.

    Firstly I Disabled Acceleration from Intel RST
    Secondly on BIOS i changed RAID to AHCI

    Windows is still booting up correctly.

    Then when I go to install Ubuntu through the Live CD after doing
    apt-get remove dmraid

    I installed
    Code:
    / on /dev/sda1 which is 8GB and
    /home on /dev/sda2 which is 22 GB
    And I tried installing the bootloader on
    /dev/sdb, /dev/sdb1, /dev/sdb2 differently. After all 3 attempts GRUB doesn't show up.

    Any pointers on what is wrong.

  8. #8
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Installer not recognizing drive (Intel Smart Response Technology)

    The commands to remove the RAID meta-data on a drive:

    Presence1960 on remove old raid setting from HD
    http://ubuntuforums.org/showthread.php?t=1325650
    sudo dmraid -E -r /dev/sda
    sudo dmraid -E -r /dev/sdb
    Also check BIOS for raid settings
    More discusion:
    http://wwww.ubuntuforums.org/showthr...38#post9274738

    If you installed grub to partitions, I hope you did not install to the Windows partition. Windows NTFS partition have to have NTFS boot signatures in them. But you can use testdisk to restore from a backup if only installed once.

    May be best to run BootInfo and post link:
    Boot Repair -Also handles LVM, GPT and separate /boot.:
    https://help.ubuntu.com/community/Boot-Repair
    You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration.
    Oldfred on vacation. Back Sept 9. Will not have much if any Internet access.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  9. #9
    Join Date
    Dec 2008
    Beans
    63

    Re: Installer not recognizing drive (Intel Smart Response Technology)

    Quote Originally Posted by oldfred View Post
    The commands to remove the RAID meta-data on a drive:

    Presence1960 on remove old raid setting from HD
    http://ubuntuforums.org/showthread.php?t=1325650
    sudo dmraid -E -r /dev/sda
    sudo dmraid -E -r /dev/sdb
    Also check BIOS for raid settings
    More discusion:
    http://wwww.ubuntuforums.org/showthr...38#post9274738

    If you installed grub to partitions, I hope you did not install to the Windows partition. Windows NTFS partition have to have NTFS boot signatures in them. But you can use testdisk to restore from a backup if only installed once.

    May be best to run BootInfo and post link:
    Boot Repair -Also handles LVM, GPT and separate /boot.:
    https://help.ubuntu.com/community/Boot-Repair
    You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration.
    I got it finally working.

    The Boot repair tool did the trick
    Here is the output from it : http://paste.ubuntu.com/1111467/

    Now my machine successfully dual boots.

    I think when I said I had tried installing grub on the other partitions it had failed because of UFI.

  10. #10
    Join Date
    Dec 2008
    Beans
    63

    Re: Installer not recognizing drive (Intel Smart Response Technology)

    Short summary on how I achieved dual booting my system. Thanks everyone

    Firstly I Disabled Acceleration from Intel RST
    Secondly on BIOS I changed RAID to AHCI

    used the live CD to boot into ubuntu and on terminal ran
    sudo dmraid -E -r /dev/sda
    sudo dmraid -E -r /dev/sdb


    I then installed
    / on /dev/sda1 which is 8GB and
    /home on /dev/sda2 which is 22 GB

    Then I followed the instructions here to install grub on /dev/sda

    https://help.ubuntu.com/community/Boot-Repair

    Now I can dual boot successfully

    I will blog in detail of these steps in a weeks time on http://vthacker.in

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •