Results 1 to 2 of 2

Thread: 12.04 Acer 0722 Atheros AR9485 (9485) - poor wireless performance

  1. #1
    Join Date
    Jan 2009
    Location
    Palo Alto, CA
    Beans
    42

    Talking 12.04 Acer 0722 Atheros AR9485 (9485) - poor wireless performance

    As, it would seem with others, my fresh install of 12.04 to an Acer Axpire One (0722) had very spotty wireless performance (slow at its best, often not working at all). Reading the forums, many fixes were suggested, the one I tried was (fortunately) both simple and effective. I'm making this additional post in the hopes that others with the same rig will find it quickly and be able to save themselves days of reading about kernal patches, WICD (whatever that is), and such as nowhere did I find this same rig (AR9485 on 12.04) documented.

    As found on:

    http://ubuntuforums.org/showthread.p...heros+acer+722

    I first tried these commands:

    Code:
    sudo modprobe -rfv ath9k
    sudo modprobe -v ath9k nohwcrypt=1
    with functionally great results and then

    made it permanent by creating the file

    Code:
    /etc/modprobe.d/ath9k.conf
    and adding this line (followed by a <cr> which i'm not sure was needed...)

    Code:
    options ath9k nohwcrypt=1
    i then moved the netboot from first in the boot order and all still works great!

    just for the record:

    Code:
    rone@ronsAcerUbu:~$ lspci -nnk | grep -iA2 net
    06:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)
    Subsystem: Acer Incorporated [ALI] Device [1025:0598]
    Kernel driver in use: atl1c
    --
    07:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)
    Subsystem: Foxconn International, Inc. Device [105b:e047]
    Kernel driver in use: ath9k
    Let me know if you need any more info.
    ______Ron

  2. #2
    Join Date
    Jan 2009
    Location
    Palo Alto, CA
    Beans
    42

    Unhappy Re: 12.04 Acer 0722 Atheros AR9485 (9485) - poor wireless performance

    Um, never mind about the positive boot order comment in the original post. For whatever reason, the problem with freezing on boot returned the next day and it seems that moving the network boot to first in the boot order is still necessary to prevent this.

    Really weird tho that the system seemed to work fine for over the many test boots that I tried, including several complete power down/up (not just restarts) with the network boot no longer in first position. And then, the freeze came back the next day. What could that be about?
    ______Ron

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •