Hello everyone...

I am experiencing a rather weird problem I have never encountered before. While using Gimp, the system will abruptly log out.

For example: Open Gimp > New File > select bucket tool (or any tool) > (click) on the new image with tool... then, BOOM! The system logs out.

I am using Precise 12.04, and I have a Thinkpad T420s. The only logs that have any information about the abrupt logout are what I found in:

/var/log/Xorg.0.log.old,

Code:
Backtrace:
[   226.575] 0: /usr/bin/X (xorg_backtrace+0x26) [0x7fddaa92b996]
[   226.575] 1: /usr/bin/X (0x7fddaa7a3000+0x18c83a) [0x7fddaa92f83a]
[   226.575] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fdda9ac9000+0xfcb0) [0x7fdda9ad8cb0]
[   226.575] 3: /usr/bin/X (0x7fddaa7a3000+0x5e71a) [0x7fddaa80171a]
[   226.575] 4: /usr/bin/X (0x7fddaa7a3000+0x58070) [0x7fddaa7fb070]
[   226.575] 5: /usr/bin/X (0x7fddaa7a3000+0x1230ef) [0x7fddaa8c60ef]
[   226.575] 6: /usr/bin/X (0x7fddaa7a3000+0x4e8b1) [0x7fddaa7f18b1]
[   226.575] 7: /usr/bin/X (0x7fddaa7a3000+0x3d6da) [0x7fddaa7e06da]
[   226.575] 8: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7fdda895e76d]
[   226.575] 9: /usr/bin/X (0x7fddaa7a3000+0x3d9d1) [0x7fddaa7e09d1]
[   226.575] Segmentation fault at address 0x28
[   226.575] 
Caught signal 11 (Segmentation fault). Server aborting
[   226.575] 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
[   226.575] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
and .xsession-error.old

Code:
(gimp-2.6:7435): LibGimpBase-WARNING **: gimp-2.6: gimp_wire_read(): error
This error is always reproducible, I log back in open gimp, use a tool, BAM! logout again...!?

Can anyone help me capture more error information so that it can be attached to this thread?

Maybe it could be a bug? Any help from the community is greatly appreciated since I need to use Gimp to make a meager living...