Results 1 to 7 of 7

Thread: ACPI fan off? (fan control)

  1. #1

    Question ACPI fan off? (fan control)

    Hello,

    I assembled a new PC (P8Z77-I Ivy Bridge motherboard).
    I ran sensors detect but the only thing I get with sensors is:
    Code:
    pmatos@jupiter:~$ sensors
    acpitz-virtual-0
    Adapter: Virtual device
    temp1:        +27.8C  (crit = +106.0C)
    temp2:        +29.8C  (crit = +106.0C)
    
    coretemp-isa-0000
    Adapter: ISA adapter
    Physical id 0:  +38.0C  (high = +85.0C, crit = +105.0C)
    Core 0:         +32.0C  (high = +85.0C, crit = +105.0C)
    Core 1:         +33.0C  (high = +85.0C, crit = +105.0C)
    Core 2:         +25.0C  (high = +85.0C, crit = +105.0C)
    Core 3:         +33.0C  (high = +85.0C, crit = +105.0C)
    Fans are currently running at a very high speed (quite noisy).

    I want them to control themselves so that they only turn on when they see fit.

    I noticed the following using dmesg:
    Code:
    [    0.826817] ACPI: Fan [FAN0] (off)
    [    0.826834] ACPI: Fan [FAN1] (off)
    [    0.826851] ACPI: Fan [FAN2] (off)
    [    0.826867] ACPI: Fan [FAN3] (off)
    [    0.826882] ACPI: Fan [FAN4] (off)
    I am wondering if this is affecting sensors detect ability to see the fans and show their speed (at the same time allowing the kernel to set fan speeds as it sees fit).

    Any suggestions?

  2. #2
    Join Date
    Jun 2009
    Location
    NY
    Beans
    570
    Distro
    Kubuntu Development Release

    Re: ACPI fan off? (fan control)

    Who manufactured your motherboard or the BIOS?

    See if they have any documentation on using the board or the BIOS.

    You should look into the BIOS to see if there are any fan control options or thermal trip point since the BIOS usually controls these aspects.

    -Red
    Everything in the future is a wave, everything in the past is a particle. -Lawrence Bragg

    Parabola: https://parabolagnulinux.org/
    Completely freed... Libre GNU/Linux !!!

  3. #3

    Exclamation Re: ACPI fan off? (fan control)

    Quote Originally Posted by Redblade20XX View Post
    Who manufactured your motherboard or the BIOS?

    See if they have any documentation on using the board or the BIOS.

    You should look into the BIOS to see if there are any fan control options or thermal trip point since the BIOS usually controls these aspects.

    -Red
    Thanks Red, I actually thought it was the OS (Ubuntu) that could communicate with the mobo/bios and set up the fan speed according to the temperatures. I will look at my bios and see what I can do.

  4. #4
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: ACPI fan off? (fan control)

    Lot of work have been done lately on kernel 3.5 about acpi, so better to install it

  5. #5

    Question Re: ACPI fan off? (fan control)

    Quote Originally Posted by dino99 View Post
    Lot of work have been done lately on kernel 3.5 about acpi, so better to install it
    Is there any ubuntu 'approved' way to install it? apt-get?
    Or it boils down to download/configure/make?

  6. #6

    Re: ACPI fan off? (fan control)

    Quote Originally Posted by Redblade20XX View Post
    Who manufactured your motherboard or the BIOS?

    See if they have any documentation on using the board or the BIOS.

    You should look into the BIOS to see if there are any fan control options or thermal trip point since the BIOS usually controls these aspects.

    -Red
    Btw, the motherboard is an ASUS P8Z77-I and the BIOS seems to be ASUS too. The motherboard has some settings to control fan. However, if I set the settings to silent or even manually, I still get fans at full speed in linux. I wonder if incorrectly linux is overriding these settings...

  7. #7
    Join Date
    Jun 2009
    Location
    NY
    Beans
    570
    Distro
    Kubuntu Development Release

    Re: ACPI fan off? (fan control)

    Quote Originally Posted by pmatos View Post
    Btw, the motherboard is an ASUS P8Z77-I and the BIOS seems to be ASUS too. The motherboard has some settings to control fan. However, if I set the settings to silent or even manually, I still get fans at full speed in linux. I wonder if incorrectly linux is overriding these settings...
    Do you have the most current BIOS?

    Hmm... linux is not suppose to mess with BIOS settings.

    Try some of these options to see if the kernel is doing something wrong.
    https://help.ubuntu.com/community/Bo...Kernel_Options

    In your BIOS setting, enable and save the silent option or the manual option, push some of these kernel options and see what happens.

    -Red
    Everything in the future is a wave, everything in the past is a particle. -Lawrence Bragg

    Parabola: https://parabolagnulinux.org/
    Completely freed... Libre GNU/Linux !!!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •