Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 48

Thread: Thinkpad L430: Wifi rtl8188ce Unstable Connection

  1. #31
    Join Date
    Oct 2009
    Location
    Amsterdam, Netherlands
    Beans
    3
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Thinkpad L430: Wifi rtl8188ce Unstable Connection

    Hi,

    I am thinking about buying a thinkpad L430, but I don't want the network problems you're describing. Do you know which network card you are using? There are a few available if you buy the laptop. Especially: Do you know if it is the centrino wireless 2200, or something else?

    regards,

    Dirk Boonzajer
    Last edited by dboonz; August 24th, 2012 at 04:07 PM. Reason: used driver w

  2. #32
    Join Date
    Jun 2006
    Location
    The Netherlands
    Beans
    36
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Thinkpad L430: Wifi rtl8188ce Unstable Connection

    I bought a toshiba c850 and was extremely disappointed to discover that it kept dropping wifi. I refused to accept that the problem could not be solved in spite of a lot of the threads I read about the problem. I downloaded the driver from Realtek (even though it seemed to be installed), compiled it (following instructions from the readme file or one of the ubuntu forum threads) and the problem seems to be over and out.
    The toshiba has
    *-network
    description: Wireless interface
    product: RTL8188CE 802.11b/g/n WiFi Adapter [10EC:8176]
    vendor: Realtek Semiconductor Co., Ltd. [10EC]
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: wlan0
    version: 01
    serial: 1c:c6:3c:65:08:4d
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wir

    I had tried out a laptop in the shop with a livecd (not the toshiba but also with realtek wireless) and it looked like the wireless worked ok. I discovered that it connected ok but dropped after a periode of time. So you may think it's ok.

    Good luck and don't despair

  3. #33
    Join Date
    Aug 2012
    Beans
    6

    Re: Thinkpad L430: Wifi rtl8188ce Unstable Connection

    Similar problem here on new Lenovo Thinkpad x121e with 12.04. When I first installed 12.04 everything seemed to work perfectly fine for about a week-10 days, and then the wifi problems started. At first it only had difficulty connecting to a network, then networks started not showing up under the network icon, then it started dropping the network connection for no apparent reason.

    I downloaded, compiled and installed the rtl8188ce driver yesterday (as explained here: http://ubuntuforums.org/showthread.php?t=1944493 ) and now connection is definitely more stable, networks show up under the network icon, but it still doesn't work properly. Occasionally it will drop the connection and then most of the time it's unable to reconnect. Sometimes it manages to reconnect after repeatedly asking for the password, but most times only a reboot will fix things, and even then connecting might be hugely problematic and require several reboots before it works.

    Any and all help would be greatly appreciated!

  4. #34
    Join Date
    Jun 2006
    Location
    The Netherlands
    Beans
    36
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Thinkpad L430: Wifi rtl8188ce Unstable Connection

    I also followed the instructions on the post mentioned by Ddamia and also this post,
    http://ubuntuforums.org/showthread.php?t=1930475

    ...with reference to the instruction regarding rtl8192ce.ko

    I have had no problems since; I'm using linuxmint 13.

  5. #35
    Join Date
    Oct 2009
    Location
    Amsterdam, Netherlands
    Beans
    3
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Thinkpad L430: Wifi rtl8188ce Unstable Connection

    @Ddamia:

    It depends on your wireless network card. If you buy a lenovo, you can choose different options for the wireless network card. I chose the intel 2200 bgn network card, and it works flawlessly. So you could just try to change the network card - if you can still return it to the shop.

  6. #36
    Join Date
    Aug 2012
    Beans
    6

    Re: Thinkpad L430: Wifi rtl8188ce Unstable Connection

    Quote Originally Posted by dboonz View Post
    @Ddamia:

    It depends on your wireless network card. If you buy a lenovo, you can choose different options for the wireless network card. I chose the intel 2200 bgn network card, and it works flawlessly. So you could just try to change the network card - if you can still return it to the shop.
    Um, no... I don't think I can get the same computer with a different network card from the shop I bought it from. All their Lenovos have realtek cards if I remember correctly.

  7. #37
    Join Date
    Aug 2012
    Beans
    6

    Re: Thinkpad L430: Wifi rtl8188ce Unstable Connection

    Tentative bump!
    Anyone have any suggestions on how to make the wireless connection with rtl8188ce driver more stable?

    As I said above, compiling and installing from the rtl site improved stability hugely, but it's still not working 100% reliably.

  8. #38
    Join Date
    Aug 2012
    Beans
    11

    Re: Thinkpad L430: Wifi rtl8188ce Unstable Connection

    Quote Originally Posted by Ddamia View Post
    Similar problem here on new Lenovo Thinkpad x121e with 12.04....
    I downloaded, compiled and installed the rtl8188ce driver yesterday (as explained here: http://ubuntuforums.org/showthread.php?t=1944493 ) and now connection is definitely more stable, networks show up under the network icon, but it still doesn't work properly.
    Well I don't know how many drivers I have downloaded and installed reading various forums over the last few days and I am still getting horrible WiFi stability on my x120e. However the surprising fact is that it works flawlessly, out of the box, if you install the 32 bit Ubuntu 12.04.

    I'm not a great with hardware and drivers so I have little knowledge about how stuff works behind the scenes. But then why I really need the amd64 Ubuntu 12.04 is to make full use of the 6gb ram I have installed in the system so that I can run winXP on virtual box that would run ArcGIS in it.

    [off-topic] If there is a work around to get ArcGIS on Ubuntu (I already have QGIS), I'd love to know that too [/off-topic]

    Many thanks in advance
    Last edited by seshdroid; November 4th, 2012 at 09:32 PM. Reason: To add an off-topic content

  9. #39
    Join Date
    Nov 2012
    Beans
    4

    Re: Thinkpad L430: Wifi rtl8188ce Unstable Connection

    I am the owner of an Lenovo x121e (Type 3051-5QG). The build-in rtl8188ce Wifi shows the same problems since I have changed the OS from 32Bit to 64Bit (currently Ubuntu 12.10 64Bit).

    But today I found a hint, that might fix the problem easily. Look at
    http://www.hitxp.com/articles/softwa...natty-narwhal/

    Type the following in the command line
    gksudo gedit /etc/nsswitch.conf
    This will open the nsswitch.conf file in the text editor. Then simply change the following line
    hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4
    to the below line and save the file.
    hosts: files dns
    That is it. Just reset your internet connection or probably restart your system

    This change disables Multicast DNS and for me it looks like the Wifi runs stable. I hope you can agree and you don't need Multicast DNS either.

    2012-11-23: The WLAN Connection is still unstable if the signal gets weak. So I followed the other hint in the forums. Download the original driver-software from realtek and compile it for your own machine. I found the driver at
    http://www.realtek.com.tw/downloads/...Downloads=true
    I took the version 0007.0809.2012 (2012-10-23), unpack and compiled it with
    make
    sudo make install
    The wlan reacts different and up to now the connection is stable even with an weak signal.
    Last edited by koebln; November 23rd, 2012 at 10:30 PM.

  10. #40
    Join Date
    Dec 2012
    Beans
    9

    Re: Thinkpad L430: Wifi rtl8188ce Unstable Connection

    Quote Originally Posted by koebln View Post
    I am the owner of an Lenovo x121e (Type 3051-5QG). The build-in rtl8188ce Wifi shows the same problems since I have changed the OS from 32Bit to 64Bit (currently Ubuntu 12.10 64Bit).

    But today I found a hint, that might fix the problem easily. Look at
    http://www.hitxp.com/articles/softwa...natty-narwhal/

    Type the following in the command line
    gksudo gedit /etc/nsswitch.conf
    This will open the nsswitch.conf file in the text editor. Then simply change the following line
    hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4
    to the below line and save the file.
    hosts: files dns
    That is it. Just reset your internet connection or probably restart your system

    This change disables Multicast DNS and for me it looks like the Wifi runs stable. I hope you can agree and you don't need Multicast DNS either.

    2012-11-23: The WLAN Connection is still unstable if the signal gets weak. So I followed the other hint in the forums. Download the original driver-software from realtek and compile it for your own machine. I found the driver at
    http://www.realtek.com.tw/downloads/...Downloads=true
    I took the version 0007.0809.2012 (2012-10-23), unpack and compiled it with
    make
    sudo make install
    The wlan reacts different and up to now the connection is stable even with an weak signal.
    Hi,
    Your suggestion on editing nsswitch.conf, got my wireless working in fresh install 12.10, however the installing drivers from the realtek website will screw it up. I think the drivers do not support the kernel 3.5 yet, which is default in 12.10 ubuntu. But my wireless used to stop working after 5 mins, now it alteast works. Thanks a lot.

    so in short, if you have a fresh install of 12.10, editing nsswitch.conf as mentioned above should do the trick. Do not try to install the drivers from the realtek website

Page 4 of 5 FirstFirst ... 2345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •