Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: No surround sound on Realtek ALC892

  1. #1
    Join Date
    Apr 2006
    Location
    Seattle, WA
    Beans
    56
    Distro
    Ubuntu Development Release

    No surround sound on Realtek ALC892

    I've been trying to get my surround sound(5.1) to work for the past couple of of days, followed a number of guides, but nothing seems to get it working at all. I'm connecting the speakers using 3 analogue audio cables, I have tested and they work fine under Windows. When I go into the Sound options in Ubuntu I don't see a 5.1 profile listed under the Hardware tab, only stereo(and that works fine).

    The sound controller is a Realtek ALC892 built-in to my mobo(Gigabyte P55A-UD3).

    Here is some info I've seen requested in other threads, I'm running 10.10 RC, but I can assure you it doesn't work under earlier versions.

    Code:
    Linux Yurippe 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:32:27 UTC 2010 x86_64 GNU/Linux
    Code:
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC892 Analog [ALC892 Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: ALC892 Digital [ALC892 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Code:
    Advanced Linux Sound Architecture Driver Version 1.0.23.
    Code:
    hideaki@Yurippe:~$ head -n 1 /proc/asound/card*/codec#*
    ==> /proc/asound/card0/codec#2 <==
    Codec: Realtek ALC892
    
    ==> /proc/asound/card1/codec#0 <==
    Codec: Nvidia ID 12
    
    ==> /proc/asound/card1/codec#1 <==
    Codec: Nvidia ID 12
    
    ==> /proc/asound/card1/codec#2 <==
    Codec: Nvidia ID 12
    
    ==> /proc/asound/card1/codec#3 <==
    Codec: Nvidia ID 12
    Any help on this would be greatly appreciated!

  2. #2
    Join Date
    May 2006
    Location
    West Sussex UK
    Beans
    207
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: No surround sound on Realtek ALC892

    Hate to say this, but I went all round the houses on this one also. My solution for the moment is to fit a PCI sound card, works a treat!

    All the solutions that I've seen so far will break if there is a Linux header update.

    I'm now waiting for Alsa sound modules that support this chipset to be officially incorporated in to Ubuntu.

  3. #3
    Join Date
    Apr 2006
    Location
    Seattle, WA
    Beans
    56
    Distro
    Ubuntu Development Release

    Re: No surround sound on Realtek ALC892

    That makes sense. I suppose it's just a matter of time then...

    At least stereo audio works great.

  4. #4
    Join Date
    Oct 2008
    Beans
    115
    Distro
    Ubuntu

    Re: No surround sound on Realtek ALC892

    Any progress here?

  5. #5
    Join Date
    Oct 2008
    Beans
    115
    Distro
    Ubuntu

    Re: No surround sound on Realtek ALC892

    rm
    Last edited by lores; January 21st, 2011 at 12:38 AM.

  6. #6
    Join Date
    Oct 2008
    Beans
    115
    Distro
    Ubuntu

    Re: No surround sound on Realtek ALC892

    rm
    Last edited by lores; January 21st, 2011 at 12:39 AM.

  7. #7
    Join Date
    Oct 2008
    Beans
    115
    Distro
    Ubuntu

    Re: No surround sound on Realtek ALC892

    rm
    Last edited by lores; January 21st, 2011 at 12:39 AM.

  8. #8
    Join Date
    Oct 2008
    Beans
    115
    Distro
    Ubuntu

    Re: No surround sound on Realtek ALC892

    rm
    Last edited by lores; January 21st, 2011 at 12:39 AM.

  9. #9
    Join Date
    Oct 2008
    Beans
    115
    Distro
    Ubuntu

    Re: No surround sound on Realtek ALC892

    rm
    Last edited by lores; January 21st, 2011 at 12:38 AM.

  10. #10
    Join Date
    Oct 2008
    Beans
    115
    Distro
    Ubuntu

    Re: No surround sound on Realtek ALC892

    rm
    Last edited by lores; January 21st, 2011 at 12:38 AM.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •