Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Make Firefox the Default Browser!

  1. #11
    Join Date
    Mar 2008
    Location
    Florida
    Beans
    81
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Make Firefox the Default Browser!

    Quote Originally Posted by Robert Leithe View Post
    Hi, I've been trying to set Opera as my default browser, and been following your description as stated above. However, when I click a link in an e-mail (KMail), Konqueror opens. What gives?

    Sincerely
    Robert Leithe
    Robert,

    In a terminal (shell), navigate to $HOME/.local/share/applications.
    Then, run: gedit opera.desktop
    Look for the Exec= line and it probably has:
    Exec=konqueror %u
    Change this to:
    Exec=opera %u

    Save and close this file and you should be golden.

  2. #12
    Join Date
    Aug 2007
    Location
    Stockholm, Sweden
    Beans
    12
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Make Firefox the Default Browser!

    Allright, tried all of these, but:

    On Preferred Applications I have firefox and Chromium Web Browser (with these names). Firefox appears as default, that can be seen also when I run 'sudo update-alternatives --config x-www-browser', but firefox has no icon on it while Chromium has.

    Firefox has also disappeared from 'Browse the Web' (icon on Unity when you click the Ubuntu logo) and got replaced by Chromium.

    When I do an application search on unity, I get two Firefoxes. In my .local/share/applications/ are shortcuts 'Firefox' and 'Firefox Web Browser' which doesn't appear when I do a search in Unity.

    Seems like I've managed to crap up my icons or my icons settings somehow.

  3. #13
    Join Date
    Aug 2007
    Location
    Stockholm, Sweden
    Beans
    12
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Make Firefox the Default Browser!

    Hmm... It seems like deleting shortcuts from .local/share/applications/ and letting Ubuntu recreate them fixed the problem.

    Now I got my 'Firefox Web Browser' back working. It appeared in Preferred Applications and as Unity's Browse the Web shortcut.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •