Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Discussion - https://help.ubuntu.com/community/EnableHibernateWithEncryptedSwap

  1. #1
    Join Date
    Jan 2008
    Location
    Manchester UK
    Beans
    13,637
    Distro
    Ubuntu

    Discussion - https://help.ubuntu.com/community/EnableHibernateWithEncryptedSwap

    Please use this thread for discussion regarding

    https://help.ubuntu.com/community/En...hEncryptedSwap

    Support threads should be posted in normal forums.

    Thank you.

  2. #2
    Join Date
    May 2011
    Beans
    2

    Unhappy Re: Discussion - https://help.ubuntu.com/community/EnableHibernateWithEncryptedSwap

    Thanks for the guide, I followed it including regenerating the initramfs, but when rebooting and entering the password on boot, it says
    "cryptsetup: unknown fstype, bad password or options?"
    when entering the right password.

    The following works with no problem after the system boots
    Code:
    /sbin/cryptsetup luksOpen /dev/sda7 cryptswap1
    But the code in /usr/share/initramfs-tools/scripts/local-top/cryptroot goes inside the if block at #314
    Code:
                    if [ -z "$FSTYPE" ] || [ "$FSTYPE" = "unknown" ]; then
                            message "cryptsetup: unknown fstype, bad password or options?"
                            udev_settle
                            $cryptremove
                            continue
                    fi
    and shows the above message.

    Apparently the script isn't recognizing the encrypted filesystem, but I have no idea why.

    I am on ubuntu 12.04 (Linux aularon-laptop 3.2.0-27-generic #43-Ubuntu SMP Fri Jul 6 14:25:57 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux).

    If there's anything I can try to troubleshoot the problem/solve it?

  3. #3
    Join Date
    Apr 2010
    Location
    Simferopol, Ukraine
    Beans
    39
    Distro
    Ubuntu

    Re: Discussion - https://help.ubuntu.com/community/EnableHibernateWithEncryptedSwap

    Great guide!
    But I have a problem: after password query appears system continues to boot and there is no ability to enter the password.

  4. #4
    Join Date
    May 2007
    Location
    The New Forest
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Discussion - https://help.ubuntu.com/community/EnableHibernateWithEncryptedSwap

    Quote Originally Posted by zuker View Post
    Great guide!
    But I have a problem: after password query appears system continues to boot and there is no ability to enter the password.
    Please start a thread in the normal forums for your issue

  5. #5

    Question Re: Discussion - https://help.ubuntu.com/community/EnableHibernateWithEncryptedSwap

    after applying this steps I need to enter the pass-phrase each time the swap is being mounted or just first time?

  6. #6
    Join Date
    Oct 2012
    Beans
    1

    Re: Discussion - https://help.ubuntu.com/community/EnableHibernateWithEncryptedSwap

    Hello,

    how can I revert the use of a fixed passphrase to a random one?

    I guess I shoud follow the instructions in the wiki and change something at the step
    Code:
    sudo cryptsetup luksFormat --cipher aes-cbc-essiv:sha256 --verify-passphrase --key-size 256 /dev/sdXN
    ?

  7. #7

    Re: Discussion - https://help.ubuntu.com/community/EnableHibernateWithEncryptedSwap

    Quote Originally Posted by stylishkoala View Post
    after applying this steps I need to enter the pass-phrase each time the swap is being mounted or just first time?
    Quote Originally Posted by JonasHagen View Post
    Hello,

    how can I revert the use of a fixed passphrase to a random one?

    I guess I shoud follow the instructions in the wiki and change something at the step
    Code:
    sudo cryptsetup luksFormat --cipher aes-cbc-essiv:sha256 --verify-passphrase --key-size 256 /dev/sdXN
    ?
    This area is for discussing the relevant wiki page(s) and not for support. For that please post in the relevant subforum.


    Regards
    404
    404

    Come shoot the breeze with us on the Ubuntu Forums IRC channel - #ubuntuforums

  8. #8
    Join Date
    Mar 2008
    Location
    NJ USA
    Beans
    192
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Discussion - https://help.ubuntu.com/community/EnableHibernateWithEncryptedSwap

    Curiously, how much memory you have, and how big the swap space you have here?

    Can I have 4GB memory DIM and with 2GB swap space to enable Hibernate?

  9. #9
    Join Date
    May 2013
    Beans
    7

    Re: Discussion - https://help.ubuntu.com/community/EnableHibernateWithEncryptedSwap

    Thanks for the guide. It was very helpful. There was just one extra thing I had to add in order for the passphrase prompt to always show up during start-up. In /etc/default/grub I edited GRUB_CMDLINE_LINUX_DEFAULT to look like:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash cryptopts=target=cryptswap1,source=/dev/sda6 resume=swap:/dev/mapper/cryptswap1"

  10. #10
    Join Date
    May 2013
    Beans
    7

    Re: Discussion - https://help.ubuntu.com/community/EnableHibernateWithEncryptedSwap

    Quote Originally Posted by thelinuxkidd View Post
    Thanks for the guide. It was very helpful. There was just one extra thing I had to add in order for the passphrase prompt to always show up during start-up. In /etc/default/grub I edited GRUB_CMDLINE_LINUX_DEFAULT to look like:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash cryptopts=target=cryptswap1,source=/dev/sda6 resume=swap:/dev/mapper/cryptswap1"
    I should mention two other things:
    1. I only got hibernate to work with tuxonice.
    2. By adding the line in the quote to /etc/default/grub (and then rebuilding with upgrade-grub2) I didn't need to edit /usr/share/initramfs-tools/scripts/local-top/cryptroot as mentioned in the guide at the beginning of this thread.


    Linux dist: Ubuntu 12.04
    Linux kernel: 3.2.0-44-generic-tuxonice
    System: Thinkpad T430s

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •