Results 1 to 4 of 4

Thread: Suddenly cannot plot in octave

  1. #1
    Join Date
    Apr 2006
    Beans
    6

    Suddenly cannot plot in octave

    Hi,

    My previous Octave installation was working fine, and suddenly (I think after accepting a lot of updates from update manager), I can't plot in Octave at all.

    This is what I get in Octave:

    Code:
    octave:1> x = 1:10
    x =
    
        1    2    3    4    5    6    7    8    9   10
    
    octave:2> y = 1:10
    y =
    
        1    2    3    4    5    6    7    8    9   10
    
    octave:3> plot(x, y)
    error: `plot' undefined near line 3 column 1
    octave:3> version
    ans = 3.2.4
    octave:4> help plot
    error: help: `plot' not found
    This is the list of installed packages

    Code:
    $ dpkg --get-selections | grep 'octave'
    octave-plot					install
    octave3.2					install
    octave3.2-common				install
    octave3.2-htmldoc				install
    qtoctave					install
    Could anybody help me, please ? I'm running Ubuntu 12.04 LTS. Thanks !

  2. #2
    Join Date
    Jun 2009
    Location
    NY
    Beans
    570
    Distro
    Kubuntu Development Release

    Re: Suddenly cannot plot in octave

    Did you try this example before and it worked?

    Try installing gnuplot package.



    -Red
    Last edited by Redblade20XX; June 26th, 2012 at 09:58 PM.
    Everything in the future is a wave, everything in the past is a particle. -Lawrence Bragg

    Parabola: https://parabolagnulinux.org/
    Completely freed... Libre GNU/Linux !!!

  3. #3
    Join Date
    Apr 2012
    Beans
    5,531

    Re: Suddenly cannot plot in octave

    I can't really offer any help, but I can confirm the exact same code runs (and produces a plot) with 3.2.4 on my Xubuntu 11.10 box - I don't recall having to install anything non-standard although my package list is a little different

    EDIT: apparently plot.m is part of octave3.2-common, maybe that gives you a starting point - perhaps you just need to addpath("/usr/share/octave/3.2.4/m/plot")

    Code:
    octave3.2-common: /usr/share/octave/3.2.4/m/plot/plot.m
    Code:
    $ dpkg --get-selections | grep 'octave'
    octave-miscellaneous        install
    octave-optim                install
    octave-struct                install
    octave3.2                    install
    octave3.2-common            install
    
    octave:1> x = 1:10
    x =
    
        1    2    3    4    5    6    7    8    9   10
    
    octave:2> y = 1:10
    y =
    
        1    2    3    4    5    6    7    8    9   10
    
    octave:3> plot(x,y)
    octave:4> version
    ans = 3.2.4
    Last edited by steeldriver; June 27th, 2012 at 12:03 AM.

  4. #4
    Join Date
    Apr 2006
    Beans
    6

    Re: Suddenly cannot plot in octave

    For an unknown reason, plotting works fine again after I restarted Ubuntu. Probably some leftover from the previous system update?

    This is starting to resemble Windows Thanks for the help, everyone !

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •