Page 4 of 7 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 63

Thread: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

  1. #31
    Join Date
    Oct 2012
    Beans
    14

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Thank you guys so much, I am now posting this using wifi! After trying everything you said chili555 with no different results, I added
    Code:
    options iwlwifi bt_coex_active=N
    to the iwlwifi.conf then rebooted and it worked like a charm.

    Now, what did I do exactly? I'm doing my best to try and learn ubuntu, and I would like to have a better under standing of what the problems I run into are and what I do to fix them.
    Last edited by jwx330; November 30th, 2012 at 07:45 PM.

  2. #32
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,438
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    I'm surprised it had no effect in post #27, but does now. We learn every day.

    The parameter tells the driver we don't want bluetooth and wireless to co-exist, presumably running at the same time. How or why it helps, I don't know. If it works, I'll take it!
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  3. #33
    Join Date
    May 2012
    Beans
    8

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Thanks everyone for the effort on this. I have the same problem with an ASUS but I'm an absolute beginner and don't understand how I would apply this. What are the codes I'd type into the Terminal?

  4. #34
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,438
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Quote Originally Posted by pauleskey View Post
    Thanks everyone for the effort on this. I have the same problem with an ASUS but I'm an absolute beginner and don't understand how I would apply this. What are the codes I'd type into the Terminal?
    There are several posters here describing slightly different problems. Please tell us your exact problem. Open the terminal and run these commands and post the results:
    Code:
    lspci -nn | grep 0280
    uname -r 
    arch
    The pipe symbol | is on the right side of my US keyboard on the same key with \. Thanks.
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  5. #35
    Join Date
    May 2012
    Beans
    8

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Sorry about being so vague. I have an ASUS U56E-bal7 on which I have installed 12.04 LTS Xubuntu. Post installation the computer detects the Netgear wireless router (but not 5g?) and automatically tries to connect and presents a password prompt. After entering the correct password, the prompt diappears but the connection is not made and the prompt repeats after a short interval. I would like to connect to the internet via wireless through the Netgear router (wndr3700). After some research including this thread I believe the answer is this:

    Code:
    Note: 'iwlagn' becomes 'iwlwifi' on kernel >=3.1
    For those that did not read the upstream bug, the fix for this issue is to:
    
    sudo modprobe -r iwlagn
    sudo modprobe iwlagn bt_coex_active=0
    
    To make the change permanent:
    gksu gedit /etc/modprobe.d/iwl.conf
    
    Copy/paste this line into the new file:
    options iwlagn bt_coex_active=0
    
    Save. Quit.
    I entered the first two commands with iwlwifi and then the third. At that point the computer stated that a connection via the wireless had been made, but neither the browser nor Thunderbird were able to connect to the internet. I do not understand what the copy/paste command means....

    The result of your first request is : 02:00.0 Network Controller [0280]: Intel Corporation Centrino Wireless-N + WiMAX 6150 [8086:0885] (rev67)

    The result of your second request is: 3.2.0-37-generic

    The result of your third request is : i686

    Thanks. I hope that is clearer?

  6. #36
    Join Date
    May 2012
    Beans
    8

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    I also think this is a solution, but I don't know enough to implement or understand:

    Code:
    @Dave using 12.04 I just did
    
    options iwlwifi 11n_disable=1
    
    /etc/modprobe.d/iwlwifi.conf

  7. #37
    Join Date
    May 2012
    Beans
    8

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Okay got it to work temporarily with first two commands. I do not know how to use the following to make changes permanent:

    Code:
    To make the change permanent: gksu gedit /etc/modprobe.d/iwl.conf  Copy/paste this line into the new file: options iwlagn bt_coex_active=0  Save. Quit
    .

    I think the gksu should be gsku?

  8. #38
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,438
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    First, please do:
    Code:
    gksudo gedit /etc/modprobe.d/iwl.conf
    Whatever is in there now, please change it to:
    Code:
    options iwlwifi 11n_disable=1
    Proofread carefully, save and close gedit. Reboot.

    Can you connect, surf the web, etc. now?

    The driver iwlwifi is near to my heart; I am replying with mine right now. Some card/firmware/router combinations, like mine, work beautifully, even at N speeds. Some stubbornly refuse. I have been trying to work out the reasons and, if you wish, after we get you connected smoothly, we could look at router settings and try to restore N. I make no guarantees!
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  9. #39
    Join Date
    May 2012
    Beans
    8

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    okay. One issue resolved. Gedit had not installed. I have installed it. I ran the first command and a dialog box came up with nothing in it. Should I insert the second command you gave?

  10. #40
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,438
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Yes, please. After you save and close, let's be certain there are no conflicting files around:
    Code:
    ls /et/modprobe.d | grep iwl
    If you see nothing except the file you just wrote: iwl.conf, you are good to go. If there is anything else, tell me what it is.
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

Page 4 of 7 FirstFirst ... 23456 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •