Results 1 to 4 of 4

Thread: 12.04 pm-suspend wol problem

  1. #1
    Join Date
    Dec 2012
    Beans
    5

    12.04 pm-suspend wol problem

    Hi
    I have issue as folow.
    I'm on Ubuntu desktop. I use pm-suspend and wol to work remote on my mashine.
    Before I stood on Ubuntu 10.04 and all mentioned procedures work excellent.
    Since I move to 12.04 (64bit) problems occure.
    If I suspend mashine from system menu I can wakeup it from power button,
    but I cant wakeup it from wol.
    If I suspend mashine from terminal with pm-suspend I can wakeup mashine either with
    power button and wol, system wakeup maybe 1-2 times and in next attempt it doesn't.
    Mashines start, but monitors (I have to monitors) are dead - diode on them blinking.
    Follow this thread http://ubuntuforums.org/showthread.php?t=1981650
    I guess it's graphic drives fault (ATI Radeon HD 3300)
    so I tried with proprietary ATI drivers as folow:
    http://askubuntu.com/questions/74171...rted-in-ubuntu
    but its doesn't solve the problem.

    I see to ways to solve the problem:
    - try to find out what is wrong with pm-suspend and graphical,
    - tune suspend from system menu to suspend with wol capability.

    And here is my questions accordingly:
    - how to do this
    - what is the command that I can use in terminal to suspend in menu suspend manner,
    and how to tune it to make wol possible.

    Best Regards

  2. #2
    Join Date
    Sep 2010
    Location
    Germany
    Beans
    83
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 pm-suspend wol problem

    Hi,

    you may be on the wrong track. There is a script in Precise /usr/lib/pm-utils/power.d/disable_wol that disables wol on battery power. To disable the script create an empty file named /etc/pm/power.d/disable_wol.

    Did you check with
    Code:
    sudo ethtool eth0 | grep Wake
    if wol ist enabled before suspending and after resume?

    EDITH: for the terminal command to suspend "desktop-like" look here.
    Last edited by linrunner; December 16th, 2012 at 05:42 PM.

  3. #3
    Join Date
    Dec 2012
    Beans
    5

    Re: 12.04 pm-suspend wol problem

    Thank you for fast response.
    Yee the link dispel my second issue - thanks a lot !
    But still have first issue.
    sudo ethtool eth0 | grep Wake gives :
    Supports Wake-on: pumbg
    Wake-on: g

    I have the following efect
    If suspend with own-power-cmd - cant wakeup by wol
    if suspend with pm-suspend - can wakeup by wol
    (but sometimes doesn't back the screens)

    More difference betwen this two:
    if suspend via own-power-cmd after wakeup system ask for login passwd.
    If suspend via pm-suspend system doesn't ask for passwd (if wakeup at all).

    Any suggestions?

    regards

  4. #4
    Join Date
    Sep 2010
    Location
    Germany
    Beans
    83
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 pm-suspend wol problem

    Quote Originally Posted by wojb View Post
    Wake-on: g
    Means "Wake on MagicPacket" which is ok for your purpose.

    Quote Originally Posted by wojb View Post
    I have the following efect ...
    I have no idea about the exact cause. I would suggest you analyze/compare the log output in /var/log/pm-suspend.log and /var/log/pm-powersave.log of both methods – because on-power-cmd should call pm-suspend too (at the last stage).

    Quote Originally Posted by wojb View Post
    More difference betwen this two:
    if suspend via own-power-cmd after wakeup system ask for login passwd.
    If suspend via pm-suspend system doesn't ask for passwd (if wakeup at all).
    To my knowledge this works as designed (same here). You need the additional desktop logic of the dbus call in on-power-cmd to lock the screen after resume.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •