Results 1 to 5 of 5

Thread: apt-get broken

  1. #1
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    apt-get broken

    The title says it all really. Any takers?
    Code:
    root@quantal:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
     ia32-libs : Depends: ia32-libs-multiarch but it is not installable
    E: Unmet dependencies. Try using -f.
    root@quantal:~# apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following packages will be REMOVED:
      aquaria ia32-libs
    0 upgraded, 0 newly installed, 2 to remove and 194 not upgraded.
    1 not fully installed or removed.
    After this operation, 4235 kB disk space will be freed.
    Do you want to continue [Y/n]? 
    dpkg: error: file triggers record mentions illegal package name `libglib2.0-0' (for interest in file `/usr/lib/x86_64-linux-gnu/gio/modules'): ambiguous package name 'libglib2.0-0' with more than one installed instance
    E: Sub-process /usr/bin/dpkg returned an error code (2)
    Cheesemill

  2. #2
    Join Date
    Jun 2007
    Beans
    13,072

    Re: apt-get broken

    Possibly you upgraded to a bad dpkg version - see here for how to fix & then upgrade to the latest one

    https://bugs.launchpad.net/ubuntu/+s...g/+bug/1015329

    you could also read here
    http://ubuntuforums.org/showthread.php?t=2006840
    Last edited by mc4man; June 23rd, 2012 at 02:19 PM. Reason: previous thread

  3. #3
    Join Date
    Jan 2012
    Beans
    333

    Re: apt-get broken

    Post deleted after reading bug report with suggested solutions.
    Last edited by Curtis6767; June 23rd, 2012 at 03:16 PM. Reason: Different issue.

  4. #4
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: apt-get broken

    Quote Originally Posted by mc4man View Post
    Possibly you upgraded to a bad dpkg version - see here for how to fix & then upgrade to the latest one

    https://bugs.launchpad.net/ubuntu/+s...g/+bug/1015329

    you could also read here
    http://ubuntuforums.org/showthread.php?t=2006840
    Thanks a lot, that first link fixed it for me.
    Cheesemill

  5. #5
    Join Date
    Apr 2006
    Location
    New Hampshire, U.S.A.
    Beans
    2,491
    Distro
    Ubuntu Development Release

    Unhappy Re: apt-get broken

    Quote Originally Posted by mc4man View Post
    Possibly you upgraded to a bad dpkg version - see here for how to fix & then upgrade to the latest one

    https://bugs.launchpad.net/ubuntu/+s...g/+bug/1015329

    you could also read here
    http://ubuntuforums.org/showthread.php?t=2006840
    mc4man, 25 June Daily Build apt-get broken. Is there a way to get the "bad dpkg" fixed in the Quantal Daily Build"?

    Let me try your suggestions.

    Jerry

    I did.

    As of 25 June the bug is still in the Quantal Daily Build.

    Did an
    sudo apt-get update
    now apt-get install is working.

    Either a change since today's daily build was made today or daily build didn't do an update.

    Anyway install successful up and running just before Alpha 2. Some pain with wireless WPA which is another bug #.

    Jerry
    Last edited by jerrylamos; June 25th, 2012 at 06:20 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •