Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: New Install: Grub "you need to load the kernel first"

  1. #11
    Join Date
    Mar 2008
    Location
    Colorado, USA
    Beans
    18

    Re: New Install: Grub "you need to load the kernel first"

    Thanks, I'll give it a try this evening.

  2. #12
    Join Date
    Mar 2008
    Location
    Colorado, USA
    Beans
    18

    Re: New Install: Grub "you need to load the kernel first"

    This is interesting. If I hit 'c' on the grub menu and type in the 'ls (hd1,5)/' command, I get 'no such partition'.

    I then type 'exit' to get back to the menu and hit 'c' again and repeat 'ls (hd1,5)/' and it works. There is a vmlinuz and an initrd.img. If I continue with the rest of the commands in your first block of commands, the screen eventually goes blank and seems to hang.


    I can mount and inspect these partitions from within the Xubuntu 12.04 OS.

  3. #13
    Join Date
    Jan 2008
    Location
    France
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Arrow Re: New Install: Grub "you need to load the kernel first"

    Hello
    Following your PM,

    I see no error in the Boot-Repair log. It successfully installed the GRUB of your Xubuntu (sda5) into the MBRs of sda and sdb.

    As you now can boot into the systems located on sda (Xubuntu&Seven) but not the ones located on sdb (Vista&Kubuntu), I suppose that this is due to a bug of GRUB (which generated wrong entries, or cannot read on sdb...), so you should first create a bug report here: https://bugs.launchpad.net/ubuntu/+s...grub2/+filebug
    and see what GRUB devs will say.

    As a workaround, we can try to install the GRUB of Kubuntu into the MBR of sdb, so that you can boot Vista&Kubuntu by making your BIOS boot on sdb. (and if you are lucky, this GRUB menu will also allow you to boot Xubuntu&Seven).
    To do this:
    1) run Boot-Repair, click "Advanced options", go to the "GRUB location" tab, select "OS to boot by default: Ubuntu 10.04.4 LTS (sdb5)" and "Place GRUB into: sdb", apply. Indicate the new URL that will appear.
    2) Setup your BIOS so that your 320GB disk is first in the boot order.
    3) Reboot and tell us what you observe (do you see a GRUB menu? if yes, which entries work? which is the first entry?)

  4. #14
    Join Date
    Mar 2008
    Location
    Colorado, USA
    Beans
    18

    Re: New Install: Grub "you need to load the kernel first"

    Yann,

    I've submitted a bug report at Launchpad(https://bugs.launchpad.net/ubuntu/+s...2/+bug/1018419).

    I'll attempt your workaround this evening.

    Thanks!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •