Results 1 to 4 of 4

Thread: Ibus Language/Keyboard input method menu disappeared

  1. #1
    Join Date
    Jun 2012
    Beans
    2

    Ibus Language/Keyboard input method menu disappeared

    Hello, Ubuntu forums!
    I'm returning to Ubuntu after a few years in the Windows wilderness. I installed 12.04 about a week ago and so far I'm impressed at how easy things have been to configure to my liking. It seems like usability has come a long way.

    There's a couple things that are still giving me trouble, though. One of them is international text input support. I need to be able to enter Chinese pinyin for a project. I installed IBus and turned on the Pinyin keyboard input method. It was working for a while (in some applications - not in Emacs, unfortunately, but i can work around that). But now, after some updates and restarts, the input-method menu no longer appears in my menu bar, and I can't figure out how to get it back.

    Here are some of the things I have tried:

    * Going to Language Support under System Settings, I see that Chinese (simplified) appears (greyed out) at the bottom of the language list. Keyboard input method system is set to "ibus".

    * Following instructions at https://help.ubuntu.com/community/ibus , I added ibus-daemon to my startup applications, and restarted. I saw the input-method menu in the menu bar on the login screen (and briefly got my hopes up) but once I was logged in, it disappeared once again.

    * I can launch the IBus application using Dash, but nothing seems to happen.

    * I can launch IBus Preferences / Keyboard Input Methods. "Show icon on system tray" and "show input method name on menu bar" are checked. "Show language panel" is set to "always".

    * The enable/disable keyboard shortcut is set to ctrl+alt+space, and the "switch methods" shortcut is set to alt+shift_L, but hitting either of those key combos seems to do nothing.

    I'm new here, so apologies if the general forum is the wrong place for this topic. I looked around a bit but didn't see more specific forum for internationalization or language input issues.

    I greatly appreciate any help that anyone can offer. Thank you!
    --Jono

  2. #2
    Join Date
    Jun 2012
    Beans
    2

    Re: Ibus Language/Keyboard input method menu disappeared

    Update: After some fiddling about, I've discovered that I can actually switch the input method using the keyboard shortcuts; it's just that there's no visible indication that I have done so, and no way to tell what input mode I'm currently in.

    This discovery makes my problem less urgent, since I can now input Chinese text, but I would still like to figure out what's gone wrong, and how to get the menu to display again.

    Thanks,
    --Jono

  3. #3
    Join Date
    Mar 2013
    Beans
    2

    Re: Ibus Language/Keyboard input method menu disappeared

    Quote Originally Posted by Jono Xia View Post
    Update: After some fiddling about, I've discovered that I can actually switch the input method using the keyboard shortcuts; it's just that there's no visible indication that I have done so, and no way to tell what input mode I'm currently in.

    This discovery makes my problem less urgent, since I can now input Chinese text, but I would still like to figure out what's gone wrong, and how to get the menu to display again.

    Thanks,
    --Jono

    i also encountered this problem!!!!!!

  4. #4
    Join Date
    Mar 2013
    Beans
    2

    Re: Ibus Language/Keyboard input method menu disappeared

    系统设置-->通用辅助功能-->打字选项卡里把“打开键盘辅助功能特性”勾上

    应该就可以了………………………………………………

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •