Results 1 to 8 of 8

Thread: Changing user permissions

  1. #1
    Join Date
    Jun 2012
    Beans
    24

    Angry Changing user permissions

    Hi All

    so the back story is as follows. i was a happy mac user who backed up all important data on two external HDD's, however my mac then crashed and burned. I then went and bought a PC replacement and am now using ubuntu 12.04 LTS. I then discovered that all data on the externals is set to read only.

    I need to change the permissions of the data on the external HDD's so i can read & right it freely OR somehow align my Ubuntu system user profile to my external HDD's.

    The data is quite large. 100's of GB of .MP3, .wave and ISO installers make up the majority. It quite important i am able to recover this data. if i have to (for corruption safety) change files one at a time, i will.

    ive tryed the forums with moderate luck, i was looking at baltix 2.7? or some kind of elaborate terminal procedure?
    but before i start mucking with important files i thought a straight (and personally specific) explanation would be smart.

    I'm running Ubuntu 12.04 LTS
    My mac run (i think) the latest snow leopard.

    thanks

  2. #2
    Join Date
    Jan 2008
    Location
    Manchester UK
    Beans
    13,634
    Distro
    Ubuntu

    Re: Changing user permissions

    If your external drives have macs hfs+ file system then you either need to disable journaling or force mount them read/write. Neither approach is particularly safe as afaik, especially if your data is important to you.

    The best option if you plan on using Ubuntu for the forseeable future would be to transfer the data to a drive with a linux compatible filesystem.

  3. #3
    Join Date
    Oct 2010
    Location
    rhodes,greece
    Beans
    54
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Changing user permissions

    Give the follow command in terminal
    Code:
    gksudo nautilus
    Then type your passward and then in the files
    you want right click
    and choose properties, there u can change the properties u like to.
    if you are in hurry you go slow

  4. #4
    Join Date
    Mar 2012
    Beans
    246

    Re: Changing user permissions

    Quote Originally Posted by yiannis66 View Post
    Give the follow command in terminal
    Code:
    gksudo nautilus
    Then type your passward and then in the files
    you want right click
    and choose properties, there u can change the properties u like to.
    Maybe i'm wrong but there is faster metod:

    Code:
    chown -R profile:users /
    chown - change ownership
    -R - recursively (all contents in folders)
    profile - your profile (in my case it is firekage)
    users - group

    and

    Code:
    chmod 700 /folders/
    chmod - change files permission

    (for owner)

    Code:
    chmod 770 /folders/
    (for owner and groups)

    Code:
    chmod 777 /folders/
    (for owner, groups, all)

    Am I right?


    If i have to do something like this i just do:

    Code:
    chown -R firekage:users /mnt/ (because on mnt i have mounted my hard drive disks)
    chmod xxx /mnt/ (the same)
    that's all. If i use truecrypt container than

    Code:
    chown -R firekage:users /media/
    chmod xxx /media/
    Last edited by firekage; June 15th, 2012 at 07:04 PM.

  5. #5
    Join Date
    Jun 2012
    Beans
    24

    Re: Changing user permissions

    thx for the replies

    i should of also mentioned that i still have the HDD from my old mac (this hdd is the user of the external hdd im trying to access).

    so im going to use a friends macbook to boot of my hdd. once thats done ill just change the user permissions read and write. that should work right?

  6. #6
    Join Date
    Jun 2012
    Beans
    24

    Re: Changing user permissions

    ok so i booted the old internal mac harddrive on a friends mac, then changed the user permissions of the external harddrive in question (and all files on it) to read/write.

    however i after connecting the new read/write external to my ubuntu laptop i still cant write files on the external harddrive.... ?

  7. #7
    Join Date
    Jul 2012
    Beans
    5

    Re: Changing user permissions

    I am having a similar problem. bump.

  8. #8
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: Changing user permissions

    Quote Originally Posted by nothingspecial View Post
    If your external drives have macs hfs+ file system then you either need to disable journaling or force mount them read/write.
    Have you done this yet?
    Cheesemill

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •