Results 1 to 10 of 10

Thread: Still no automatic start od default kernel in grub at my place...

  1. #1
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,881
    Distro
    Ubuntu 14.04 Trusty Tahr

    Still no automatic start od default kernel in grub at my place...

    I still do not have automatic start of default (chosen by GRUB_DEFAULT=0 in /etc/default/grub) even though I have cleared everything I could think of (grubenv and similar...) and Grub is installed on /dev/sda as it is supposed to... Any ideas?
    Code:
                      Boot Info Script 0.61      [1 April 2012]
    
    
    ============================= Boot Info Summary: ===============================
    
     => Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 1 of 
        the same hard drive for core.img. core.img is at this location and looks 
        for (,msdos1)/boot/grub on this drive.
    
    sda1: __________________________________________________________________________
    
        File system:       ext4
        Boot sector type:  -
        Boot sector info: 
        Operating System:  Ubuntu quantal (development 
                           branch)
        Boot files:        /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img
    
    sda2: __________________________________________________________________________
    
        File system:       Extended Partition
        Boot sector type:  -
        Boot sector info: 
    
    sda5: __________________________________________________________________________
    
        File system:       swap
        Boot sector type:  -
        Boot sector info: 
    
    ============================ Drive/Partition Info: =============================
    
    Drive: sda _____________________________________________________________________
    
    Disk /dev/sda: 250.1 GB, 250059350016 bytes
    255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    
    Partition  Boot  Start Sector    End Sector  # of Sectors  Id System
    
    /dev/sda1    *          2,048   482,107,391   482,105,344  83 Linux
    /dev/sda2         482,109,438   488,396,799     6,287,362   5 Extended
    /dev/sda5         482,109,440   488,396,799     6,287,360  82 Linux swap / Solaris
    
    
    "blkid" output: ________________________________________________________________
    
    Device           UUID                                   TYPE       LABEL
    
    /dev/sda1        ...   ext4       
    /dev/sda5        ...   swap       
    
    ================================ Mount points: =================================
    
    Device           Mount_Point              Type       Options
    
    /dev/sda1        /                        ext4       (rw,noatime,nodiratime,errors=remount-ro,data=ordered,nouser_xattr)
    
    
    =========================== sda1/boot/grub/grub.cfg: ===========================
    
    --------------------------------------------------------------------------------
    #
    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #
    
    ### BEGIN /etc/grub.d/00_header ###
    if [ -s $prefix/grubenv ]; then
      set have_grubenv=true
      load_env
    fi
    set default="0"
    if [ "${prev_saved_entry}" ]; then
      set saved_entry="${prev_saved_entry}"
      save_env saved_entry
      set prev_saved_entry=
      save_env prev_saved_entry
      set boot_once=true
    fi
    
    function savedefault {
      if [ -z "${boot_once}" ]; then
        saved_entry="${chosen}"
        save_env saved_entry
      fi
    }
    
    function recordfail {
      set recordfail=1
      if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
    }
    
    function load_video {
      insmod vbe
      insmod vga
      insmod video_bochs
      insmod video_cirrus
    }
    
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set=root ...
    if loadfont /usr/share/grub/unicode.pf2 ; then
      set gfxmode=auto
      load_video
      insmod gfxterm
      insmod part_msdos
      insmod ext2
      set root='(hd0,msdos1)'
      search --no-floppy --fs-uuid --set=root ...
      set locale_dir=($root)/boot/grub/locale
      set lang=en_US
      insmod gettext
    fi
    terminal_output gfxterm
    if [ "${recordfail}" = 1 ]; then
    #  set timeout=-1
      set timeout=2
    
    else
      set timeout=2
    fi
    ### END /etc/grub.d/00_header ###
    
    ### BEGIN /etc/grub.d/05_debian_theme ###
    set menu_color_normal=white/black
    set menu_color_highlight=black/light-gray
    if background_color 44,0,30; then
      clear
    fi
    ### END /etc/grub.d/05_debian_theme ###
    
    ### BEGIN /etc/grub.d/10_linux ###
    function gfxmode {
    	set gfxpayload="$1"
    	if [ "$1" = "keep" ]; then
    		set vt_handoff=vt.handoff=7
    	else
    		set vt_handoff=
    	fi
    }
    if [ ${recordfail} != 1 ]; then
      if [ -e ${prefix}/gfxblacklist.txt ]; then
        if hwmatch ${prefix}/gfxblacklist.txt 3; then
          if [ ${match} = 0 ]; then
            set linux_gfx_mode=keep
          else
            set linux_gfx_mode=text
          fi
        else
          set linux_gfx_mode=text
        fi
      else
        set linux_gfx_mode=keep
      fi
    else
      set linux_gfx_mode=text
    fi
    export linux_gfx_mode
    if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
    menuentry 'Ubuntu, with Linux 3.4.0-999-generic' --class ubuntu --class gnu-linux --class gnu --class os {
    	recordfail
    	gfxmode $linux_gfx_mode
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='(hd0,msdos1)'
    	search --no-floppy --fs-uuid --set=root ...
    	linux	/boot/vmlinuz-3.4.0-999-generic root=UUID=... ro   nohz=off text ipv6.disable=1
    	initrd	/boot/initrd.img-3.4.0-999-generic
    }
    menuentry 'Ubuntu, with Linux 3.4.0-999-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
    	recordfail
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='(hd0,msdos1)'
    	search --no-floppy --fs-uuid --set=root 
    	echo	'Loading Linux 3.4.0-999-generic ...'
    	linux	/boot/vmlinuz-3.4.0-999-generic root=UUID=... ro recovery nomodeset 
    	echo	'Loading initial ramdisk ...'
    	initrd	/boot/initrd.img-3.4.0-999-generic
    }
    menuentry 'Ubuntu, with Linux 3.4.0-1-generic' --class ubuntu --class gnu-linux --class gnu --class os {
    	recordfail
    	gfxmode $linux_gfx_mode
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='(hd0,msdos1)'
    	search --no-floppy --fs-uuid --set=root ...
    	linux	/boot/vmlinuz-3.4.0-1-generic root=UUID=... ro   nohz=off text ipv6.disable=1
    	initrd	/boot/initrd.img-3.4.0-1-generic
    }
    menuentry 'Ubuntu, with Linux 3.4.0-1-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
    	recordfail
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='(hd0,msdos1)'
    	search --no-floppy --fs-uuid --set=root ...
    	echo	'Loading Linux 3.4.0-1-generic ...'
    	linux	/boot/vmlinuz-3.4.0-1-generic root=UUID=... ro recovery nomodeset 
    	echo	'Loading initial ramdisk ...'
    	initrd	/boot/initrd.img-3.4.0-1-generic
    }
    menuentry 'Ubuntu, with Linux 3.3.0-5.dmz.1-liquorix-amd64' --class ubuntu --class gnu-linux --class gnu --class os {
    	recordfail
    	gfxmode $linux_gfx_mode
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='(hd0,msdos1)'
    	search --no-floppy --fs-uuid --set=root ...
    	linux	/boot/vmlinuz-3.3.0-5.dmz.1-liquorix-amd64 root=UUID=... ro   nohz=off text ipv6.disable=1
    	initrd	/boot/initrd.img-3.3.0-5.dmz.1-liquorix-amd64
    }
    menuentry 'Ubuntu, with Linux 3.3.0-5.dmz.1-liquorix-amd64 (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
    	recordfail
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='(hd0,msdos1)'
    	search --no-floppy --fs-uuid --set=root ...
    	echo	'Loading Linux 3.3.0-5.dmz.1-liquorix-amd64 ...'
    	linux	/boot/vmlinuz-3.3.0-5.dmz.1-liquorix-amd64 root=UUID=... ro recovery nomodeset 
    	echo	'Loading initial ramdisk ...'
    	initrd	/boot/initrd.img-3.3.0-5.dmz.1-liquorix-amd64
    }
    ### END /etc/grub.d/10_linux ###
    
    ### BEGIN /etc/grub.d/20_linux_xen ###
    ### END /etc/grub.d/20_linux_xen ###
    
    ### BEGIN /etc/grub.d/20_memtest86+ ###
    menuentry "Memory test (memtest86+)" {
    	insmod part_msdos
    	insmod ext2
    	set root='(hd0,msdos1)'
    	search --no-floppy --fs-uuid --set=root ...
    	linux16	/boot/memtest86+.bin
    }
    menuentry "Memory test (memtest86+, serial console 115200)" {
    	insmod part_msdos
    	insmod ext2
    	set root='(hd0,msdos1)'
    	search --no-floppy --fs-uuid --set=root ...
    	linux16	/boot/memtest86+.bin console=ttyS0,115200n8
    }
    ### END /etc/grub.d/20_memtest86+ ###
    
    ### BEGIN /etc/grub.d/30_os-prober ###
    ### END /etc/grub.d/30_os-prober ###
    
    ### BEGIN /etc/grub.d/40_custom ###
    # This file provides an easy way to add custom menu entries.  Simply type the
    # menu entries you want to add after this comment.  Be careful not to change
    # the 'exec tail' line above.
    ### END /etc/grub.d/40_custom ###
    
    ### BEGIN /etc/grub.d/41_custom ###
    if [ -f  $prefix/custom.cfg ]; then
      source $prefix/custom.cfg;
    fi
    ### END /etc/grub.d/41_custom ###
    --------------------------------------------------------------------------------
    
    =============================== sda1/etc/fstab: ================================
    
    --------------------------------------------------------------------------------
    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    nodev,noexec,nosuid 0       0
    # / was on /dev/sda1 during installation
    UUID=... /               ext4    errors=remount-ro,data=ordered,noatime,nodiratime,nouser_xattr 0       1
    # swap was on /dev/sda5 during installation
    UUID=... none            swap    sw              0       0
    # zika tmpfs tweak
    #tmpfs        /tmp           tmpfs    defaults,noatime    0    0
    #tmpfs        /var/run       tmpfs    defaults,noatime    0    0
    #tmpfs        /var/lock      tmpfs    defaults,noatime    0    0
    #tmpfs        /var/log       tmpfs    defaults,noatime    0    0
    #tmpfs        /var/run       tmpfs    defaults,noatime    0    0
    #tmpfs        /var/mail      tmpfs    defaults,noatime    0    0
    #tmpfs        /var/spool     tmpfs    defaults,noatime    0    0
    #tmpfs        /var/tmp       tmpfs    defaults,noatime    0    0
    #tmpfs        /var/cache     tmpfs    defaults,noatime    0    0
    
    --------------------------------------------------------------------------------
    
    =================== sda1: Location of files loaded by Grub: ====================
    
               GiB - GB             File                                 Fragment(s)
    
                   =                boot/grub/core.img                             1
                   =                boot/grub/grub.cfg                             1
                   =                boot/initrd.img-3.3.0-5.dmz.1-liquorix-amd64   1
                   =                boot/initrd.img-3.4.0-1-generic                2
                   =                boot/initrd.img-3.4.0-999-generic              1
                   =                boot/vmlinuz-3.3.0-5.dmz.1-liquorix-amd64      1
                   =                boot/vmlinuz-3.4.0-1-generic                   2
                   =                boot/vmlinuz-3.4.0-999-generic                 2
                   =                initrd.img                                     1
                   =                initrd.img.old                                 1
                   =                vmlinuz                                        2
                   =                vmlinuz.old                                    1
    
    ========= Devices which don't seem to have a corresponding hard drive: =========
    
    sdb sdc sdd sde 
    
    =============================== StdErr Messages: ===============================
    
    xz: (stdin): Compressed data is corrupt
    awk: cmd. line:36: Math support is not compiled in
    awk: cmd. line:36: Math support is not compiled in
    awk: cmd. line:36: Math support is not compiled in
    awk: cmd. line:36: Math support is not compiled in
    awk: cmd. line:36: Math support is not compiled in
    awk: cmd. line:36: Math support is not compiled in
    awk: cmd. line:36: Math support is not compiled in
    awk: cmd. line:36: Math support is not compiled in
    awk: cmd. line:36: Math support is not compiled in
    awk: cmd. line:36: Math support is not compiled in
    awk: cmd. line:36: Math support is not compiled in
    awk: cmd. line:36: Math support is not compiled in
    The only change from vanilla is change in /etc/grub.d/10_linux:

    Code:
    ...
    
      list=`echo $list | tr ' ' '\n' | grep -vx $linux | tr '\n' ' '`
    
    #  if [ "$list" ] && ! $in_submenu; then
    #    echo "submenu \"Previous Linux versions\" {"
    #    in_submenu=:
    #  fi
    done
    
    if $in_submenu; then
      echo "}"
    fi
    Last edited by zika; May 10th, 2012 at 12:54 PM.

  2. #2
    Join Date
    Mar 2006
    Beans
    4,373
    Distro
    Ubuntu Development Release

    Re: Still no automatic start od default kernel in grub at my place...

    can you boot by selecting the entry and hitting return ? if not the drive that ubiquity called sda may not be sda in your bios , one of my favorite bugs , ubiquity dosen't even call the same drive sdX on 2 consecutive boots of the live cd .
    if it ain't broke you haven't tweaked it enough

  3. #3
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,881
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Still no automatic start od default kernel in grub at my place...

    Quote Originally Posted by ronacc View Post
    can you boot by selecting the entry and hitting return ? if not the drive that ubiquity called sda may not be sda in your bios , one of my favorite bugs , ubiquity dosen't even call the same drive sdX on 2 consecutive boots of the live cd .
    There is no problem with boot. Knock on wood... Just no automatic boot and no countdown at grub boot window... As it triggers grubenv as there was a bad previous boot (which there was not)...

  4. #4
    Join Date
    Mar 2006
    Beans
    4,373
    Distro
    Ubuntu Development Release

    Re: Still no automatic start od default kernel in grub at my place...

    hmm I just did a fresh install from the amd64 desktop iso and its booting ok , check /etc/fstab and see if anything looks wonky there on your sda .
    if it ain't broke you haven't tweaked it enough

  5. #5
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,881
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Still no automatic start od default kernel in grub at my place...

    Quote Originally Posted by ronacc View Post
    hmm I just did a fresh install from the amd64 desktop iso and its booting ok , check /etc/fstab and see if anything looks wonky there on your sda .
    Fstab is given in my first post. Nothing „wonky“ for my taste&knowledge...

  6. #6
    Join Date
    Sep 2009
    Beans
    8,874
    Distro
    Ubuntu Development Release

    Re: Still no automatic start od default kernel in grub at my place...

    I would just purge and reload grub from the desktop you will probably be set.

    Code:
    sudo apt-get purge grub-pc grub-common
    then

    Code:
    sudo apt-get install grub-pc grub-common
    When asked where grub goes just choose sda and use the space key to tick it.

    then run

    Code:
    sudo update-grub

  7. #7
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,881
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Still no automatic start od default kernel in grub at my place...

    Quote Originally Posted by wilee-nilee View Post
    I would just purge and reload grub from the desktop you will probably be set.

    Code:
    sudo apt-get purge grub-pc grub-common
    then

    Code:
    sudo apt-get install grub-pc grub-common
    When asked where grub goes just choose sda and use the space key to tick it.

    then run

    Code:
    sudo update-grub
    Already done. Once I get enough time I'ii try it again. It is (already) very high on my ToDo list...
    There is a thread about this in previous testing PP Forum... I (really) tried everything that could pop up as an idea...

  8. #8
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,881
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Still no automatic start od default kernel in grub at my place...

    It seems (we will see after several boot cycles) that I've found the culprit: during some testings with net I've made a script to umount nfs and ... It worked but it seems that it interfered with grubenv... I'll investigate more once I get time...
    I'm glad I did not revert to trying a bigger hammer...

    Update₁: Script was not guilty. Still searching...

    Update₂: If I put „nomodeset“ in kernel line it works! I put „radeon.modeset=1“ with that and I have both worlds OK... Total serendipity...

    If this works in the morning I'll mark thread as „solved“...
    Last edited by zika; May 14th, 2012 at 08:22 AM.

  9. #9
    Join Date
    Mar 2006
    Beans
    4,373
    Distro
    Ubuntu Development Release

    Re: Still no automatic start od default kernel in grub at my place...

    glad you found it , I sometimes have to remove " quite splash " from the boot line to get it to go all the way to DT .
    if it ain't broke you haven't tweaked it enough

  10. #10
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,881
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Still no automatic start od default kernel in grub at my place...

    Quote Originally Posted by ronacc View Post
    glad you found it , I sometimes have to remove " quite splash " from the boot line to get it to go all the way to DT .
    No that is/was not remedy. Twilight Zone is/was that a remedy is to turn Floppy Controller on in BIOS??? ...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •