Results 1 to 4 of 4

Thread: cannot see /dev/sda during installation

  1. #1
    Join Date
    Sep 2006
    Beans
    5

    Exclamation cannot see /dev/sda during installation

    Hi guys,

    I am currently having a problem with installing Ubuntu 12.04. I have a PC running Windows 7 and with 4 hard drives.

    All partitions listed below:

    Hard Drive A
    Partition 1: 100MB, System Reserved (Win7 Required)
    Partition 2: 100GB, Windows 7 OS
    Partition 3: 670GB, Data 1
    Partition 4: 162GB, free space for UBUNTU
    Hard Drive B
    Partition 1: 1TB, Data 2
    Hard Drive C
    Partition 1: 500GB, Windows Backup
    Hard Drive D
    Partition 1: 750GB, Data 3


    The problem is when I go to the partition step and select "Something else" during installation, all partions are displayed as a list except partitions on HARD DRIVE A (there is no /dev/sda). So I am unable to get ubuntu installed. /dev/sda can be diplayed by using Gparted. It is really weird, because everything was fine on ubuntu 11.04 and earlier versions. Please help me.
    Last edited by cncsc; June 14th, 2012 at 06:15 PM.

  2. #2
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: cannot see /dev/sda during installation

    If the disk has been used in raid, it has raid meta data remains. In this case ubuntu ignores it thinking you are using it in a raid array.

    If you ARE NOT using any raid, remove the meta data from live mode with:
    sudo dmraid -E -r /dev/sda

    After that it should be fine. Usually this is the problem with these symptoms.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  3. #3
    Join Date
    Sep 2006
    Beans
    5

    Re: cannot see /dev/sda during installation

    Quote Originally Posted by darkod View Post
    If the disk has been used in raid, it has raid meta data remains. In this case ubuntu ignores it thinking you are using it in a raid array.

    If you ARE NOT using any raid, remove the meta data from live mode with:
    sudo dmraid -E -r /dev/sda

    After that it should be fine. Usually this is the problem with these symptoms.
    Thanks for your reply. I will try this once i'm back home.
    Last edited by cncsc; June 14th, 2012 at 06:24 PM.

  4. #4
    Join Date
    Sep 2006
    Beans
    5

    Re: cannot see /dev/sda during installation

    Quote Originally Posted by darkod View Post
    If the disk has been used in raid, it has raid meta data remains. In this case ubuntu ignores it thinking you are using it in a raid array.

    If you ARE NOT using any raid, remove the meta data from live mode with:
    sudo dmraid -E -r /dev/sda

    After that it should be fine. Usually this is the problem with these symptoms.
    This command works for me! Everything is OK now! Thank you again!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •