Greetings:

I am installing this library needed for GTK from source, named atk-2.4.0, i have already installed all prior dependencies, and in this case the one that marks as inexistent is GLIB

checking for GLIB - version >= 2.31.2... no
configure: error:
*** GLIB 2.31.2 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

The thing is, i already configured said paths, exported them and even checked for the running version:

Code:
$ echo $PKG_CONFIG_PATH
/opt/glib/lib/pkgconfig
$ echo $LD_LIBRARY_PATH
/opt/glib/lib/pkgconfig
$ pkg-config --modversion glib-2.0
2.32.3
As you can see it is a version higher than what the configure expects. Is there anything i can do to solve this problem?

Regards.