Dear all,

I'm trying to load the most recent update of QGIS through the update manager, and the update manager is not allowing because the sources are not authenticated. The error message is below

Requires installation of untrusted packages

The action would require the installation of packages from sources that are not authenticated.

Details
gdal-bin libfreexl1 libgdal1 libgeos-3.3.3 libgeos-c1 libqgis1.7.4 libspatialite3 python-gdal python-qgis python-qgis-common qgis qgis-common qgis-plugin-grass qgis-plugin-grass-common qgis-providers qgis-providers-common
I guess maybe there is something I have done wrong when I originally installed QGIS? Any help would be great.

Thanks
BB