Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Freezing firefox

  1. #1
    Join Date
    Mar 2012
    Beans
    115

    Question Freezing firefox

    Installed kubuntu 12.04 from alternate cd (fully encrypted). Running firefox with js off. Also disabled all visible add-ons. No plugins, no flash. System should be secure and fast. Instead what happens: firefox freezes not only iself but the whole desktop for no reason quite often. When a big page is loaded it may freeze (even this should not happen), but it happens at random times. Sometimes I get an error (after freezing) which says something.js is not resposnding. Why is it even running: js is supposed to be off. Don't want to add any addons or plugins for extrasecurity. I just don't want any scripts. (I don't click any ads, so noone can make click money from me anyway.)

  2. #2
    Join Date
    Mar 2012
    Beans
    115

    Re: Freezing firefox

    Noone really knows anything about this? There are some programs running without user control, and I want to disable them permanently. Things that and with .js, .jsm, or any addons or default plugins. How can they be eliminated? Do I need to be a linux expert to get enough control on firefox? I also searched internet and it looks like these are common problems but people don't want to give any answer.

  3. #3
    Join Date
    Dec 2011
    Location
    The Netherlands
    Beans
    1,093
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Freezing firefox

    Check your swap and your ram.
    There might be a lack of size in either or bad ram.
    My 256mb ram systems would go swapping so bad when using google images that i had to pull the ethernet cable to make it timeout and stop swapping.
    "Everything that has a beginning, has an end." --an unexpectedly wise wallpaper

  4. #4
    Join Date
    Mar 2012
    Beans
    115

    Re: Freezing firefox

    Why do everything need to freeze only because one page is big, or I switch desktops. Only solution becomes: power off, and lose everything at once. If you need to be healty you need to know more than doctors. if you need to use computer you need to be as good as a hcker, or risk losing everything. Whenever I ask a critical question I don't get any answer (thanks for answer but this doen't help much). Main question: how to eliminate .jsm programs. Javascript is disabled, still some uknonw scripts running. Which firefox programs are really unnecessary and runs without user approval?

  5. #5
    Join Date
    Sep 2011
    Beans
    1,531

    Re: Freezing firefox

    How did you disable javascripts in your browser?

  6. #6
    Join Date
    May 2010
    Beans
    462
    Distro
    Ubuntu Development Release

    Re: Freezing firefox

    Quote Originally Posted by Ms. Daisy View Post
    How did you disable javascripts in your browser?
    aboutlugins ->>> Firefox (make sure no java is down there)


  7. #7
    Join Date
    Sep 2011
    Beans
    1,531

    Re: Freezing firefox

    Quote Originally Posted by wacky_sung View Post
    about: plugins ->>> Firefox (make sure no java is down there)
    Are we talking about JavaScripts or Java? Similar names but very different things.

  8. #8
    Join Date
    May 2010
    Beans
    462
    Distro
    Ubuntu Development Release

    Re: Freezing firefox

    Quote Originally Posted by Ms. Daisy View Post
    Are we talking about JavaScripts or Java? Similar names but very different things.
    Sound complex but in they are in common in term of programming.

  9. #9
    Join Date
    Sep 2011
    Beans
    1,531

    Re: Freezing firefox

    OK, I'll just make some presumptions to save a little time here. I presume that you disabled java in the browser like wacky_sung showed. However, that does not block javascripts. If you want to limit or stop javascripts, then you need to install an add-on like NoScripts. For a guide on how to configure NoScripts, please see the No Scripts wiki.

  10. #10
    Join Date
    May 2010
    Beans
    462
    Distro
    Ubuntu Development Release

    Re: Freezing firefox

    Quote Originally Posted by Ms. Daisy View Post
    OK, I'll just make some presumptions to save a little time here. I presume that you disabled java in the browser like wacky_sung showed. However, that does not block javascripts. If you want to limit or stop javascripts, then you need to install an add-on like NoScripts. For a guide on how to configure NoScripts, please see the No Scripts wiki.
    Actually you do not need Noscipt to do the disable of java script.

    Uncheck the Javascript box from firefox will do.


Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •