Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Ambiance theme doesn't apply to all apps?

  1. #11
    Join Date
    Sep 2008
    Beans
    796

    Re: Ambiance theme doesn't apply to all apps?

    Quote Originally Posted by mc4man View Post
    If you mean sub menus like in screen then that's 'fixable', though ATM the new gtk 3.5.4 has messed up some things in light-themes so may be better fixed when stuff settles out
    (firefox & some other apps, (gtk2), are adjusted thru the gtkrc file
    You'll probably see what I mean from this screenshot.
    Attached Images Attached Images

  2. #12
    Join Date
    Jun 2007
    Beans
    13,327

    Re: Ambiance theme doesn't apply to all apps?

    Quote Originally Posted by paul_in_london View Post
    You'll probably see what I mean from this screenshot.
    I guess I'm looking at a browser in gnome Classic?, no global menu?
    Anyway browsers still use gtk2 (gtkrc) for in window menus as do some other apps & window deco context menus

    Here I don't use the default though do ck. it out, then switch to an ambiance I've keep going since 11.10, as things break or are changed (usually from gtk3), i edit to fix.

    So here ATM all is quite fine except for one small issue I see in both mine & the current default

    As far as your gtk2 menu color, I'll attach my current gtkrc, you can try if desired, if it improves great, if not then just put back the current one

    To try -
    open /usr/share/themes/Ambiance/gtk-2.0 as root, rename the current gtkrc & paste in the new one. you may need to do a log out/in after

    (you could otherwise search out an ambiance mod by StanAngeloff, if he hasn't adjusted for 12.10 then it would need a little help, it also addresses normal context menu color (gtk3

    If curious this is the small issue I see with both the current LT & my mod, haven't found a way to fix other then reset after login with a gsettings command(s)
    https://bugs.launchpad.net/ubuntu/+s...s/+bug/1014948
    Attached Images Attached Images
    Attached Files Attached Files

  3. #13
    Join Date
    Sep 2008
    Beans
    796

    Re: Ambiance theme doesn't apply to all apps?

    Quote Originally Posted by mc4man View Post
    I guess I'm looking at a browser in gnome Classic?, no global menu?
    Anyway browsers still use gtk2 (gtkrc) for in window menus as do some other apps & window deco context menus

    Here I don't use the default though do ck. it out, then switch to an ambiance I've keep going since 11.10, as things break or are changed (usually from gtk3), i edit to fix.

    So here ATM all is quite fine except for one small issue I see in both mine & the current default

    As far as your gtk2 menu color, I'll attach my current gtkrc, you can try if desired, if it improves great, if not then just put back the current one

    To try -
    open /usr/share/themes/Ambiance/gtk-2.0 as root, rename the current gtkrc & paste in the new one. you may need to do a log out/in after

    (you could otherwise search out an ambiance mod by StanAngeloff, if he hasn't adjusted for 12.10 then it would need a little help, it also addresses normal context menu color (gtk3

    If curious this is the small issue I see with both the current LT & my mod, haven't found a way to fix other then reset after login with a gsettings command(s)
    https://bugs.launchpad.net/ubuntu/+s...s/+bug/1014948
    Thanks mc4man. What I ended up doing (before I saw your post a second ago) was installing ambiance-dark-gtk-theme from here (no quantal branch at the moment):

    https://launchpad.net/~kokoto-java/+...filter=precise

    A little too dark maybe (see screenshot).
    Attached Images Attached Images

  4. #14
    Join Date
    Jun 2007
    Beans
    13,327

    Re: Ambiance theme doesn't apply to all apps?

    Doesn't look that bad, seems to use black?

    At least here for my current I use the same as ambiance - #3c3b37

    Without seeing the theme fully (nautilus, ect.) I might be inclined to darken the selected_fg_color so it stands out a bit
    (here I use a selected_fg_color:#3c3b37 to go with ambiance default, it looks better with the selected_bg_color:#D3B37D I use

    So this may be interesting (or not

    Code:
    gsettings set org.gnome.desktop.interface gtk-color-scheme "selected_fg_color:#000000"
    To unset back to theme default
    Code:
    gsettings set org.gnome.desktop.interface gtk-color-scheme ""
    There are likely a number of xsession-errors warning with that theme, not terribly important

  5. #15
    Join Date
    Sep 2008
    Beans
    796

    Re: Ambiance theme doesn't apply to all apps?

    Quote Originally Posted by mc4man View Post
    Doesn't look that bad, seems to use black?

    At least here for my current I use the same as ambiance - #3c3b37

    Without seeing the theme fully (nautilus, ect.) I might be inclined to darken the selected_fg_color so it stands out a bit
    (here I use a selected_fg_color:#3c3b37 to go with ambiance default, it looks better with the selected_bg_color:#D3B37D I use

    So this may be interesting (or not

    Code:
    gsettings set org.gnome.desktop.interface gtk-color-scheme "selected_fg_color:#000000"
    To unset back to theme default
    Code:
    gsettings set org.gnome.desktop.interface gtk-color-scheme ""
    There are likely a number of xsession-errors warning with that theme, not terribly important
    Thanks again. Does it work for you? I get:

    Code:
    paul@quantal-64:~$ gsettings set org.gnome.desktop.interface gtk-color-scheme "selected_fg_color:#000000"
    
    ** (process:3523): WARNING **: Could not connect: Connection refused
    
    ** (process:3523): WARNING **: Could not connect: Connection refused
    paul@quantal-64:~$
    Previously (after changing theme) I also wanted to reset my terminal background colour so I tried:

    Code:
    paul@quantal-64:~$ gconftool --type string --set /desktop/gnome/background/prima
    ry_color "#2F0B24"
    
    (gconftool:7160): GConf-WARNING **: Client failed to connect to the D-BUS daemon
    :
    Failed to connect to socket /tmp/dbus-6h5eo9VUQc: Connection refused
    Error setting value: No D-BUS daemon running
    
    paul@quantal-64:~$

  6. #16
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,867
    Distro
    Ubuntu Development Release

    Re: Ambiance theme doesn't apply to all apps?

    Quote Originally Posted by paul_in_london View Post
    Thanks mc4man. What I ended up doing (before I saw your post a second ago) was installing ambiance-dark-gtk-theme from here (no quantal branch at the moment):

    https://launchpad.net/~kokoto-java/+...filter=precise

    A little too dark maybe (see screenshot).
    That's hilarious! What a small world!?!?!?!

    I installed that theme, not more than 15 minutes ago. Looks great in LXDE/Openbox!

    Guess I'll go take a look-see in Unity.
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  7. #17
    Join Date
    Sep 2008
    Beans
    796

    Re: Ambiance theme doesn't apply to all apps?

    Actually after I installed the 3.5-rc4 kernel and rebooted I didn't get those errors any more.

  8. #18
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,867
    Distro
    Ubuntu Development Release

    Re: Ambiance theme doesn't apply to all apps?

    Quote Originally Posted by paul_in_london View Post
    Actually after I installed the 3.5-rc4 kernel and rebooted I didn't get those errors any more.
    Heh!

    Downloading, as we "speak"...

    Thanks!
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  9. #19
    Join Date
    Jun 2007
    Beans
    13,327

    Re: Ambiance theme doesn't apply to all apps?

    Quote Originally Posted by paul_in_london View Post
    Actually after I installed the 3.5-rc4 kernel and rebooted I didn't get those errors any more.
    Was going to post I tried your gconf command in a Classic session & no issue (though I guess if I wanted to change a terminal I'd likely do in profile preferences instead

    As far as the gsettings command(s), they work fine

    For the moment to 'fix' that small 'rendering' issue I see when I log in I run a reset combo, then my selected_fg is correct

    Ie. -
    Code:
    gsettings set org.gnome.desktop.interface gtk-color-scheme "" && \
    gsettings set org.gnome.desktop.interface gtk-color-scheme "selected_bg_color:#D3B37D;selected_fg_color:#3c3b37"
    That key is also in dconf as in screen

    Atm I'm sticking with compiz/unity/nautilus/ambiance though not sure if the future is rosy for mods
    Attached Images Attached Images

  10. #20
    Join Date
    Sep 2008
    Beans
    796

    Re: Ambiance theme doesn't apply to all apps?

    Quote Originally Posted by mc4man View Post
    Was going to post I tried your gconf command in a Classic session & no issue (though I guess if I wanted to change a terminal I'd likely do in profile preferences instead

    As far as the gsettings command(s), they work fine

    For the moment to 'fix' that small 'rendering' issue I see when I log in I run a reset combo, then my selected_fg is correct

    Ie. -
    Code:
    gsettings set org.gnome.desktop.interface gtk-color-scheme "" && \
    gsettings set org.gnome.desktop.interface gtk-color-scheme "selected_bg_color:#D3B37D;selected_fg_color:#3c3b37"
    That key is also in dconf as in screen

    Atm I'm sticking with compiz/unity/nautilus/ambiance though not sure if the future is rosy for mods
    EDIT: Got what I wanted after I edited the terminal profile via the GUI and unticked "Use colors from system theme".

    I know the terminal background colour code I want to use, but the GUI way isn't working for some reason (I've done it that way before without any problem) so that's why I tried the gconf command, but it didn't change anything.

    Also tried this:

    Code:
    gconftool-2 -t string -s /apps/gnome-terminal/profiles/Default/background_color "#2F0B24"
    but still no effect.

    EDIT: Got what I wanted after I edited the terminal profile via the GUI and unticked "Use colors from system theme".
    Last edited by paul_in_london; June 25th, 2012 at 12:26 AM. Reason: Update

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •