Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: (12.04) partition not mounting at boot

  1. #1
    Join Date
    Mar 2012
    Beans
    130

    (12.04) partition not mounting at boot

    I have a second drive on my system, which has a partition for Windows, and one for Ubuntu. When I boot into Ubuntu, I get an error saying that the system was unable to mount this device. I choose "s" for skip, the boot completes, and then I'm able to manually mount via gparted.

    I probably have to give you more information to answer this, but...what might be going on, and what's the recommended disk utility for fixing such an issue?

    Thanks.

  2. #2
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: (12.04) partition not mounting at boot

    Once you boot, open /etc/fstab as root. There is most likely a line trying to mount a partition which isn't working. You can disable that line by placing a # symbol at the start of the line, or you can edit the line to make it correct.

    It could be an incorrect UUID (check UUIDs with 'sudo blkid'), a non-existent mount point (make it), etc.

    To edit fstab:
    Code:
    gksu gedit /etc/fstab
    If you can figure it out, post the contents of fstab and the output of "sudo blkid".
    GRUB2

    Retired.

  3. #3
    Join Date
    Mar 2012
    Beans
    130

    Re: (12.04) partition not mounting at boot

    Hi, drs -

    Contents of /etc/fstab:

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc                                       /proc        proc  nodev,noexec,nosuid                                                    0  0  
    # / was on /dev/sda6 during installation
    UUID=2b3a266c-5751-4de4-81c7-72eeb3a9cc15  /            ext4  errors=remount-ro                                                      0  1  
    # swap was on /dev/sda7 during installation
    UUID=c8da4520-a43b-404d-a4a7-d802391a0e62  none         swap  sw                                                                     0  0  
    /dev/sdb2                                  /media/sdb2  ntfs  nls=iso8859-1,ro,users,umask=644,gid=mzimmers,user,owner,uid=mzimmers  0  0
    Output of sudo blkid:
    Code:
    /dev/sda1: LABEL="System Reserved" UUID="AA70CBF170CBC275" TYPE="ntfs" 
    /dev/sda2: UUID="26A2E4FCA2E4D17B" TYPE="ntfs" 
    /dev/sda5: UUID="530c8b1a-5050-4c16-a562-219083d17a00" TYPE="swap" 
    /dev/sda6: UUID="2b3a266c-5751-4de4-81c7-72eeb3a9cc15" TYPE="ext4" 
    /dev/sdb1: UUID="4CFDA2557B6F1A46" TYPE="ntfs" 
    /dev/sdb2: LABEL="Ubuntu backups" UUID="a72e6a43-904e-43c3-8edd-2632481d7735" TYPE="ext2" 
    /dev/zram0: UUID="dd3aaa63-3232-48b8-93ce-967fd543eaf7" TYPE="swap"
    Thanks for the help.

  4. #4
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: (12.04) partition not mounting at boot

    /dev/sdb2 /media/sdb2 ntfs nls=iso8859-1,ro,users,umask=644,gid=mzimmers,user,owner,uid=m zimmers 0 0
    The above entry in your fstab points to sdb2 and tries to mount it as ntfs.

    According to the system, sdb2 is ext2:
    /dev/sdb2: LABEL="Ubuntu backups" UUID="a72e6a43-904e-43c3-8edd-2632481d7735" TYPE="ext2"
    I would make a new mountpoint for it, make yourself the owner of the mountpoint so you 'own' the files once fstab mounts it, and make the following entry in fstab. Of course you can change the mountpoint location/name to anything you want. And I'm assuming your username is mzimmers

    Code:
    sudo mkdir /mnt/ubuntu_backups
    sudo chown -R mzimmers: /mnt/ubuntu_backups
    Change the sdb2 fstab entry to:
    UUID=a72e6a43-904e-43c3-8edd-2632481d7735 /mnt/ubuntu_backups ext2 defaults,users,auto 0 2
    Once you have made the change and saved the file, test to see if it mounts.
    Code:
    sudo umount /dev/sdb2  # Note it may not be mounted and the command will say so
    sudo mount -a # Attempts to mount all fstab entries. It will complain if one or more won't work
    GRUB2

    Retired.

  5. #5
    Join Date
    Mar 2012
    Beans
    130

    Re: (12.04) partition not mounting at boot

    OK, we have at least partial success here. I no longer get the error upon starting, but the partition doesn't seem to be mounted.

    New contents of /etc/fstab:

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc                                       /proc        proc  nodev,noexec,nosuid                                                    0  0  
    # / was on /dev/sda6 during installation
    UUID=2b3a266c-5751-4de4-81c7-72eeb3a9cc15  /            ext4  errors=remount-ro                                                      0  1  
    # swap was on /dev/sda7 during installation
    UUID=c8da4520-a43b-404d-a4a7-d802391a0e62  none         swap  sw                                                                     0  0  
    UUID=a72e6a43-904e-43c3-8edd-2632481d7735 /mnt/ubuntu_backups ext2 defaults,users,auto 0 2
    The mount command doesn't return an error, by the way, but the drive doesn't show up in my file system browser, so I must have done something incorrectly.

  6. #6
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: (12.04) partition not mounting at boot

    Does the "mount" command display the partition as mounted?

    What happens if you run this command, which should open the partition in a file browser:
    Code:
    nautilus /mnt/ubuntu_backups &
    If there is a permission issue, try the same preceeded by "gksu".
    GRUB2

    Retired.

  7. #7
    Join Date
    Dec 2009
    Beans
    5,542

    Re: (12.04) partition not mounting at boot

    Excuse the interruption but there's something odd here. It shouldn't have affected the mounting of /mnt/ubuntu_backup but this line in fstab references a partition that doesn't exist:
    UUID=c8da4520-a43b-404d-a4a7-d802391a0e62 none swap sw 0 0
    Swap isn't mounted in the conventional sense but I'm wondering if it's stopping the execution of the next line in fstab.

    Since there are so many changes being made to the partitions you might want to re-verify the UUID numbers by running blkid another way:
    Code:
    sudo blkid -c /dev/null

  8. #8
    Join Date
    Mar 2012
    Beans
    130

    Re: (12.04) partition not mounting at boot

    drs: the nautilus command works fine -- opens a window where I can see what I'd expect to see. BUT: inside /media/sdb2 there's nothing (that I can see from the GUI).

    Morbius: the results of "sudo blkid -c /dev/null are:

    Code:
    mzimmers@mzimmers-desktop:~$ sudo blkid -c /dev/null
    [sudo] password for mzimmers: 
    /dev/sda1: LABEL="System Reserved" UUID="AA70CBF170CBC275" TYPE="ntfs" 
    /dev/sda2: UUID="26A2E4FCA2E4D17B" TYPE="ntfs" 
    /dev/sda5: UUID="530c8b1a-5050-4c16-a562-219083d17a00" TYPE="swap" 
    /dev/sda6: UUID="2b3a266c-5751-4de4-81c7-72eeb3a9cc15" TYPE="ext4" 
    /dev/sdb1: UUID="4CFDA2557B6F1A46" TYPE="ntfs" 
    /dev/sdb2: LABEL="Ubuntu backups" UUID="a72e6a43-904e-43c3-8edd-2632481d7735" TYPE="ext2" 
    /dev/zram0: UUID="b6b77824-eec0-4524-9ab9-0a17e5be0b0d" TYPE="swap"
    I may have messed up something when I was fiddling with swap spaces awhile back.

    Thanks...

  9. #9
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: (12.04) partition not mounting at boot

    Quote Originally Posted by mzimmers View Post
    drs: the nautilus command works fine -- opens a window where I can see what I'd expect to see. BUT: inside /media/sdb2 there's nothing (that I can see from the GUI).

    Morbius: the results of "sudo blkid -c /dev/null are:

    Code:
    mzimmers@mzimmers-desktop:~$ sudo blkid -c /dev/null
    [sudo] password for mzimmers: 
    /dev/sda1: LABEL="System Reserved" UUID="AA70CBF170CBC275" TYPE="ntfs" 
    /dev/sda2: UUID="26A2E4FCA2E4D17B" TYPE="ntfs" 
    /dev/sda5: UUID="530c8b1a-5050-4c16-a562-219083d17a00" TYPE="swap" 
    /dev/sda6: UUID="2b3a266c-5751-4de4-81c7-72eeb3a9cc15" TYPE="ext4" 
    /dev/sdb1: UUID="4CFDA2557B6F1A46" TYPE="ntfs" 
    /dev/sdb2: LABEL="Ubuntu backups" UUID="a72e6a43-904e-43c3-8edd-2632481d7735" TYPE="ext2" 
    /dev/zram0: UUID="b6b77824-eec0-4524-9ab9-0a17e5be0b0d" TYPE="swap"
    I may have messed up something when I was fiddling with swap spaces awhile back.

    Thanks...
    First, youir swap entry in fstab should have the UUID in red, as the one in fstab is incorrect. (Hat tip Moribus1).

    There is nothing inside /media/sdb2 because the partition is no longer mounted there.

    If the /mnt/ubuntu_backups folder doesn't show in your file browser's side pane, you can probably drag it into the Shortcuts section of the side pane you you can click on 'ubuntu_backups' to see the contents of the sdb2 partition.
    GRUB2

    Retired.

  10. #10
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: (12.04) partition not mounting at boot

    Quote Originally Posted by mzimmers View Post
    drs: the nautilus command works fine -- opens a window where I can see what I'd expect to see. BUT: inside /media/sdb2 there's nothing (that I can see from the GUI).

    Morbius: the results of "sudo blkid -c /dev/null are:

    Code:
    mzimmers@mzimmers-desktop:~$ sudo blkid -c /dev/null
    [sudo] password for mzimmers: 
    /dev/sda1: LABEL="System Reserved" UUID="AA70CBF170CBC275" TYPE="ntfs" 
    /dev/sda2: UUID="26A2E4FCA2E4D17B" TYPE="ntfs" 
    /dev/sda5: UUID="530c8b1a-5050-4c16-a562-219083d17a00" TYPE="swap" 
    /dev/sda6: UUID="2b3a266c-5751-4de4-81c7-72eeb3a9cc15" TYPE="ext4" 
    /dev/sdb1: UUID="4CFDA2557B6F1A46" TYPE="ntfs" 
    /dev/sdb2: LABEL="Ubuntu backups" UUID="a72e6a43-904e-43c3-8edd-2632481d7735" TYPE="ext2" 
    /dev/zram0: UUID="b6b77824-eec0-4524-9ab9-0a17e5be0b0d" TYPE="swap"
    I may have messed up something when I was fiddling with swap spaces awhile back.

    Thanks...
    First, youir swap entry in fstab should have the UUID in red, as the one in fstab is incorrect. (Hat tip Moribus1).

    There is nothing inside /media/sdb2 because the partition is no longer mounted there.

    If the /mnt/ubuntu_backups folder doesn't show in your file browser's side pane, you can probably drag it into the Shortcuts section of the side pane you you can click on 'ubuntu_backups' to see the contents of the sdb2 partition.

    If you want the partition to show in the upper part of the side pane you will probably have to create a new mountpoint in /media and make that change in fstab as well. I know the Ubuntus of long ago would automatically place /media folders in the upper pane but not those in /mnt. Don't know if that is still true today or not.
    GRUB2

    Retired.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •