Results 1 to 6 of 6

Thread: Screen won't show after suspend - Asus A52F

  1. #1
    Join Date
    Aug 2011
    Location
    Southampton
    Beans
    96
    Distro
    Ubuntu 13.04 Raring Ringtail

    Screen won't show after suspend - Asus A52F

    Hi

    I often suspend my laptop by shutting the lid, and it has an intermittent problem with restarting. It does restart (I will qualify what I mean by this in a second) but it won't show anything on the screen. When I say it restarts, my guess is that it is fully functioning, since I can see a cursor and move it, which changes according to what it is over, and I have also managed to shut down by guessing where to click.

    I can access tty1-6 fine, so if anyone knows a work around whereby I can go to one of these and restart X or something that would be grand.

    I haven't been able to spot any sort of pattern as to when it happens with regards to power supply, programs running etc. It doesn't seem to happen if I suspend from the menu, but I haven't tried this enough to confirm whether it is the case for sure.

    Any help would be much appreciated

    edit: I am running 12.04
    Last edited by joetait; June 9th, 2012 at 10:54 AM.

  2. #2
    Join Date
    Jun 2008
    Location
    Malaysia
    Beans
    140
    Distro
    Ubuntu 12.04 Precise Pangolin

    Cool Re: Screen won't show after suspend - Asus A52F

    I share in the same issue.

    Case Scenario
    Whenever, the lid is closed (my laptop is set to DO NOTHING on Lid Close) my system get a 'white-screen-panic'-- It starts with blackout and gracefully moves through to all-white screen in a span of 10secs or thereabout.
    Scenario End

    In Ubuntu 11.04 & 11.10, I solved the issue using the suspend script on this page, but now, that don't work anymore.

    It's personally saddening, I use my laptop for presentation everyday (cause I lecture) and use it almost 24 hours. It's painful to know that I HAVE to shutdown every now and then to avoid the 'white-screen-panic'. It's awful!

    Attempts/Discoveries
    • While using Unity 2D, this issue is taken care of (suggesting, it's got something to do with OpenGL or Compiz etc.) I tried Gnome Shell, the WSP showed up still.
    • I also discovered that if I left the lid closed for a bit longer time, it might in many cases work when I open the lid (This, I guess has worked 40% of the times :'( )
    • This issue also persists when Ubuntu tries to switch screens between projector and system screen. Interestingly, plugging the projector (VGA) cable back works on the projector but not on the system's display.


    My system's info
    Code:
    ikon@P34CE2:~$ lsb_release -a
    No LSB modules are available.
    Distributor ID:	Ubuntu
    Description:	Ubuntu 12.04 LTS
    Release:	12.04
    Codename:	precise
    
    ikon@P34CE2:~$ uname -ar 
    Linux P34CE2 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
    • Graphics card: Optimus Nvidia Geforce GT540M CUDA
    • Model No.: U41SV Asus


    If additional info is required, we'll be willing to give.

    Thanks
    "The collection of people, hardware, and software --Internet.
    Let us assume for a moment that such a network has been formed." - J. C. R. Licklider, Robert Taylor, 1968.
    Linux Registered User #511228! Ubuntu Registered User #31414

  3. #3
    Join Date
    Jun 2012
    Beans
    3

    Re: Screen won't show after suspend - Asus A52F

    I've been having the same problem with my AOD150. When it enters suspended mode while open, no problem works fine, but whenever the lid closes the screen won't reactivate except as a momentary blip when I move the cursor or type something.

  4. #4
    Join Date
    Jun 2012
    Beans
    1

    Re: Screen won't show after suspend - Asus A52F

    I have the smane problem with this Ubuntu version 11.10 running on a ASUS K52F P6100

  5. #5
    Join Date
    Dec 2007
    Location
    /bin
    Beans
    180

    Re: Screen won't show after suspend - Asus A52F

    I had a similar issue with an Asus 1225B; I solved it by removing fgrlx and using the radeon driver. Hope that helps.
    freedom, forever

  6. #6
    Join Date
    Apr 2006
    Beans
    240
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Screen won't show after suspend - Asus A52F

    I have a system 76 running 12.04 with an Intel Graphics 4000 chip that does the same thing. Try using the shutdown menu and choose suspend instead of closing the lid. I had some success with that.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •