Results 1 to 10 of 11

Thread: Wireless/NetworkManager won't auto-connect!

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Location
    Oakland, CA
    Beans
    65
    Distro
    Ubuntu

    Wireless/NetworkManager won't auto-connect!

    Hello,

    I have a WPA router. I can connect fine using the default tool in the top panel (nm-applet, I think). However, even after editing the connection in settings, it will not auto-connect. Instead, every time I reconnect/reboot, a new profile is created and I must re-enter the wireless password. Any clues why NetworkManager is not using the saved profile to auto-connect? I have seriously over 20 profiles in /etc/NetworkManager/system-connections (yes, I've tried deleting all profiles (via GUI and CLI) and starting over). Also, at some point I would like to be able to use static IP, but if profiles can't be saved I'm SOL.

    I know I could use WICD et al but if there's an easy fix to make the default work, that would be swell.

    Thanks folks!
    Every hour my servant takes my temperature and gives me another.

  2. #2
    Join Date
    Feb 2006
    Location
    Oakland, CA
    Beans
    65
    Distro
    Ubuntu

    Angry Re: Wireless/NetworkManager won't auto-connect!

    Bump #1.
    Every hour my servant takes my temperature and gives me another.

  3. #3
    Join Date
    Apr 2012
    Beans
    5,954

    Re: Wireless/NetworkManager won't auto-connect!

    what happens when you try to save the connection? does it ask for authentication (sudo)? does it actually create a new file in the /etc/NetworkManager/system-connections/ directory?

  4. #4
    Join Date
    Feb 2006
    Location
    Oakland, CA
    Beans
    65
    Distro
    Ubuntu

    Re: Wireless/NetworkManager won't auto-connect!

    Hi, thanks for answering!

    It does not ask me to authenticate when I check the boxes for "Connect automatically" and "Available to all users." In fact I am never asked for my keyring password or to authenticate as root/sudo/whatever. The only password I am asked for is the wireless password, which I have to enter every time I select my wireless AP from the applet (which I must do every time I want to connect to it, auto-connect is not happening). And yet, /etc/NetworkManager/system-connections now contains 12 profiles (all of which say the same thing).

    I don't know which behavior I'm most disturbed by, the lack of fucntionality or the writing to a supposedly root-owned folder without asking permission. Happy to furnish further details.
    Every hour my servant takes my temperature and gives me another.

  5. #5
    Join Date
    Feb 2006
    Location
    Oakland, CA
    Beans
    65
    Distro
    Ubuntu

    Re: Wireless/NetworkManager won't auto-connect!

    Bump #2
    Every hour my servant takes my temperature and gives me another.

  6. #6
    Join Date
    Feb 2006
    Location
    Oakland, CA
    Beans
    65
    Distro
    Ubuntu

    Re: Wireless/NetworkManager won't auto-connect!

    Bump #3. Willing to try anything/provide any info.
    Every hour my servant takes my temperature and gives me another.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •