Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: CIFS, autofs - doesn't work on 12.04, but worked on 10.04!

  1. #11
    Join Date
    Mar 2007
    Beans
    82
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: CIFS, autofs - doesn't work on 12.04, but worked on 10.04!

    OK now I feel pretty silly because it just got working again, and I have no idea how. The only thing that I changed in the last hour is starting Ubuntu One (where my configuration files are) but I was accessing them locally and even modified the files by trying to put the options at the end of the line as suggested by papibe. So that I don't get it.

    I'll try to figure out if I changed anything else in between (possible as I'm reinstalling that computer). Sorry for the false problem... although I'm happy it got resolved


    -------------------------------------
    keeping my answers in case, and thanks redmk2 for helping me out:

    Quote Originally Posted by redmk2 View Post
    Are you running NIS and mounting a home directory? Did you look at the bug reports?
    I am not mounting a home directory, but several networks shares. I looked quickly at the bug reports you sent but they all seem to be about autofs not starting properly. I did google and search forums etc but didn't find any relevant issue - this thread is the closest to my problem.

    I don't have ypbind/nis (not installed). I guess those are related to the ypbind error of uusrs but because (s)he said "I guess ypbind problem is not necessary the reason because manual mount command works. And exactly the same autofs settings worked on Ubuntu 10.04!" I thought there was a very good chance we had the same problem, that would have nothing to do with ypbind.

  2. #12
    Join Date
    Jun 2012
    Beans
    6

    Re: CIFS, autofs - doesn't work on 12.04, but worked on 10.04!

    Quote Originally Posted by papibe View Post
    Hi uusrs.

    After a quick look to your first post, it looks like you are not using the proper syntax for the auto.uusrs file. The mount options should be on the end of the line.

    Could you post both autofs files, but now using code tags so we can take a detail look at them?

    Regards.
    Hi papibe and everybody reading/responding to the thread. Thank you for your help!

    Here is the content of /etc/auto.master:
    Code:
    +auto.master
    /home/uusrs/@  /etc/auto.uusrs --timeout=60 --ghost
    /etc/auto.uusrs:
    Code:
    music     -fstype=cifs,credentials=/etc/auto.uusrs.cred,uid=uusrs,gid=uusrs,file_mode=0600,dir_mode=0755     ://192.168.1.11/music
    The directory I'm trying to mount is not a home dir. But I mounted successfully both home and non-home directories in the previous 10.04 configuration. I left only one non-home dir in the config files for simplicity.

    Also, I checked description of ypbind and not sure I really need it to mount shares from this server, because all necessary information is available already in static configs and server is resolvable via DNS,

    Messages like ypbind[857]: broadcast: RPC: Timed out. are really annoying and I prefer not to use unnecessary complexities if possible and turn off ypbind. May one do it in this config?

    Thank you!

  3. #13
    Join Date
    Jun 2012
    Beans
    6

    Re: CIFS, autofs - doesn't work on 12.04, but worked on 10.04!

    Hello everybody,

    I found my mistake.

    After I commented "+auto.master" string in /etc/auto.master, autofs mounted the network share successfully.

    Now, the corrected /etc/auto.master is:

    Code:
    /home/uusrs/@  /etc/auto.uusrs --timeout=60 --ghost
    /etc/auto.uusrs is mostly unchanged (I used DNS resolvable name of the server instead of IP address). Both methods work.

    Code:
    music    -fstype=cifs,credentials=/etc/auto.uusrs.cred,uid=uusrs,gid=uusrs,file_mode=0600,dir_mode=0755    ://darkstar/music
    ypbind[857]: broadcast: RPC: Timed out. still in /var/log/syslog but I plan to turn off ypbind since I do not see any need to use it in my network.

    Thank you!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •