Results 1 to 3 of 3

Thread: Unknown encoder 'libfaac'

  1. #1
    Join Date
    Dec 2010
    Beans
    5
    Distro
    Ubuntu

    Unhappy Unknown encoder 'libfaac'

    I can't convert video in Winff. It says Unknown encoder 'libfaac'. This problem happened after update libavcode.I had already Medibuntu Repository added and libavcode-extra-53 installed.
    The output of ffmpeg -formats | grep aac was

    Code:
    ffmpeg version 0.8.3-4:0.8.3-0ubuntu0.12.04.1, Copyright (c) 2000-2012 the Libav developers
      built on Jun 12 2012 16:52:09 with gcc 4.6.3
    *** THIS PROGRAM IS DEPRECATED ***
    This program is only provided for compatibility and will be removed in a future release. Please use avconv instead.
     D  aac             raw ADTS AAC
    Please help.
    Last edited by samaresh; June 21st, 2012 at 11:32 AM.

  2. #2
    Join Date
    Nov 2006
    Beans
    17

    Re: Unknown encoder 'libfaac'

    This may help:

    http://dthatcher.blogspot.com.au/201...faac-from.html

    In short libfaac has been removed from FFmpeg for licensing reasons. So instead of using the following option to encode AAC:
    -acodec libfaac
    Use FFmpeg's experimental encoder instead:
    -acodec aac -strict experimental

  3. #3
    Join Date
    Sep 2006
    Beans
    3,605

    Re: Unknown encoder 'libfaac'

    Quote Originally Posted by samaresh View Post
    I can't convert video in Winff. It says Unknown encoder 'libfaac'. This problem happened after update libavcode.I had already Medibuntu Repository added and libavcode-extra-53 installed.
    Ubuntu has updated its version of libavcode-extra-53; therefore its version number has surpassed what is available from Medibuntu. Either wait for Medibuntu to update its version, or you can go back to what is currently available from Medibuntu. See this post for one method of doing this.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •